在线检测未来函数

飞狐扭曲均线主图指标公式

来源:Internet,编辑:股旁网,2012-07-06

均价:=(C+(H+l)/2*0.382+(c+O)/2*0.618)/2;
X1:=eMA((均价+h)/2,5),COLORWHITE;
X2:=eMA(X1,8),COLORWHITE,LINETHICK2;
X3:=eMA(X2,13),COLORFFF000;
X4:=eMA(X3,21),COLORFFF000,LINETHICK2;
X5:=eMA(X4,34),COLORYELLOW;
X6:=eMA(X5,55),COLORYELLOW,LINETHICK2;
X7:=eMA(X6,89),COLOR7F00FF,LINETHICK2;
多空线:(X3+x4)/2,COLORMAGENTA;
反多空线:=EMA(多空线-(eMA(均价,2)-多空线),2),COLORGRAY,LINETHICK1;
FILLRGN(反多空线>多空线,多空线,反多空线),COLORBLUE;
FILLRGN(反多空线<=多空线,多空线,反多空线),COLOR7F00FF,COLORBROWN;
操盘线:X1,COLORWHITE;
多:X2,COLORWHITE,LINETHICK2;
启动线:X3,COLORFFF000;
生命线:X4,COLORFFF000,LINETHICK2;
行情线:X6,COLORYELLOW,LINETHICK2;
牛熊线:X7,COLOR7F00FF,LINETHICK2;
乾坤线:=EMA(X6-(eMA((均价+c)/2,2)-X6),2);
PARTLINE(乾坤线>X6,X6),COLOR00AA99,LINETHICK2;
{www.gupang.com 股旁网_飞狐股票指标公式}
STICKLINE(OPEN>=CLOSE,HIGH,LOW,0.2,0),colorFFCC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8,0),colorFF9F68;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7,0),colorFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6,0),colorFFAA11;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5,0),colorFFBB11;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,4,0),colorFFCC22;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),colorFFDD22;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2,0),colorFFEE33;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),colorFFFF33;
STICKLINE(CLOSE>OPEN,HIGH,LOW,0.2,0),colorFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),colorCC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0),color3300CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0),color33CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0),color6633CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0),color3333FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),color6633FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),color3366FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),color6666FF;
{K线卖提示}
Qc0:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
stickline(Qc0>=91 AND (CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100>99.9,open,close,3,0),COLOR3366FF;
stickline(Qc0>=91 AND (CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100>99.9,H,L,0.5,0),COLOR3366FF;
{VAR11:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);{ZIG 有未来}
VAR123:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);}
KSD:=IF(O>C,O,C);
VAR12:=IF(TROUGHBARS(KSD,10,1)=1,1,0);
VAR1:=IF(PEAKBARS(KSD,10,1)=1,1,0);
STICKLINE(VAR1,C,O,10,0),COLORYELLOW,LINETHICK2;{高位黄色}
STICKLINE(VAR1,C,O,6,0),COLORGRAY,LINETHICK2;{高位黄色}
STICKLINE(VAR1,H,L,1,0),COLORYELLOW,LINETHICK2;{高位黄色}
STICKLINE(VAR12,C,O,10,0),COLOR9900FF,LINETHICK2;{底位红色}
STICKLINE(VAR12,C,O,6,0),COLORWHITE,LINETHICK2;{底位红色}
STICKLINE(VAR12,H,L,1,0),COLORRED,LINETHICK2;{底位红色}
缺口:=(L>REF(H,1));
不破:=(ALL(L>REF(H,BARSLAST(缺口)+1),BARSLAST(缺口)+1));
STICKLINE(不破,REF(H,BARSLAST(缺口)+1),REF(L,BARSLAST(缺口)),10,1),COLORMAGENTA;
下缺口:=(H<REF(L,1));
不补:=(ALL(H<REF(L,BARSLAST(下缺口)+1),BARSLAST(下缺口)+1));
STICKLINE(不补,REF(L,BARSLAST(下缺口)+1),REF(H,BARSLAST(下缺口)),10,0),COLORGRAY;

飞狐扭曲均线主图指标公式

 

相关文章