在线检测未来函数

大智慧东升看盘主图指标公式

来源:Internet,编辑:股旁网,2012-07-07

VAR6:=HHV(HIGH,34)/LLV(LOW,34);
VAR7:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
VAR8:=MA(VAR7,10);
VAR9:=SMA(VAR8,3,1)/10;
VARB:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
VARC:=HIGH-REF(HIGH,1);
VARD:=REF(LOW,1)-LOW;
VARE:=SMA(IF(VARC>0 AND VARC>VARD,VARC,0),12,1);
VARF:=SMA(IF(VARD>0 AND VARD>VARC,VARD,0),12,1);
VAR10:=VARE*100/VARB;
VAR11:=VARF*100/VARB;
VAR12:=SMA(ABS(VAR11-VAR10)/(VAR11+VAR10)*100,12,1);
VAR13:=(VAR12+REF(VAR12,5))/2;
VAR14:=SUM(HIGH-OPEN,12)/SUM(OPEN-LOW,12)*100;
VAR15:=SUM(MAX(0,HIGH-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW),12)*100;
VAR16:=AMOUNT/VOL/100;
VAR17:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR18:=SUM(AMOUNT,5)/VAR16/100;
VAR19:=SUM(AMOUNT,13)/VAR16/100;
VAR1A:=SUM(AMOUNT,34)/VAR16/100;
VAR1B:=SUM(AMOUNT,209)/VAR16/100;
VAR1C:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);
VAR1D:=VAR1C/CAPITAL;
VAR1E:=VOL/CAPITAL*VAR17+VAR1D*REF(VAR16,1);
CYC5: IF(DATE<9991228,DMA(VAR17,VOL/VAR18),0);
VAR27:DRAWTEXT(CROSS(9,VAR9),HIGH+0.5,'【逃】'),COLORYELLOW;
CYC13: IF(DATE<9991228,DMA(VAR17,VOL/VAR19),0),COLOR59B7FF;
CYC34: IF(DATE<9991228,DMA(VAR17,VOL/VAR1A),0);
VAR2A:=VOL/CAPITAL*100<3;
VAR2B:=100*WINNER(CLOSE)>90;
VAR2C:=VAR2A AND VAR2B;
VAR2D:DRAWTEXT(VAR2C,LOW*0.93,'◇'),COLORYELLOW;
CYC无穷: IF(DATE<9991228,DMA(VAR17,VOL/CAPITAL),0), LINETHICK4, COLORFF0000;
VAR2E:=100*(CLOSE-CYC5)/CYC5;
VAR2F:=100*(CLOSE-CYC13)/CYC13;
VAR30:=100*(CLOSE-CYC34)/CYC34;
VAR31:=100*(CLOSE-CYC无穷)/CYC无穷;
VAR32:=MA(CLOSE,13);
VAR33:=100*(VAR32-REF(VAR32,1))/REF(VAR32,1);
VAR34:=CLOSE-LOW;
VAR35:=HIGH-LOW;
VAR36:=CLOSE-HIGH;
VAR37:=IF(CLOSE>=0,(VAR34/VAR35+VAR36/VAR35)*VOL,(VAR36/VAR35+VAR34/VAR35)*VOL);
VAR38:=SUM(VAR37,10)/10000;
VAR39:=100*(CYC13-REF(CYC13,1))/REF(CYC13,1);
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR3B:=SMA(VAR3A,3,1);
VAR3C:=SMA(VAR3B,3,1);
VAR3D:=3*VAR3B-2*VAR3C;
VAR3E:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR3F:=SMA(VAR3E,5,1);
VAR40:=SMA(VAR3F,10,1);
VAR41:=CROSS(VAR3F,VAR40);
VAR44:=CROSS(VAR40,VAR3F);
VAR47:=CROSS(VAR40,VAR3F);
VAR48:=VAR40>80 OR VAR3F>80;
VAR49:=VAR47 AND VAR48;
VAR4A:=VAR33>0 AND VAR39>0 AND VAR38>0;
VAR4B:=VAR33<0 OR VAR39<0 OR VAR38<0 OR VAR2F<0;
VAR4C:=CLOSE;
VAR4D:=OPEN;
VAR4E:=HIGH;
VAR4F:=LOW;
【晋城】:STICKLINE(VAR4A,VAR4C,VAR4D,8,0),COLORRED;
STICKLINE(VAR4A,VAR4E,MAX(VAR4C,VAR4D),0.0,0),COLORRED;
STICKLINE(VAR4A,MIN(VAR4C,VAR4D),VAR4F,0.0,0),COLORRED;
VAR51:=100*(CLOSE-COST(1))/(COST(99)-COST(1));
VAR52:=100*(CYC无穷-COST(1))/(COST(99)-COST(1));
VAR53:=100*(CLOSE-COST(5))/(COST(95)-COST(5));
VAR54:=100*(CYC无穷-COST(5))/(COST(95)-COST(5));
STICKLINE(VAR4B,VAR4C,VAR4D,8,0),COLORCYAN;
STICKLINE(VAR4B,VAR4E,MAX(VAR4C,VAR4D),0.0,0),COLORCYAN;
STICKLINE(VAR4B,MIN(VAR4C,VAR4D),VAR4F,0.0,0),COLORCYAN;
VAR57:=1.1*CLOSE;
VAR58:=0.9*CLOSE;
VAR59:=100*(WINNER(VAR57)-WINNER(VAR58));
VAR5A:=SUM(VOL,34)/CAPITAL;
VAR5B:=100-100/(1+VAR5A)>0;
VAR5C:=100-100/(1+VAR5A)<34;
VAR5D:=VAR5B AND VAR5C;
VAR5E:=100*VOL/CAPITAL;
VAR5F:=WINNER(CLOSE)*100-WINNER(REF(CLOSE,1))*100;
VAR60:=4;
VAR61:=VAR5F/VAR5E;
VAR62:=VAR5F/VAR5E;
VAR63:=100*(WINNER(CLOSE)-REF(WINNER(CLOSE),VAR60))/5*MA(VAR5E,5);
VAR64:=LLV(LOW,240);
VAR65:=LLV(LOW,480);
VAR66:=100*(CLOSE-VAR65)/VAR65;
VAR67:=100*(CLOSE-VAR64)/VAR64>15;
VAR68:=100*(CLOSE-VAR64)/VAR64<45;
VAR69:=100*(CLOSE-VAR64)/VAR64;
VAR6A:=VAR67 AND VAR68;
VAR6B:=100*(WINNER(CLOSE)-WINNER(OPEN));
VAR6C:=VAR6B;
DRAWTEXT(CROSS(VAR59,88),LOW*0.95,'密'),COLORBROWN;
DRAWTEXT(VAR6C>30 AND VOL/CAPITAL*100>3,LOW,'长阳'),COLORMAGENTA;
VAR73:DRAWTEXT(VAR6C>30 AND VOL/CAPITAL*100<3,LOW,'无量长阳'),COLORRED;
VAR74:=VAR51<25 AND VAR52>50;
VAR75:=VAR59<10 AND VAR2F<-16;
VAR76:=LLV(HIGH,480);
VAR77:=100*(CLOSE-VAR76)/VAR76;
VAR78:=LLV(HIGH,240);
VAR79:=100*(CLOSE-VAR78)/VAR78;
VAR7A:=LLV(HIGH,720);
VAR7B:=100*(CLOSE-VAR7A)/VAR7A;
VAR7C:=VOL/CAPITAL*100;
VAR7F:=VAR38>0 AND VAR39>0 AND VAR3F<30 AND VAR40<30 AND VAR3F>VAR40 AND VAR3B<80 AND VAR3C<80 AND VAR79<45 AND VAR77<45 AND VAR7B<45;
VAR81:=100*WINNER(CLOSE);
VAR82:=VAR2F<-16 AND VAR81>=40;
VAR83:=WINNER(CLOSE)/(VOL/CAPITAL);
VAR84:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
VAR87:=BARSLAST(VAR81<10);
VAR88:=(CLOSE-REF(CLOSE,VAR87))/REF(CLOSE,VAR87)*100<15 AND VAR69<45 AND VAR87<20 AND VAR66<100 AND VAR81>80 AND CYC5>CYC13 AND CYC13>CYC34 AND CYC34>CYC无穷;
DRAWTEXT(VAR49,HIGH*1.03,'逃命!'), COLORYELLOW;
VAR8A:=(VAR2F-LLV(VAR2F,60))/(HHV(VAR2F,60)-LLV(VAR2F,60))*100;
VAR8B:=LLV(LOW,240);
VAR8C:=100*(CLOSE-VAR8B)/VAR8B;
VAR8D:=WINNER(CLOSE)/SMA(VOL/CAPITAL,13,1);
VAR8E:=(CLOSE-LLV(LOW,240))/(HHV(HIGH,240)-LLV(LOW,240))*100;
VAR8F:=(CLOSE-LLV(LOW,480))/(HHV(HIGH,480)-LLV(LOW,480))*100;
VAR90:=100*(1-WINNER(CLOSE));
VAR91:=VAR69<1 AND VAR83<0.3 AND VAR8D<0.3 AND VAR61<0 AND VAR8E<0.5 AND VAR8F<0.5 AND VAR59<1.5 AND VAR51<1 AND VAR8A=0;
VAR92:=IF(VAR91,0,50);
VAR93:=WINNER(CLOSE)*100;
VAR91:=VAR69<1 AND VAR83<0.3 AND VAR8D<0.3 AND VAR61<0 AND VAR8E<0.5 AND VAR8F<0.5 AND VAR59<1.5 AND VAR51<1 AND VAR8A=0;
VAR96:DRAWTEXT(VAR8D>100 and VAR2B,LOW*0.985,'庄股'),COLORYELLOW;
{www.gupang.com 股旁网_大智慧股票指标公式}
DRAWTEXT(VAR7F,LOW*0.88,'▲'), COLORGREEN;
DRAWTEXT(VAR91,LOW-0.5,'【抢钱】'),COLORYELLOW;
Var45:=Var2F<-16 AND WINNER(CLOSE)*100>45;
Var46:DRAWTEXT(Var45,LOW*0.97,'【受伤庄股】');
Var55:=CROSS(Var53,80) AND Var54<60;
Var56:DRAWTEXT(Var55,HIGH,'【锁仓】'),COLORYELLOW;
VarAA:=0.8*CLOSE;
VarAB:=100*WINNER(VarAA);
VarAC:DRAWTEXT(VarAB>20 AND VarAB<30,LOW*0.98,'K23');
VarAD:DRAWTEXT(VarAB>30 AND VarAB<40,LOW*0.98,'K34');
VarAE:DRAWTEXT(VarAB>40 AND VarAB<50,LOW*0.98,'K45');
VarAF:DRAWTEXT(VarAB>50 AND VarAB<60,LOW*0.98,'K56');
VarB0:DRAWTEXT(VarAB>60 AND VarAB<70,LOW*0.98,'K67');
VarB1:DRAWTEXT(VarAB>70 AND VarAB<80,LOW*0.98,'K78');
VarB2:DRAWTEXT(VarAB>80 AND VarAB<90,LOW*0.98,'K89');
VarB3:DRAWTEXT(VarAB>90 AND VarAB<100,LOW*0.98,'K90');

大智慧东升看盘主图指标公式

 

相关文章