在线检测未来函数

通达信回调K线主图指标公式

来源:Internet,编辑:股旁网,2012-07-08

N:=27;
箱顶:EMA(REF(HHV(C,30),1),2),COLORBB5500,LINETHICK2;
箱底:EMA(REF(LLV(C,30),1),2),COLOR9955BB,LINETHICK2;
涨幅:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1),NODRAW,COLORWHITE;
上影幅:=IF(CLOSE>OPEN,100*(H-C)/C,100*(H-O)/O),NODRAW,COLORYELLOW;
下影幅:=IF(CLOSE>OPEN,100*(O-L)/L,100*(C-L)/L),NODRAW,COLORWHITE;
X:=(3*C+L+O+H)/6;
AH1:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+REF(X,20))/210;
CP:=IF(C>REF(C,1),(3*H+4*C+3*OPEN+2*L)/12,(2*H+4*C+3*OPEN+3*L)/12);
AH2:=EXPMEMA(CP,25);
持股线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
VAR2M:=CLOSE*VOL;
VAR3M:=EMA((EXPMA(VAR2M,3)/EXPMA(VOL,3)+EXPMA(VAR2M,6)/EXPMA(VOL,6)+EXPMA(VAR2M,12)/EXPMA(VOL,12)+EXPMA(VAR2M,24)/EXPMA(VOL,24))/4,13);
SDN:=VAR3M*0.94;
涨停B:=(CLOSE>1.1*REF(CLOSE,1)-0.005 AND H>L);
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
跌停:=IF((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),1,0);
STICKLINE(跌停,O,C,2,0),COLORGREEN;
首个涨停:=BARSLAST(涨停B);
大阳:=100*(H-REF(C,1))/REF(C,1)>7;
{www.gupang.com 股旁网_通达信股票指标公式}
{DRAWICON((C>SDN AND 100*(L-持股线)/持股线<1.5 AND 100*(L-((MIN(AH2,AH1)+MIN(持股线,AH2)+MIN(持股线,AH1))/2.95))/((MIN(AH2,AH1)+MIN(持股线,AH2)+MIN(持股线,AH1))/2.95)<1.5 AND (COUNT(大阳,13)>=2 OR 首个涨停<13) AND BARSLAST(大阳)>0 AND 涨幅<=2),L*0.98,38);}
{DRAWTEXT(CLOSE>1.1*REF(CLOSE,1)-0.005,CLOSE*1.02,'停,'),COLORCYAN;}
{DRAWTEXT(CLOSE<0.9*REF(CLOSE,1)+0.005,L*0.98,'停,'),COLORCCCCCC; }
VAR32:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*10;
火:=BARSLAST(EMA(CLOSE,5)<REF(EMA(CLOSE,5),1));
CRXP:=((REF(上影幅,1)>3 AND REF(下影幅,1)<1.15))AND ((下影幅>3 AND 上影幅<1.55)) AND 涨幅<8;
JM:=(3*SMA(SMA(VAR32,2,1),2,1)-2*SMA(SMA(SMA(VAR32,2,1),2,1),3,1));
强势回调:=(首个涨停<14 OR (首个涨停<26 AND 首个涨停>19));
搓揉:=((强势回调 AND CRXP) OR (CRXP AND (JM>REF(JM,1) OR (火>0 AND JM<7))));
DRAWTEXT(搓揉,L*0.98,'搓揉,'),COLORYELLOW;
回调搓合承受价:(MIN(AH2,AH1)+MIN(BBI,AH2)+MIN(BBI,AH1))/2.95,NODRAW;
大盘短期生命线:EMA(((SLOPE(INDEXC,22)*23)+INDEXC),48),COLORYELLOW,LINETHICK3,NODRAW;
回调止赢:HHV(H,X+1)*(1-0.03),COLORYELLOW,POINTDOT,LINETHICK4;
{=============================================================================================================}
M5:=MA(C,5),COLORWHITE;
M10:=MA(C,10),COLORYELLOW;
M20:=MA(C,20),COLORBLUE;
MA30:=MA(C,30),COLORRED,LINETHICK2;
M60:=MA(C,60),COLORFFCC66;
PMA:=MA(C,5);
多空线:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6) +13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12) +7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+REF(X,20))/210,COLORFF00FF,LINETHICK2;
VARZT:=BARSLAST(C/REF(C,1)>1.094);
DRAWTEXT(VARZT=2,L*0.95,'3T'),COLORYELLOW;
DRAWTEXT(VARZT=4,H*1.06,'5T'),COLORYELLOW;
DRAWTEXT(VARZT=7,L*0.95,'8T'),COLORYELLOW;
DRAWTEXT(VARZT=12,H*1.06,'13T'),COLORYELLOW;
DRAWTEXT(VARZT=20,L*0.95,'21T'),COLORYELLOW;
DRAWTEXT(VARZT=33,H*1.06,'34T'),COLORYELLOW;
DRAWTEXT(VARZT=54,L*0.95,'55T'),COLORYELLOW;
DRAWTEXT_FIX(1,0,0,0,'所属板块:'),COLORLIGRAY;
DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK),COLORLIGRAY;
AL2:=ABS((REF(C,1)-(REF(O,1)))/(REF(O,1)));
AL3:=ABS((REF(H,1)-(REF(O,1)))/(REF(O,1)));
AL4:=ABS((REF(L,1)-(REF(O,1)))/(REF(O,1)));
ELE:=(((REF(HIGH,1))+(REF(LOW,1))+(REF(OPEN,1))+2*(REF(CLOSE,1)))/5);
上升突破价:=(ELE+((REF(HIGH,1))-(REF(LOW,1))));
上升阻力价:=(2*ELE-(REF(LOW,1)));
下跌支撑价:=(2*ELE-(REF(HIGH,1)));
下跌反转价:=(ELE-((REF(HIGH,1))-(REF(LOW,1))));
预测低一:=O-(O*(ABS((AL2+AL3+AL4)/3)));
预测低二:=(预测低一+((((ELE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5)+O)/2))/2;
{预测当天最高价公式}
预测高一:=O+(O*(ABS((AL2+AL3+AL4)/3)));
预测高二:=MA(REF(HIGH,1)/REF(CLOSE,2),N)*REF(CLOSE,1);
DRAWTEXT_FIX(1,0.12,0.0,0,'预测高一:'),COLORGREEN;
DRAWNUMBER_FIX(1,0.18,0.0,0,CONST(预测高一)),COLORGREEN;
DRAWTEXT_FIX(1,0.24,0.0,0,'预测高二:'),COLORGREEN;
DRAWNUMBER_FIX(1,0.30,0.0,0,CONST(预测高二)),COLORGREEN;
VARM:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:=IF(CLOSE>OPEN,VARM*(HIGH-LOW),IF(CLOSE<OPEN,VARM*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
DRAWTEXT_FIX(1,0,0.06,0,'预测低一:'),COLORRED;
DRAWTEXT_FIX(1,0,0.12,0,'预测低二:'),COLORRED;
DRAWTEXT_FIX(1,0.25,0.12,0,'系数:'),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.06,0.06,0,CONST(预测低一)),COLORRED;
DRAWNUMBER_FIX(1,0.06,0.12,0,CONST(预测低二)),COLORRED;
DRAWTEXT_FIX(1,0.12,0.06,0,'成交量比:'),COLORLIGRAY;
DRAWTEXT_FIX(1,0.12,0.12,0,'涨停价★:'),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.19,0.12,0,CONST(REF(C,1)+(REF(C,1))/10)),COLORLIGRAY;
DRAWTEXT_FIX(1,0.25,0.06,0,'量比:'),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.19,0.06,0,CONST(买盘/VOL*100)),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.28,0.06,0,CONST(DYNAINFO(17))),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.28,0.12,0,CONST(IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1))),COLORLIGRAY;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF((C<REF(O,1) AND F<0),1,0);
P2:=IF((C<REF(O,2) AND F<0),1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
TT4:=P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0 ;
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
STICKLINE(TT3,OPEN,CLOSE,3,0),COLORDB7093;

通达信回调K线主图指标公式

 

相关文章