在线检测未来函数

通达信趋势顶底主图指标公式

来源:Internet,编辑:股旁网,2012-07-13

对趋势顶底进行优化,加入带有流氓函数的XMA趋势指标,可以直观看出趋势和顶底。起到辅助判断之效。

趋势顶线:SMA(AMOUNT/VOL/100,13,1)*1.15,COLORYELLOW,LINETHICK3;
趋势底线:SMA(AMOUNT/VOL/100,13,1)*0.85,COLORRED,LINETHICK3;
中位:(趋势顶线+趋势底线)/2,LINETHICK3;
{这部分是把一些经典指标的信号表示出来,没什么特别的}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
{www.gupang.com 股旁网_通达信股票指标公式}
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS
("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS
("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWICON(B1>0,L-0.20,5);
DRAWTEXT(B1,L-0.30,'MACD底背'),COLORWHITE;
DRAWICON(B2>0,L-0.20,4);
DRAWTEXT(B2,L-0.30,'KDJ底背'),COLORFF00FF;
DRAWICON(B3>0,L-0.20,3);
DRAWTEXT(B3,L-0.30,'RSI底背'),COLORYELLOW;
LY:=10;
BL:=40;
CJQS:=XMA(CLOSE,LY);
JBQS:=XMA(CLOSE,BL);
N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT);
M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT);
上轨:IF(CURRBARSCOUNT>LY/2,CJQS*1.05,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*1.05),DOTLINE;
下轨:IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*0.95),DOTLINE;
DRAWTEXT(O<=下轨,(L * 0.98),'抢'),COLORYELLOW;
DRAWTEXT(CROSS(H,上轨),(H * 1.01),'逃'),COLORGREEN;
DRAWKLINE(H,O,L,C);

通达信趋势顶底主图指标公式

 

相关文章