在线检测未来函数

通达信简单实用DMI指标公式

来源:Internet,编辑:股旁网,2012-07-14

N:=14;MM:=7;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR,COLORWHITE,LINETHICK1;
MDI: DMM*100/MTR,COLORYELLOW,LINETHICK1;
{www.gupang.com 股旁网_通达信股票指标公式}
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM),COLORWHITE,LINETHICK1,COLORBLUE,LINETHICK1;
ADXR:EXPMEMA(ADX,MM),COLORMAGENTA,LINETHICK1;
DRAWICON(CROSS(PDI,MDI),PDI-0.01,1);
DRAWICON(CROSS(MDI,PDI),PDI-0.01,2);

通达信简单实用DMI指标公式

 

相关文章