在线检测未来函数

飞狐卷珠帘主图指标公式

来源:Internet,编辑:股旁网,2012-07-16

主要优化的内容是明确了压力和支撑位价线,另加了回踩线.当出现红黄线时表示突破了压力位.红黄线消失说明多变空.回踩线采用了回抽压力线到支撑线五分之三的位置.当操盘线下穿支撑线后要坚决离场.

均价:=(C+(C+H+L+O)/4+O)/3;
操盘线:EMA(MA(IF(MA(均价,3)>MA(均价,4),MA((均价+3*H)/4,3),REF(MA((均价+3*L)/4,3),1)),3),5),COLORWHITE,LINETHICK2;
A1:REF(操盘线,1), COLOR8A8A8A;
A2:REF(操盘线,2), COLOR898989;
A3:REF(操盘线,3), COLOR888888;
A4:REF(操盘线,4), COLOR878787;
A5:REF(操盘线,5), COLOR868686;
A6:REF(操盘线,6), COLOR858585;
A7:REF(操盘线,7), COLOR848484;
A8:REF(操盘线,8), COLOR838383;
A9:REF(操盘线,9), COLOR828282;
A10:REF(操盘线,10), COLOR818181;
A11:REF(操盘线,11), COLOR808080;
A12:REF(操盘线,12), COLOR7A7A7A;
A13:REF(操盘线,13), COLOR797979;
A14:REF(操盘线,14), COLOR787878;
A15:REF(操盘线,15), COLOR777777;
A16:REF(操盘线,16), COLOR767676;
A17:REF(操盘线,17), COLOR757575;
A18:REF(操盘线,18), COLOR747474;
A19:REF(操盘线,19), COLOR737373;
A20:REF(操盘线,20), COLOR727272;
A21:REF(操盘线,21), COLOR717171;
A22:REF(操盘线,22), COLOR707070;
A23:REF(操盘线,23), COLOR6A6A6A;
A24:REF(操盘线,24), COLOR696969;
压力:MAX(a1,max(A2,MAX(a3,max(A4,MAX(a5,max(A6,MAX(a7,max(A8,MAX(a9,max(A10,MAX(a11,max(A12,MAX(a13,max(A14,MAX(a15,max(A16,MAX(a17,
max(A18,MAX(a19,max(A20,MAX(a21,max(A22,MAX(a23,A24))))))))))))))))))))))),COLORYELLOW,LINETHICK2;
PARTLINE(操盘线>=压力,操盘线),COLORRED,LINETHICK2;
PARTLINE(操盘线<压力,压力),COLORAAAA00,LINETHICK2;
支撑:MIN(a1,MIN(A2,MIN(a3,MIN(A4,MIN(a5,MIN(A6,MIN(a7,MIN(A8,MIN(a9,MIN(A10,MIN(a11,MIN(A12,MIN(a13,MIN(A14,MIN(a15,MIN(A16,MIN(a17,
MIN(A18,MIN(a19,MIN(A20,MIN(a21,MIN(A22,MIN(a23,A24))))))))))))))))))))))),COLOR00AA99,LINETHICK2;
回踩线:HHV(((3*支撑+2*压力)/5),3),COLOR7F00FF,LINETHICK3;
IF(C>0,回踩线,回踩线),COLORCYAN;
{www.gupang.com 股旁网_飞狐股票指标公式}
STICKLINE(OPEN>=CLOSE,HIGH,LOW,0.2,0),colorFFCC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8,0),colorFF9F68;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7,0),colorFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6,0),colorFFAA11;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5,0),colorFFBB11;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,4,0),colorFFCC22;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),colorFFDD22;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2,0),colorFFEE33;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),colorFFFF33;
STICKLINE(CLOSE>OPEN,HIGH,LOW,0.2,0),colorFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),colorCC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0),color3300CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0),color33CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0),color6633CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0),color3333FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),color6633FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),color3366FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),color6666FF;

飞狐卷珠帘主图指标公式

 

相关文章