在线检测未来函数

通达信锯齿顶底买卖指标公式

来源:Internet,编辑:股旁网,2012-07-19

将图分为强势区,与弱势区,同时标识出底部、大底。及顶部信号等,主要目的是方便大家及时判断走势。还可以利用《红色锯齿》进行快速买卖,运用起来较灵活。图形也很明快、漂亮。

STICKLINE(1,100,50,10,0),COLOR660088;
STICKLINE(1,50,10,10,0),COLOR565656;
STICKLINE(1,10,5,10,0),COLORAA00BB;
STICKLINE(1,5,0,10,0),COLOR0000BB;
N:=3;
VAR01:=MA(HHV(HIGH,485),17);
VAR02:=MA(HHV(HIGH,222),17);
VAR03:=MA(HHV(HIGH,96),17);
VAR04:=MA(LLV(LOW,485),17);
VAR05:=MA(LLV(LOW,222),17);
VAR06:=MA(LLV(LOW,96),17);
VAR07:=MA((VAR04*0.96+VAR05*0.96+VAR06*0.96+VAR01*0.558+VAR02*0.558+VAR03*0.558)/6,17);
VAR08:=MA((VAR04*1.25+VAR05*1.23+VAR06*1.2+VAR01*0.55+VAR02*0.55+VAR03*0.65)/6,17);
VAR09:=MA((VAR04*1.3+VAR05*1.3+VAR06*1.3+VAR01*0.68+VAR02*0.68+VAR03*0.68)/6,17);
VAR10:=MA((VAR07*3+VAR08*2+VAR09)/6*1.738,17);
VAR11:=IF(DATE<=1050531,VAR10,VAR10*DAY);
VAR12:=LOW;
VAR13:=REF(LOW,1);
VAR14:=SMA(ABS(VAR12-VAR13),3,1)/SMA(MAX(VAR12-VAR13,0),N,1)*100;
VAR15:=MA(IF(CLOSE*1.35<=VAR11,VAR14*10,VAR14/10),N);
VAR16:=LLV(LOW,30);
VAR17:=HHV(VAR15,30);
VAR18:=1990831;
VAR19:=IF(DATE<=VAR18,MA(IF(LOW<=VAR16,(VAR15+VAR17*2)/2,0),N),100000000);
VAR20:=(HHV(H,9.8)-C)/(HHV(H,9.8)-LLV(L,9.8))*100;
VAR21:=SMA(VAR20,3,1);
VAR22:=SMA(VAR21,3,1);
VAR23:=3*VAR21-2*VAR22;
VAR24:=IF(VAR23>=100,100,IF(VAR23<=0,0,VAR23));
VAR25:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
VAR26:=100+(-ABS(VAR25));
VAR27:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR28:=SMA(SMA(VAR27,9,4),9,4)/7.77777;
VAR29:=EMA(VAR28,5);
VAR30:=3*VAR28-2*VAR29;
VAR31:=CROSS(VAR30,VAR28) AND VAR28<2.7 AND C>O;
{www.gupang.com 股旁网_通达信股票指标公式}
VAR32:=(CLOSE-LLV(LOW,17))/(HHV(HIGH,17)-LLV(LOW,17))*100;
VAR33:=(CLOSE-LLV(LOW,50))/(HHV(HIGH,50)-LLV(LOW,50))*100;
VAR34:=SMA(SMA(VAR32,3,1),3,1)+3*STD(CLOSE,10);
VAR35:=SMA(VAR33,3,1);
VAR36:=100-((100*((HHV(HIGH,17))-CLOSE))/((HHV(HIGH,17))-(LLV(LOW,17))));
VAR37:=100-(MA(((100*((HHV(HIGH,17))-CLOSE))/((HHV(HIGH,17))-(LLV(LOW,17)))),4));
VAR38:=MA(VAR37,1);
VAR39:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA
((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
建仓:IF(VAR39<5,5,0),COLORFF0000,LINETHICK2;
底部:IF(VAR19>10000 AND VAR19>20000,10,0),COLORFFFF00,LINETHICK4;
超低:IF(VAR19>30000 AND VAR19>30000,20,0),COLORFF0000,LINETHICK4;
卖出警报:IF((VAR24=0),85,100),COLORGREEN,LINETHICK2;
DRAWBAND(卖出警报,RGB(0,0,0),100,RGB(0,240,0));
超短:=IF((VAR36<VAR38),VAR38,VAR36),COLORFF00FF,LINETHICK2;
走势:=(VAR38),COLOR00FFFF,LINETHICK2;
DRAWBAND(走势,RGB(0,180,180),50,RGB(130,130,130));
DRAWBAND(底部,RGB(200,0,180),0,RGB(0,0,0));
DRAWBAND(超低,RGB(240,240,0),0,RGB(0,0,0));
DRAWBAND(建仓,RGB(0,200,240),0,RGB(0,0,0));
DRAWTEXT(CROSS(VAR34,VAR35) AND VAR35<18 AND VAR35>REF(VAR35,1)OR CROSS(VAR35,5),40,'千载难逢'),COLORMAGENTA;
STICKLINE(C>0,100,100,4,0),COLOR00FFFF;
DRAWBAND(超短,RGB(200,0,0),走势,RGB(0,0,0));
走势线:(VAR38),COLORFFFF00,LINETHICK2;
短线:超短,COLOR00BBBB,LINETHICK2;
{短线决策线}
N1:=IF(BARSCOUNT(C)>=8,8,BARSCOUNT(C));
AMOV:=VOL*(C+L+H)/3;
MN:=SUM(AMOV,N1)/SUM(VOL,N1),COLORFF0000,LINETHICK5;
NOTEXT1:IF(C>=MN,50,DRAWNULL),LINETHICK5,COLOR0000FF;
NOTEXT2:IF(C<MN,50,DRAWNULL),LINETHICK5,COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=15,47,'短线决策线'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=15,53,'短线决策线'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=10,25,'弱势区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=10,75,'强势区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=10,2.5,'大底区'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=10,7.5,'底部区'),COLORFFFFFF;

通达信锯齿顶底买卖指标公式

 

相关文章