在线检测未来函数

通达信超级短线优化选股指标公式

来源:Internet,编辑:股旁网,2012-07-22

N:=14;
MM:=6;
SHORT:=12;
LONG:=26;
MID:=9;
N1:=13;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:= DMP*100/MTR;
MDI:= DMM*100/MTR;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=EXPMA(EXPMA(EXPMA(VAR1,4),4),4);
{www.gupang.com 股旁网_通达信股票指标公式}
J:= (VAR2-REF(VAR2,1))/REF(VAR2,1)*100, COLORSTICK;
D:= MA(J,3);
K:= MA(J,1);
VAR22:=CLOSE*VOL;
VAR3:=EMA((EXPMA(VAR22,3)/EXPMA(VOL,3)+EXPMA(VAR22,6)/EXPMA(VOL,6)+EXPMA(VAR22,12)/EXPMA(VOL,12)+EXPMA(VAR22,24)/EXPMA(VOL,24))/4,N1);
SUP:=1.06*VAR3;
SDN:=VAR3*0.94;
VAR4:=EXPMA(CLOSE,9);
LUP:=EXPMA(VAR4*1.14,5);
LDN:=EXPMA(VAR4*0.86,5);
X:=PDI>MDI;
Y:=DIF>DEA;
Z:=CROSS(J,D);
XG:X AND Y AND Z;

通达信超级短线优化选股指标公式

 

相关文章