在线检测未来函数

大智慧西电买卖主图指标公式

来源:Internet,编辑:股旁网,2012-07-23

DRAWGBKlast(c>0,strip(RGB(0,0,255),RGB(0,0,0),0));
{K线}
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,0,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,0,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000088;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR0000AA;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000EE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLOR0000FF;
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
STICKLINE(CROSS(MA(C,2),MA(C,7)),H,C,0.05,0),COLOR0000FF,LAYER0;
STICKLINE(CROSS(MA(C,2),MA(C,7)),C,O,6,0),COLORFF0099,LAYER0 ;
STICKLINE(CROSS(MA(C,2),MA(C,7)),O,L,0.05,0), COLOR0099FF,LAYER0;
XG1:=CROSS(MA(C,7),MA(C,2));
STICKLINE(XG1,H,L,5,0),LINETHICK1,COLORWHITE,LAYER0;
STICKLINE(XG1,H,L,0.2,0),COLORGREEN,LAYER0;
STICKLINE(XG1,O,C,6,0),LINETHICK1,COLORGREEN,LAYER0;
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,6,0),COLORFF00FF,LAYER0;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,6,0),COLORWHITE,LAYER0;
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,6,0),COLOR00CCFF,LAYER0;
FILLRGN(MA(C,2),MA(C,7),MA(C,2)>MA(C,7),RGB(80,0,80),MA(C,2)<MA(C,7),RGB(0,80,0)),LAYER7;
P:=8;
KE:=V*(H-L)/REF(C,1);
KEP:=KE=HHV(KE,P);
KUD:=BARSLAST(KEP);
红平台收:IF(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),IF(KUD=0,C,REF(C,KUD)),0),POINTDOT,COLORYELLOW,LINETHICK0;
红平台低:IF(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),IF(KUD=0,L,REF(L,KUD)),0),POINTDOT,COLORWHITE,LINETHICK0;
回调警戒:IF(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),IF(KUD=0,C-(C-REF(C,1))*0.618,REF(C-(C-REF(C,1))*0.618,KUD)),0),POINTDOT,COLORBLUE,LINETHICK0;
绿平台收:IF(IF(KUD=0,C<REF(C,1),REF(C,KUD)<REF(REF(C,1),KUD)),IF(KUD=0,C,REF(C,KUD)),0),POINTDOT,COLORGREEN,LINETHICK0;
企稳警戒:IF(IF(KUD=0,C<REF(C,1),REF(C,KUD)<REF(REF(C,1),KUD)),IF(KUD=0,C+(REF(C,1)-C)*0.618,REF(C+(REF(C,1)-C)*0.618,KUD)),0),POINTDOT,COLOR0000ff,LINETHICK0;
STICKLINE(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),红平台收,红平台收,7,1),COLORYELLOW,LAYER0;
STICKLINE(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),红平台低,红平台低,7,1),COLORWHITE,LAYER0;
STICKLINE(IF(KUD=0,C>REF(C,1),REF(C,KUD)>REF(REF(C,1),KUD)),回调警戒,回调警戒,7,1),COLORBLUE,LAYER0;
STICKLINE(IF(KUD=0,C<REF(C,1),REF(C,KUD)<REF(REF(C,1),KUD)),绿平台收,绿平台收,7,1),COLORGREEN,LAYER0;
STICKLINE(IF(KUD=0,C<REF(C,1),REF(C,KUD)<REF(REF(C,1),KUD)),企稳警戒,企稳警戒,7,1),COLOR00ff00,LAYER0;
VAR17:=OPEN;
VAR18:=HIGH;
VAR19:=LOW;
VAR20:=CLOSE;
KK:=IF(VAR20>=VAR17 AND (VAR20>=REF(VAR20,1) OR REF(VAR20,1)>=REF(VAR17,1)),1,IF(VAR20<VAR17 AND (VAR20<REF(VAR17,1) OR REF(VAR20,1)<REF(VAR17,1)),-1,0));
明日转折:FLOOR((VAR17+VAR20)/2),COLORYELLOW,LAYER0;
{www.gupang.com 股旁网_大智慧股票指标公式}
西楚霸王:=EMA((351*(EMA(CLOSE,24)-EMA(CLOSE,52))-297*EMA(CLOSE,24)+325*EMA(CLOSE,52))/28,2);
A1:=BARSLAST(CROSS(VAR20,西楚霸王) AND 西楚霸王>=REF(西楚霸王,1) OR VAR20>西楚霸王 AND 西楚霸王>=REF(西楚霸王,1) AND REF(西楚霸王,1)<REF(西楚霸王,2));
A2:=BARSLAST(CROSS(西楚霸王,VAR20) AND 西楚霸王<REF(西楚霸王,1) OR VAR20<西楚霸王 AND 西楚霸王<REF(西楚霸王,1) AND REF(西楚霸王,1)>=REF(西楚霸王,2));
DRAWTEXT(CROSS(A2,A1),VAR19*0.99,'▲'),COLOR00FFFF;
DRAWTEXT(CROSS(A2,A1),VAR19*0.99,'▲'),COLOR00FFFF;
DRAWTEXT(CROSS(A1,A2),VAR18*1.01,'▼'),COLOR00FF00;
DRAWTEXT(CROSS(A1,A2),VAR18*1.01,'▼'),COLOR00FF00;

大智慧西电买卖主图指标公式

 

相关文章