在线检测未来函数

通达信两趋势寻顶底指标公式

来源:Internet,编辑:股旁网,2012-07-24

STICKLINE(C>0,0,10,5,0),COLOR00008A;
STICKLINE(C>0,10,50,5,0),COLOR63006A;
STICKLINE(C>0,50,80,5,0),COLOR657600;
STICKLINE(C>0,80,90,5,0),COLOR00BBBB;
STICKLINE(C>0,90,100,5,0),COLOR79B715;
趋势A:=SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1) ,COLORGREEN,LINETHICK2;
DRAWBAND(趋势A,RGB(110,0,20),50,RGB(60,60,60));
IF(趋势A>REF(趋势A,1), 趋势A,DRAWNULL), COLORRED,LINETHICK2;
趋势B:=SMA(趋势A,3,1),COLOR00FFFF, LINETHICK2;
QSA:趋势A;
QSB:趋势B;
DRAWBAND(QSA,RGB(180,0,0),QSB,RGB(0,150,180));
IF( 趋势A>趋势B,趋势B,DRAWNULL), COLORFF00FF, LINETHICK2;
IF( 趋势A<趋势B,趋势B,DRAWNULL) ,COLORFFFF00,LINETHICK2;
{www.gupang.com 股旁网_通达信股票指标公式}
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
拐点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(拐点=1,49,51,4,0),COLORFF00FF;
STICKLINE(拐点=0,49,51,4,0),COLORCYAN;
VR2:=REF(LOW,1);
VR3:=SMA(ABS(LOW-VR2),3,1)/SMA(MAX(LOW-VR2,0),3,1)*100;
VR4:=EMA(IF(CLOSE*1.3,VR3*10,VR3/10),3);
VR5:=LLV(LOW,30);
VR6:=HHV(VR4,30);
VR7:=IF(MA(CLOSE,58),1,0);
VR8:=EMA(IF(LOW<=VR5,(VR4+VR6*2)/2,0),3)/618*VR7;
VR9:=IF(VR8>100,100,VR8);
关注主力:IF(VR9>-150,VR9,0),COLORFF00FF,LINETHICK2;
洗盘:IF(VR9<REF(VR9,1),VR9,0),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(趋势A,趋势B),趋势A,13);
DRAWICON(CROSS(趋势B,趋势A),趋势B,14);
DRAWICON(CROSS(90,趋势A),98,12);
STICKLINE(趋势A>=90,102,112,1,0),COLOR00FFFF;
STICKLINE(趋势A>=80,102,107,1,0),COLORFFFF00;
STICKLINE(趋势A<=10,-1,-7,1,0),COLOR0000FF;
STICKLINE(C>0,90,90,2,0),COLORDDDDDD;
STICKLINE(C>0,80,80,2,0),COLORDDDDDD;
STICKLINE(C>0,10,10,2,0),COLOR00DDDD;
DRAWTEXT(CURRBARSCOUNT=38,8,'底部区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,35,'反弹区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,70,'强势区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,87,'风险区'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=38,97,'逃顶区'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=38,104,'风险提示'),COLORFFFF00;
DRAWTEXT(CURRBARSCOUNT=38,110,'逃顶警示'),COLOR00FFFF;

通达信两趋势寻顶底指标公式

 

相关文章