在线检测未来函数

把 航海家主图指标出(笑脸)预警

来源:Internet,编辑:股旁网,2012-07-01

编写要求:

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6; 牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,colorFFFF; 马线:MA(牛线,6),colorFF; 五日线:MA(CLOSE,5),POINTDOT,color1; 水平面:MA(CLOSE,60),POINTDOT,colorFFFF; VAR2:=1; VAR3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),18)/4; VAR4:=IF(1,IF(VAR3>23.16,VAR3,0),0); VAR5:=VAR3<10; VAR6:=VAR3<2; VAR7:=VAR5 OR VAR6; DRAWICON(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.98,1); DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,2); DRAWICON(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*1.02,1); A1:=MA(CLOSE,23); A2:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)REF(CLOSE,1) AND REF(CLOSE,1)REF(CLOSE,1) AND REF(CLOSE,1)=A1 AND (A2 OR A3 OR A4),LOW,'追涨'),colorFFFFFF;

股旁网解答:

 CROSS(ZIG(3,10) AND CROSS(REF(ZIG(3,10),1);

相关文章