在线检测未来函数

把这3个指标合成1个指标显示

来源:Internet,编辑:股旁网,2012-07-02

编写要求:

VAR9:=CLOSE-REF(CLOSE,5); VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5); VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20); 卖出:=IF(VARA>0 AND CROSS(VARC,VARA),00,100); 买线:=EMA(CLOSE,20); 卖线:=EMA(SLOPE(CLOSE,21)*5+CLOSE,20); 买入:CROSS(买线,卖线)COLORYELLOW; A1:=REF(CLOSE,2); A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100; AA:=(CLOSE-LLV(LOW,23))/(HHV(HIGH,23)-LLV(LOW,23))*100; BB:=MA(AA,10); 趋势线:=SMA(BB,3,1)/10; 底部线:=(HHV(HIGH,34)/LLV(LOW,34)); 进入底部:IF(CROSS(底部线,趋势线),2,0); 冲出底部:IF(CROSS(趋势线,底部线),2,0); VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,6,1)- 3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1; VAR2:8,COLORGREEN,LINETHICK0; 增强体力: IF(CROSS(VAR1,VAR2),50,1),STICK,LINETHICK2; DRAWTEXT(CROSS(VAR1,VAR2),40,'买入'); VARO5:=LLV(LOW,13); VARO6:=HHV(HIGH,34); VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*3,4)*25;

股旁网解答:

 VAR9:=CLOSE-REF(CLOSE,5); 

VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5); 
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20); 
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),00,100); 
买线:=EMA(CLOSE,20); 
卖线:=EMA(SLOPE(CLOSE,21)*5+CLOSE,20); 
买入:CROSS(买线,卖线)COLORYELLOW;
 
A1:=REF(CLOSE,2);
A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100;
AA:=(CLOSE-LLV(LOW,23))/(HHV(HIGH,23)-LLV(LOW,23))*100;
BB:=MA(AA,10);
趋势线:=SMA(BB,3,1)/10;
底部线:=(HHV(HIGH,34)/LLV(LOW,34));
进入底部:IF(CROSS(底部线,趋势线),2,0);
冲出底部:IF(CROSS(趋势线,底部线),2,0);
N:=27;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,6,1)-  
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1;   
增强体力: IF(CROSS(VAR1,8),2,0),STICK,LINETHICK2;  
DRAWTEXT(CROSS(VAR1,8),2.2,'买入');  
 
 

相关文章