在线检测未来函数

将通达信 缠论公式中出现(买入-----下破止损)时设为选股

来源:Internet,编辑:股旁网,2012-07-08

编写要求:

请老师将通达信 西电缠论公式中出现(买入-----下破止损)信号时设为选股 谢谢 在线等帮忙 MA5:=MA(C,5); MA13:=MA(C,13); MA21:=MA(C,21); MA34:=MA(C,34); MA55:=MA(C,55); MA89:=MA(C,89); MA144:=MA(C,144); MA233:=MA(C,233); TMP1:=IF(C>MA5,1,0); TMP2:=IF(C>MA13,1,0); TMP3:=IF(C>MA21,1,0); TMP4:=IF(C>MA34,1,0); TMP5:=IF(C>MA55,1,0); TMP6:=IF(C>MA89,1,0); TMP7:=IF(C>MA144,1,0); TMP8:=IF(C>MA233,1,0); 缠论强度:TMP1+TMP2+TMP3+TMP4+TMP5+TMP6+TMP7+TMP8+1,NODRAW; F:=100*(C-REF(C,1))/REF(C,1); VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21)))); VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34)); 西点:=CROSS(VAR2,MA(VAR3,6)); 西电:=CROSS(MA(VAR3,6),VAR2); STICKLINE(西点,OPEN,CLOSE,3,0),COLOR22FFFF; STICKLINE(西电,OPEN,CLOSE,3,0),COLORGREEN; DRAWTEXT(西点,O,'▲-买入-----下破止损---'),COLOR22FFFF; STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLORFF00FF; STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLORBLUE; DRAWICON(CROSS(C,MA(C,5)),MA(C,5),1); DRAWICON(CROSS(MA(C,5),C),MA(C,5),2);

股旁网解答:

 VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21)))); 

VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34)); 
CROSS(VAR2,MA(VAR3,6)); 

相关文章