在线检测未来函数

操盘手B点 的选股公式

来源:Internet,编辑:股旁网,2012-07-09

编写要求:

操盘手 BOLL:MA(CLOSE,20); UB:BOLL+2*STD(CLOSE,20); LB:BOLL-2*STD(CLOSE,20); A0:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)); B0:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1); PM:MA(C,5),COLORFFFFCC,LINETHICK1; IF(PM>REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2; IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED; IF(PM MA(VAR3,6),LOW,HIGH,0,1),COLORRED; STICKLINE(((OPEN>CLOSE)AND(VAR2CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,(CLOSE-0.03),3.05,0),COLORRED; STICKLINE(((OPENMA(VAR3,6))),OPEN,CLOSE,3.05,1),COLORRED; DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.02)),7); DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.02)),8); PT:=REF(H,1)-REF(L,1); CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4; AH:=CDP+PT; AL:=CDP-PT; NH:=CDP*2-REF(L,1); NL:=CDP*2-REF(H,1); 强:IF(AH>REF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW; 阻:IF(NH>强,(强-CDP)*0.618+CDP,NH)NODRAW,COLORBLUE; M:=IF(ALLOW+0.04,4,0); VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3); VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3); VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3); VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3); VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3); VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3); VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3); VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3); VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150); 买1:=VAR10; 买2:=(VAR11+VAR13+VAR15+VAR17); 卖1:=(VAR12+VAR14+VAR16+VAR18); B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW; S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;

股旁网解答:

 VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));

VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
CROSS(VAR2,MA(VAR3,6));

相关文章