在线检测未来函数

RSI底背离选股公式

来源:Internet,编辑:股旁网,2012-07-15

编写要求:

这是一个RSI,KDJ,MACD的背离公式,里面的RSI底背离抄底很准,求RSI底背离选股公式,同时能否做个RSI底背离预警公式,万份感谢!!! A1:=BARSLAST(ref(cross("macd.diff","macd.dea"),1)); B1:=ref(c,A1+1)>c and ref("macd.diff",A1+1)<"macd.diff" and cross("macd.diff","macd.dea"); DRAWTEXT(FILTER(B1>0,5),l-0.38,'MACD底背'),COLORGREEN; A2:=BARSLAST(ref(cross("kdj.k","kdj.d"),1)); B2:=ref(c,A2+1)>c and ref("kdj.k",A2+1)<"kdj.k" and cross("kdj.k","kdj.d"); DRAWTEXT(FILTER(B2>0,5),l-0.39,'KDJ底背'),COLORYELLOW; A3:=BARSLAST(ref(cross("RSI.RSI1","RSI.RSI2"),1)); B3:=ref(c,A3+1)>c and ref("RSI.RSI1",A3+1)<"RSI.RSI1" and cross("RSI.RSI1","RSI.RSI2"); DRAWTEXT(FILTER(B3>0,5),l,'RSI底背'),COLORCYAN; C1:=BARSLAST(ref(cross("macd.dea","macd.diff"),1)); D1:=ref(c,C1+1)"macd.diff" and cross("macd.dea","macd.diff"); DRAWTEXT(FILTER(D1>0,5),h+0.08,'MACD顶背'),COLORwhite; C2:=BARSLAST(ref(cross("kdj.d","kdj.k"),1)); D2:=ref(c,C2+1)"kdj.k" and cross("kdj.d","kdj.k"); DRAWTEXT(FILTER(D2>0,5),h+0.32,'KDJ顶背'),COLORwhite; C3:=BARSLAST(ref(cross("RSI.RSI2","RSI.RSI1"),1)); D3:=ref(c,C3+1)"RSI.RSI1" and cross("RSI.RSI2","RSI.RSI1"); DRAWTEXT(FILTER(D3>0,5),h+0.1,'RSI顶背'),COLORMAGENTA;

股旁网解答:

 a3:=barslast(ref(cross("rsi.rsi1","rsi.rsi2"),1));

b3:=ref(c,a3+1)>c and ref("rsi.rsi1",a3+1)<"rsi.rsi1" and cross("rsi.rsi1","rsi.rsi2");
filter(b3>0,5);
 
 
选股和预警通用的

相关文章