在线检测未来函数

【智策波段淘金】公式改成大智慧的

来源:Internet,编辑:股旁网,2012-07-18

编写要求:

【智策波段淘金】公式改成大智慧的,谢谢老师!!!已解决(感谢:神风神风) {智策波段淘金} 黄线1:EMA((O+C)/2,10),COLORGREEN,LINETHICK2; 黄线2:EMA((O+C)/2,8.5),POINTDOT,COLORGREEN,LINETHICK3; 黄线3:EMA((O+C)/2,6),POINTDOT,COLORGREEN,LINETHICK3; 黄线4:EMA((O+C)/2,4.5),POINTDOT,COLORGREEN,LINETHICK3; 黄线5:EMA((L+H)/2,3),COLORGREEN; IF(黄线1>=REF(黄线1,1),黄线1,DRAWNULL),COLORRED,LINETHICK2; IF(黄线1<=REF(黄线1,1),黄线1,DRAWNULL),COLORGREEN,LINETHICK2; IF(黄线2>=REF(黄线2,1),黄线2,DRAWNULL),POINTDOT,COLORRED,LINETHICK1; IF(黄线2<=REF(黄线2,1),黄线2,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK1; IF(黄线3>=REF(黄线3,1),黄线3,DRAWNULL),POINTDOT,COLORRED,LINETHICK1; IF(黄线3<=REF(黄线3,1),黄线3,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK1; IF(黄线4>=REF(黄线4,1),黄线4,DRAWNULL),POINTDOT,COLORRED,LINETHICK1; IF(黄线4<=REF(黄线4,1),黄线4,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK1; IF(黄线5>=REF(黄线5,1),黄线5,DRAWNULL),COLORRED,LINETHICK1; IF(黄线5<=REF(黄线5,1),黄线5,DRAWNULL),COLORGREEN,LINETHICK1; 强势区:=IF((EVERY(黄线1>=REF(黄线1,1),1)),5,0)COLOR0000FF,LINETHICK3;

股旁网解答:

 

 
黄线1:ema((o+c)/2,10),colorgreen,linethick2;
黄线2:ema((o+c)/2,8.5),pointdot,colorgreen,linethick3;
黄线3:ema((o+c)/2,6),pointdot,colorgreen,linethick3;
黄线4:ema((o+c)/2,4.5),pointdot,colorgreen,linethick3;
黄线5:ema((l+h)/2,3),colorgreen;
 
partline(黄线1,黄线1>=ref(黄线1,1)),colorred,linethick2;
partline(黄线1,黄线1<=ref(黄线1,1)),colorgreen,linethick2;
partline(黄线2,黄线2>=ref(黄线2,1)),pointdot,colorred;
partline(黄线2,黄线2<=ref(黄线2,1)),pointdot,colorgreen;
partline(黄线3,黄线3>=ref(黄线3,1)),pointdot,colorred;
partline(黄线3,黄线3<=ref(黄线3,1)),pointdot,colorgreen;
partline(黄线4,黄线4>=ref(黄线4,1)),pointdot,colorred;
partline(黄线4,黄线4<=ref(黄线4,1)),pointdot,colorgreen;
partline(黄线5,黄线5>=ref(黄线5,1)),colorred;
partline(黄线5,黄线5<=ref(黄线5,1)),colorgreen;
 
强势区:=if((all(黄线1>=ref(黄线1,1),1)),5,0);

相关文章