在线检测未来函数

飞狐神奇均线+变异K线主图指标公式

来源:Internet,编辑:股旁网,2012-08-03

差:=((c-REF(c,1))*0.382+(C-O)*0.618)*0.382;
均价:=(2*C+(C+H+L+O)/4+O)/4;
R:=(2*L+3*均价)/5;R1:=(2*H+3*均价)/5;
CCI:=((R+R1)/2-MA((R+R1)/2,36))/(0.015*AVEDEV((R+R1)/2,36))/4+50;
DRAWGBK(CCI>=25 AND CCI<50,COLORRGB(30,30,30),COLORRGB(130,130,130),1);
DRAWGBK(CCI>=25 AND CCI>REF(CCI,1),COLORRGB(110,95,0),COLORRGB(0,20,0),1);
DRAWGBK(CCI>=50,COLORRGB(110,0,0),COLORRGB(0,0,0),0);
DRAWGBK(CCI>=50 AND CCI<REF(CCI,1),COLORRGB(20,50,50),COLORRGB(30,30,140),1);
DRAWGBK(CCI<25,COLORRGB(0,110,0),COLORRGB(0,0,0),0);
M3:=EMA((R+r1)/2,3);
M5:=EMA((R+r1)/2,5);
M8:=EMA((R+r1)/2,8),COLORWHITE;
M13:=EMA((R+r1)/2,13);
M21:=EMA((R+r1)/2,21),COLORYELLOW;
M34:=EMA((R+r1)/2,34);
M55:=EMA((R+r1)/2,55);
M89:=EMA((R+r1)/2,89);
M144:=EMA((R+r1)/2,144);
M233:=EMA((R+r1)/2,233);
M377:=EMA((R+r1)/2,377);
{www.gupang.com 股旁网_飞狐股票指标公式}
黄金线:Ema((M3+M5+M8+M13+M21+M34+M55)/7,(3+5+8+13+21+34+55)/7),COLORYELLOW,LINETHICK2;
正黄金线:EMA(黄金线+(eMA((R+r1)/2,2)-黄金线),13),COLORAAAA00;
FILLRGN(黄金线<正黄金线,黄金线,正黄金线),COLORBROWN;
FILLRGN(黄金线>正黄金线,黄金线,正黄金线),COLOR00AA99,COLORBLUE;
跟庄线:ma(LLV((R+R1)/2,2),3),COLORWHITE,LINETHICK1;
PARTLINE(SUM((R+R1)/2,2)/2>跟庄线,跟庄线),COLORWHITE,LINETHICK2;
价值线:Ema((M3+M5+M8+M13+M21+M34+M55+M89+M144+M233)/10,(3+5+8+13+21+34+55+89+144+233)/10),COLORRED,LINETHICK2;
乾坤线:=EMA(价值线-(eMA((R+r1)/2,2)-价值线),3),COLORAAAA00;
PARTLINE(价值线<乾坤线,价值线),COLORAAAA00,LINETHICK2;
kX:=IF(STKTYPE=0,(R+R1)/2,AMOUNT/(v*100));
STICKLINE(kX>=CLOSE,HIGH,LOW,0.2,0),colorFFCC00;
STICKLINE(kX>=CLOSE,CLOSE,kX,8,0),colorFF9F68;
STICKLINE(kX>=CLOSE,CLOSE,kX,7,0),colorFF9900;
STICKLINE(kX>=CLOSE,CLOSE,kX,6,0),colorFFAA11;
STICKLINE(kX>=CLOSE,CLOSE,kX,5,0),colorFFBB11;
STICKLINE(kX>=CLOSE,CLOSE,kX,4,0),colorFFCC22;
STICKLINE(kX>=CLOSE,CLOSE,kX,3,0),colorFFDD22;
STICKLINE(kX>=CLOSE,CLOSE,kX,2,0),colorFFEE33;
STICKLINE(kX>=CLOSE,CLOSE,kX,1,0),colorFFFF33;
STICKLINE(C>kX,HIGH,LOW,0.2,0),colorFF;
STICKLINE(CLOSE>kX,CLOSE,kX,8,0),colorCC;
STICKLINE(CLOSE>kX,CLOSE,kX,7,0),color3300CC;
STICKLINE(CLOSE>kX,CLOSE,kX,6,0),color33CC;
STICKLINE(CLOSE>kX,CLOSE,kX,5,0),color6633CC;
STICKLINE(CLOSE>kX,CLOSE,kX,4,0),color3333FF;
STICKLINE(CLOSE>kX,CLOSE,kX,3,0),color6633FF;
STICKLINE(CLOSE>kX,CLOSE,kX,2,0),color3366FF;
STICKLINE(CLOSE>kX,CLOSE,kX,1,0),color6666FF;

飞狐神奇均线+变异K线主图指标公式

 

相关文章