在线检测未来函数

通达信芳香DMI指标公式

来源:Internet,编辑:股旁网,2012-08-03

n:=5;m:=3;
TRTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
{www.gupang.com 股旁网_通达信股票指标公式}
PDI:DMP*100/TRTR;
MDI:DMM*100/TRTR;
DI:IF(PDI>MDI,PDI,MDI),COLORRED;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);

通达信芳香DMI指标公式

 

相关文章