在线检测未来函数

同花顺大机构决策密码指标公式

来源:Internet,编辑:股旁网,2012-08-05

N1:=1;
IF(n1<1)
{
IF(CLOSE>OPEN)
RETURN "阳";
ELSE IF(CLOSE<OPEN)
RETURN "阴";
ELSE IF(CLOSE==OPEN AND OPEN>=CLOSE[1])
RETURN "阳";
ELSE IF(CLOSE==OPEN AND OPEN<=CLOSE[1])
RETURN "阴";
MONEY;
K线换手;
}
IF(n1>0)
{
Var1=MONEY/VOL;
A=SMA(Var1,5,1)-SMA(Var1,55,1);
B=SMA((A-SMA(A,5,1)),5,1);
风险系数:B;
aa:=MA(CLOSE,5);
//{www.gupang.com 股旁网_同花顺股票指标公式}
前非红:=IF(REF(CLOSE,1)<REF(aa,1) OR REF(A,1)<REF(A,2) OR REF(B,1)<REF(B,2),1,2);
当红:=IF(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),1,2);
LOWV1:=LLV(LOW,8);
HIGHV1:=HHV(HIGH,8);
RSV1:=EMA((CLOSE-LOWV1)/(HIGHV1-LOWV1)*100,3);
K11:=EMA(RSV1,3);
D11:=MA(K11,2);
LOWV2:=LLV(LOW,21);
HIGHV2:=HHV(HIGH,21);
RSV2:=EMA((CLOSE-LOWV2)/(HIGHV2-LOWV2)*100,3);
K22:=EMA(RSV2,3);
D22:=MA(K22,2);
V5:=MA(V,5);
V18:=MA(V,18);
IF(V>V5 AND V>V18)
Ll:=6.5;
ELSE Ll:=0;
IF(D11>REF(D11,1))
dx:=2.1;
ELSE dx:=0;
IF(D11<25)
dz:=7.6;
ELSE IF(D11<28)
dz:=6.1;
ELSE IF(D11<31)
dz:=4.6;
ELSE IF(D11<35)
dz:=3.1;
ELSE IF(D11<40)
dz:=1.6;
IF(D22<25)
dz2:=7.6;
ELSE IF(D22<28)
dz2:=6.1;
ELSE IF(D22<31)
dz2:=4.6;
ELSE IF(D22<35)
dz2:=3.1;
ELSE IF(D22<40)
dz2:=1.6;
zz:=Ll+dx+dz+dz2;
MAVOL$0:MA(VOL,2);
MAVOL$1:MA(VOL,5);
MAVOL$2:MA(VOL,20);
RSV1=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
a1=SMA(RSV1,3,1);
b1=SMA(a1,3,1);
e1=3*a1-2*b1;
IF(前非红=1 AND 当红=1 AND zz>16 AND C>O*0.985 AND C>REF(C,1)*0.98)//23
RETURN ("yang");
IF(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1) AND REF(MAVOL$1,1)<MAVOL$1 AND REF(MAVOL$2,1)<MAVOL$2 AND 前非红=1 AND 当红=1 AND b1<80)
RETURN ("buy");
IF(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1))
RETURN ("colorred");
IF(CLOSE<MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1))
RETURN ("colorwhite");
IF(A<REF(A,3) AND B<REF(B,3))
RETURN ("colorgreen");
IF(A>REF(A,1) AND B<REF(B,1))
RETURN ("colorwhite");
IF(A<REF(A,1) AND B>REF(B,1))
RETURN ("colorwhite");
}

同花顺大机构决策密码指标公式

 

相关文章