在线检测未来函数

通达信MACD大杀器指标公式

来源:Internet,编辑:股旁网,2012-08-07

1:将传统的MACD做了微积分除理,并日周同图,对级别的判断更具有优势; 2:分时图使用时,参数可调为0,使画面在最佳效果; 3:在公式中MACD是大小不同级别的趋势,而KJD是节奏,买卖点的把握不用多说,大家明白;

N:3;
0;
WXS:=(10-5)/2;
JGL_DF:=WXS*(EMA(CLOSE,5)-REF(EMA(CLOSE,5),1));{微分}
DIF_J:=EMA(JGL_DF,10);{积分}
DEA_G:=EMA(DIF_J,8);{平滑}
MACD_L:=(DIF_J-DEA_G)*10;
周WXS:=(10-5)/2;
周JGL_DF:=("MACD.DIF#WEEK");
周DIF_J:=("MACD.DIF#WEEK");
周DEA_G:=("MACD.DEA#WEEK");
周MACD_L:=N*(周DIF_J-周DEA_G);
K_DF:=SMA(JGL_DF,3,1)*1,COLORFEDCBA;
D_DF:=SMA(K_DF,3,1),COLOR13F8F9;
J_DF:=3*K_DF-2*D_DF,COLORF813F9;
STICKLINE(周MACD_L>REF(周MACD_L,1) AND 周MACD_L>0,0,周MACD_L,18,0),COLORLIRED;
STICKLINE(周MACD_L<REF(周MACD_L,1) AND 周MACD_L>0,0,周MACD_L,18,0),COLORWHITE;
STICKLINE(周MACD_L>REF(周MACD_L,1) AND 周MACD_L<0,0,周MACD_L,18,0),COLORCYAN;
STICKLINE(周MACD_L<REF(周MACD_L,1) AND 周MACD_L<0,0,周MACD_L,18,0),COLORBLUE;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,-1,0),COLORRED;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,-1,1),COLORLIRED;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,-1,1),COLORWHITE;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,-1,0),COLORCYAN;
{www.gupang.com 股旁网_通达信股票指标公式}
日DIF_J:EMA(JGL_DF,10),COLORRED,LINETHICK2;
日DEA_G:EMA(DIF_J,8),COLORYELLOW,LINETHICK2;
周A:EMA(周DIF_J,5)-EMA(周DEA_G,10),,COLOR1234AA,LINETHICK2;
周B:EMA(周A,8),COLOR338833,LINETHICK2;
K_DFA:SMA(JGL_DF,3,1)*1,COLORFEDCBA,DOTLINE;
D_DFA:SMA(K_DF,3,1),DOTLINE;
J_DFA:3*K_DF-2*D_DF,DOTLINE;
DRAWICON(CROSS(J_DFA,D_DFA),D_DFA,1);
DRAWICON(CROSS(D_DFA,J_DFA),D_DFA,2);
IF(J_DFA>REF(J_DFA,1),J_DFA,DRAWNULL),COLORRED,DOTLINE;
IF(J_DFA<REF(J_DFA,1),J_DFA,DRAWNULL),COLORBLUE,DOTLINE;

通达信MACD大杀器指标公式

 

相关文章