在线检测未来函数

飞狐成本跟庄主图指标公式

来源:Internet,编辑:股旁网,2012-08-08

INPUT:N(8,1,60),M(90,1,300);
均价:=(2*C+(C+H+L+O)/4+O)/4;
R:=(2*L+3*均价)/5;R1:=(2*H+3*均价)/5;
CCI:=((R+R1)/2-MA((R+R1)/2,36))/(0.015*AVEDEV((R+R1)/2,36))/4+50;
DRAWGBK(CCI>=25 AND CCI<50,COLORRGB(30,30,30),COLORRGB(130,130,130),1);
DRAWGBK(CCI>=25 AND CCI>REF(CCI,1),COLORRGB(110,95,0),COLORRGB(0,20,0),1);
DRAWGBK(CCI>=50,COLORRGB(110,0,0),COLORRGB(0,0,0),0);
DRAWGBK(CCI>=50 AND CCI<REF(CCI,1),COLORRGB(20,50,50),COLORRGB(30,30,140),1);
DRAWGBK(CCI<25,COLORRGB(0,110,0),COLORRGB(0,0,0),0);
M3:=EMA(COST(3),3);
M5:=EMA(COST(5),5);
M8:=EMA(COST(8),8),COLORWHITE;
M13:=EMA(COST(13),13);
M21:=EMA(COST(21),21),COLORYELLOW;
M34:=EMA(COST(34),34);
M55:=EMA(COST(55),55);
M89:=EMA(COST(89),89);
M144:=EMA(COST(144),144);
M233:=EMA(COST(233),233);
M377:=EMA(COST(377),377);
M610:=EMA(COST(610),610);
成本线:Ema((M3+M5+M8+M13+M21+M34+M55)/7,
{www.gupang.com 股旁网_飞狐股票指标公式}
(3+5+8+13+21+34+55)/7),COLORYELLOW,LINETHICK2;
跟庄线:IF(DATATYPE=5,EMA(成本线+EMA((eMA((R+R1)/2,2)-成本线),4),N),EMA(成本线+EMA((eMA((R+R1)/2,2)-成本线),4),N/4))COLORAAAA00;
FILLRGN(成本线<跟庄线,成本线,跟庄线),COLORBROWN;
FILLRGN(成本线>跟庄线,成本线,跟庄线),COLOR00AA99,COLORBLUE;
多空线:IF(DATATYPE=5,EMA(成本线+EMA((eMA((R+R1)/2,3)-成本线),6),M),EMA(成本线+EMA((eMA((R+R1)/2,3)-成本线),6),M/4)),COLORWHITE;
压力线:=Ema((M3+M5+M8+M13+M21+M34+M55+M89+M144+M233)/10,(3+5+8+13+21+34+55+89+144+233)/10),COLORRED,LINETHICK2;
kX:=(R+R1)/2;
STICKLINE(kX>=CLOSE,HIGH,LOW,0.2,0),colorFFCC00;
STICKLINE(kX>=CLOSE,CLOSE,kX,8,0),colorFF9F68;
STICKLINE(kX>=CLOSE,CLOSE,kX,7,0),colorFF9900;
STICKLINE(kX>=CLOSE,CLOSE,kX,6,0),colorFFAA11;
STICKLINE(kX>=CLOSE,CLOSE,kX,5,0),colorFFBB11;
STICKLINE(kX>=CLOSE,CLOSE,kX,4,0),colorFFCC22;
STICKLINE(kX>=CLOSE,CLOSE,kX,3,0),colorFFDD22;
STICKLINE(kX>=CLOSE,CLOSE,kX,2,0),colorFFEE33;
STICKLINE(kX>=CLOSE,CLOSE,kX,1,0),colorFFFF33;
STICKLINE(C>kX,HIGH,LOW,0.2,0),colorFF;
STICKLINE(CLOSE>kX,CLOSE,kX,8,0),colorCC;
STICKLINE(CLOSE>kX,CLOSE,kX,7,0),color3300CC;
STICKLINE(CLOSE>kX,CLOSE,kX,6,0),color33CC;
STICKLINE(CLOSE>kX,CLOSE,kX,5,0),color6633CC;
STICKLINE(CLOSE>kX,CLOSE,kX,4,0),color3333FF;
STICKLINE(CLOSE>kX,CLOSE,kX,3,0),color6633FF;
STICKLINE(CLOSE>kX,CLOSE,kX,2,0),color3366FF;
STICKLINE(CLOSE>kX,CLOSE,kX,1,0),color6666FF;

飞狐成本跟庄主图指标公式

 

相关文章