在线检测未来函数

大智慧DMI金死叉指标公式

来源:Internet,编辑:股旁网,2012-08-12

1. +DI上交叉-DI时作买。 2. +DI下交叉-DI时作卖。 3. ADX于50以上向下转折时,代表市场趋势终了。 4. 当ADX滑落到_+DI之下时,不宜进场交易。 5. 当ADXR介于20-25时,宜采用TBP及CDP中之反应秘诀为交易参考。

N:=14;M:=6;ADXP:=1;
TR:= SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),N);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),N);
PDI: DMP*100/TR;
MDI: DMM*100/TR;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:(ADX+REF(ADX,M))/2;
CD0:20;
CD1:40;
TD0:60;
TD1:80;
DRAWTEXT(CROSS( PDI,CD0), CD0,'★金'), COLORMAGENTA ;
{www.gupang.com 股旁网_大智慧股票指标公式}
DRAWTEXT(CROSS( TD0,PDI), PDI,'★死'), COLORBLUE;
DRAWTEXT(CROSS( ADX,CD0), CD0,'★金'), COLORMAGENTA;
DRAWTEXT(CROSS( TD0,ADX), ADX,'★死'), COLORBLUE;
DRAWTEXT(CROSS( PDI,MDI), MDI,'★金'), COLORYELLOW ;
DRAWTEXT(CROSS( MDI,PDI), PDI,'★死'), COLORGREEN;
DRAWTEXT(CROSS( ADX,ADXP), ADXP,'★金'), COLOR000999 ;
DRAWTEXT(CROSS( ADXP,ADX), ADX,'★死'), COLORCYAN;
DRAWTEXTABS(0,5,'PDI线上穿20介入,下破60急出手。'),COLORBLUE;
DRAWTEXTABS(0,20,'ADX线上穿20介入,下破60急出手。'),COLORCYAN;

大智慧DMI金死叉指标公式

 

相关文章