在线检测未来函数

通达信云端短线主图指标公式

来源:Internet,编辑:股旁网,2012-08-17

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
N1:=7;
VAR1:=REF(C,1);
VAR2:=SMA(MAX(C-VAR1,0),N1,1)/SMA(ABS(C-VAR1),N1,1)*1000;
VAR3:=DRAWLINE(VAR2>=HHV(VAR2,N1),VAR2,VAR2<=LLV(VAR2,N1),VAR2,1);
VAR4:=VAR2=VAR3;
VAR5:=VAR2<REF(VAR2,1);
RSV:=(C-LLV(L,25))/(HHV(HIGH,25)-LLV(L,25))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
VAR6:=(2*C+H+L)/3;
VAR7:=EMA(EMA(EMA(VAR6,4),4),4);
VAR8:=(VAR7-REF(VAR7,1))/REF(VAR7,1)*100;
VAR9:=MA(VAR8,3)+0.03;
VAR10:=MA(VAR8,1);
KB:=EMA(C,3)-EMA(C,18);
DB:=EMA(KB,3);
AA:=BARSCOUNT(C);
AH:=HHV(H,120);
AL:=LLV(L,120);
A0:=(AH-AL)/30;
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
散:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄:=EMA(0.667*REF(散,1)+0.333*散,2)*VAR3S;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,3.2,0),COLOR004400;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,2.7,0),COLOR006600;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,2.1,0),COLOR008800;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,1.5,0),COLOR00AA00;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,0.9,0),COLOR00CC00;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,0.3,0),COLOR00EE00;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,3.2,0),COLOR000055;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,2.7,0),COLOR000077;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,2.1,0),COLOR000099;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,1.5,0),COLOR0000BB;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,0.9,0),COLOR0000DD;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,0.3,0),COLOR0000FF;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,3.15,0),COLORAA1100;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,2.45,0),COLORAA3300;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,1.75,0),COLORAA5500;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,1.05,0),COLORAA7700;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,0.35,0),COLORAA9900;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(VAR4 AND VAR5,L,OPEN,3.15,0),COLOR1111FF;
STICKLINE(VAR4 AND VAR5,L,OPEN,2.45,0),COLOR3333FF;
STICKLINE(VAR4 AND VAR5,L,OPEN,1.75,0),COLOR5555FF;
STICKLINE(VAR4 AND VAR5,L,OPEN,1.05,0),COLOR7777FF;
STICKLINE(VAR4 AND VAR5,L,OPEN,0.35,0),COLOR9999FF;
STICKLINE(CROSS(散,庄) AND 散<30,L,OPEN,3.15,0),COLOR770077;
STICKLINE(CROSS(散,庄) AND 散<30,L,OPEN,2.45,0),COLOR990099;
STICKLINE(CROSS(散,庄) AND 散<30,L,OPEN,1.75,0),COLORBB00BB;
STICKLINE(CROSS(散,庄) AND 散<30,L,OPEN,1.05,0),COLORDD00DD;
STICKLINE(CROSS(散,庄) AND 散<30,L,OPEN,0.35,0),COLORFF00FF;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,3.15,0),COLOR337777;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,2.45,0),COLOR339999;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.75,0),COLOR33BBBB;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.05,0),COLOR33DDDD;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,0.35,0),COLOR33FFFF;
STICKLINE((AA+0)/34=FLOOR((AA+0)/34),L,OPEN,3.15,-1),COLORMAGENTA;
AAA:=COST(50);
STICKLINE(CROSS(C,AAA),O,C,3,0 ),COLORFF0080;
V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
HY1:=REF(EMA(V1,3),1);
超短线:MA(CLOSE,1),COLORLIGRAY;
主力线:HY1,COLORLICYAN,LINETHICK2;
中支线:MA(CLOSE,60),COLORBLUE,LINETHICK3;
V2:=(1-7/100)*(DMA(CLOSE,V1));
决策:REFDATE(V2,DATE),,LINETHICK2,COLORLIGRAY;
DRAWTEXT(ISLASTBAR,决策,'决策线'),COLORWHITE;
DRAWTEXT_FIX(1,0.88,5,0,'~★~云在云端作品~★~'),COLORMAGENTA;
LC1:=REF(CLOSE,1);
RSI1:=((SMA(MAX((CLOSE - LC1),0),3,1) / SMA(ABS((CLOSE - LC1)),3,1)) * 100);
FF11:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
M:=MA(CLOSE,5),COLORRED;
M1:=MA(CLOSE,10),COLORYELLOW;
爆点:=CROSS(M,M1);
DRAWTEXT(爆点,M*0.96,'*爆②'),COLORYELLOW;
DRAWTEXT(CROSS(CLOSE,HY1),LOW,'*爆①'),COLORRED;
DRAWTEXT(CROSS(88,RSI1),(HIGH * 1.03),'*警'),COLORGREEN;
STICKLINE(ISLASTBAR,HHV(C,5),HHV(C,5),50,1)COLORWHITE;
STICKLINE(ISLASTBAR,HHV(C,5)*0.95,HHV(C,5)*0.95,50,1)COLORYELLOW;

通达信云端短线主图指标公式

 

相关文章