在线检测未来函数

通达信机构增减仓指标公式

来源:Internet,编辑:股旁网,2012-08-24

LL6:=REF(L,BARSLAST(L=LLV(L,20)));
CC7:=REF(C,BARSLAST(L=LLV(L,20))+7);
上高:=(CC7-LL6)*3+LL6;
高1:=上高;
低1:=LL6;
振幅:(高1-低1)/低1*100,NODRAW;
H1:=高1;
H2:=低1+(高1-低1)*1/4;
H3:=低1+(高1-低1)*1/2;
H4:=低1+(高1-低1)*3/4;
H5:=低1;
H6:=低1+(高1-低1)*1/3;
天:REFDATE(H1,DATE),COLORYELLOW,LINETHICK2;
地:REFDATE(H5,DATE),COLOR00FF00,LINETHICK2;
弱25%:REFDATE(H2,DATE),COLORFFFF00,LINETHICK2;
中50%:REFDATE(H3,DATE),COLORWHITE,LINETHICK2;
强75%:REFDATE(H4,DATE),COLOR0099FF,LINETHICK2;
特33%:REFDATE(H6,DATE),COLORMAGENTA,LINETHICK2;
RSV1:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K1:=SMA(RSV1,5,1);
D1:=SMA(K1,5,1);
J:=3*K1-2*D1;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
X8:=REF(K1,1)>80 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X8,C ,O,2,0),COLOR1880FF;
STICKLINE(X8,L ,H,0,0),COLOR1880FF;
STICKLINE(X8,L ,L,20,0),COLOR1880FF;
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,L ,H,0,0),COLORFF00FF;
STICKLINE(X,C ,O,2,0),COLORFF00FF;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,0.8,0),COLORYELLOW;
T12:=V2>=1;
T0:=BARSLAST(T12);
L11:=REF(L,T0);
H55:=REF(H,T0);
STICKLINE(REF(T12,1) OR REF(T12,2) OR REF(T12,3),H55,H55,18,-1),COLORWHITE;
STICKLINE(REF(T12,1) OR REF(T12,2) OR REF(T12,3),L11,L11,18,-1),COLORWHITE;
VAR20:=WINNER(C)*100<=0.15,NODRAW;
DRAWICON(VAR20,L*0.96,13);
VAR18:=WINNER(C)*100<=0.02,NODRAW;
DRAWTEXT(VAR18,H* 1.02,'底警戒'),COLORGRAY;
VAR21:=WINNER(C)*100>=99,NODRAW;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(VAR21,H,'警戒'),COLORYELLOW;
VAR22:=WINNER(C)*100>=95,NODRAW;
DRAWICON(VAR22,H* 1.02,14);
VAR23:=WINNER(C)*100>=100,NODRAW;
DRAWICON(VAR23,H* 1.02,15);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,10),10)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,11)*10+CLOSE,22);
B1:IF(CROSS(买线,卖线),L-0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(20,RSI)*10,H+0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100+(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.05,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;
A1:EMA(A0,5)COLORBLUE,LINETHICK2;
A2:=EMA(A0,10)COLORLIBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};
逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};
买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK2;
卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK2;
AAF:LLV(LOW,34),LINETHICK1,COLORFFFFCC,NODRAW;
BBF:MA(AAF,4),LINETHICK3,COLORBLUE;
LC:=REF(CLOSE,1),NODRAW;
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100),NODRAW;
FF:=EMA(CLOSE,3),NODRAW;
MA15:=EMA(CLOSE,21),NODRAW;
DRAWTEXT(CROSS(FF,MA15),BBF,'底背离'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶背离'),COLOR1880FF;
C2:=REF(C,1),NODRAW;
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0),NODRAW;
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
DRAWTEXT(涨停,HIGH ,'涨停'),COLORYELLOW;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
DRAWTEXT(跌停,HIGH ,'跌停'),COLORGREEN;VAR28:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR38:=SMA(VAR28,4,1);
VAR48:=SMA(VAR38,2,1);
趋势线2:=VAR28;
均线:=MA(VAR28,10);
机构增仓:IF(VAR48<14 AND VAR38<11,80,0),COLOR0000FF;
机构减仓:IF(VAR48>82 AND VAR38>89,80,0),COLOR00FF00;
A11:=REF(C,1);
{www.gupang.com 股旁网_通达信股票指标公式}
RSI11:=SMA(MAX(C-A11,0),6,1)/SMA(ABS(C-A11),6,1)*100;
A1:=C-MA(C,5)/MA(C,5)*100<1;
A2:=C-MA(C,13)/MA(C,13)*100<-10;
A3:=C-MA(C,34)/MA(C,34)*100<-15;
A4:=RSI11<18;
TYP := (HIGH + LOW + CLOSE)/3;
A5:=(TYP-MA(TYP,14)/(0.015*AVEDEV(TYP,14)))<-120;
组合底部:(A1 AND A2 AND A3 AND A4 AND A5)*100,COLOR00FFFF;

通达信机构增减仓指标公式

 

相关文章