在线检测未来函数

飞狐安全MACD指标公式

来源:Internet,编辑:股旁网,2012-08-28

均价:=(2*C+(C+H+L+O)/4+O)/4;
R:=(2*L+3*均价)/5;R1:=(2*H+3*均价)/5;
kX:=(R+R1)/2;
YCZXH:=(MA(HHV(R,1),5)+MA(HHV(R,2),13)+MA(HHV(R,3),21)+MA(HHV(R,4),29))/4;
YCZXL:=(MA(LLV(R,1),5)+MA(LLV(R,2),13)+MA(LLV(R,3),21)+MA(LLV(R,4),29))/4;
SMH:=EMA(YCZXH,17);SML:=EMA(YCZXL,17);
{线差}
AM:=(4*R+3*REF(r,1)+2*REF(r,2)+REF(r,3))/10;
{www.gupang.com 股旁网_飞狐股票指标公式}
DF:=AM-SMH;DFM:=EMA(DF,3);
KF:=AM-SML;KFM:=EMA(KF,3);
ZDF1:=MAX(DFM,0);ZDF2:=EMA(ZDF1,3);ZDF3:=EMA(ZDF2,7);
ZKF1:=-MIN(KFM,0);ZKF2:=EMA(ZKF1,3);ZKF3:=EMA(ZKF2,7);
ABSDK:=MAX(ZDF2,ZKF2);ABSDKX:=max(MAX(ABSDK,ZDF3),ZKF3);
{---------------------【图】---------------------}
{显示方法一}
STICKLINE(ZKF3>ZKF2,-ZKF2,-ZKF3,8,1),COLOR202020,COLOR6600FF;
STICKLINE(ZDF3>ZDF2,ZDF2,ZDF3,8,1),COLOR202020,COLORYELLOW;
STICKLINE(ZDF2>ZKF2,0,ZDF2,8,1),COLOR460046,COLORRED;
STICKLINE(ZDF2<ZKF2,0,-ZKF2,8,1),COLOR800000,COLORGRAY;
STICKLINE(ZDF2>ZKF2,0,ZDF2,1,1),COLOR790079,COLORMAGENTA;
STICKLINE(ZDF2<ZKF2,0,-ZKF2,1,1),COLORFF0000;
{显示方法二}
STICKLINE(ZKF3>ABSDK,ABSDK,ZKF3,4,0),COLOR202020,COLORMAGENTA;
STICKLINE(ZDF3>ABSDK,ABSDK,ZDF3,4,0),COLOR202020,COLOR00bb00;
STICKLINE(ZDF2>ZKF2,0,ZDF2,4,1),COLOR460046,COLORWHITE;
STICKLINE(ZDF2<ZKF2,0,ZKF2,4,1),COLOR800000,COLORAAAA00;
STICKLINE(ZDF2>ZKF2,0,ZDF2,1,1),COLOR790079,COLORFFC0FF;
STICKLINE(ZDF2<ZKF2,0,ZKF2,1,1),COLORFF0000;

飞狐安全MACD指标公式

 

相关文章