在线检测未来函数

通达信看牛卖指标公式

来源:Internet,编辑:股旁网,2012-08-28

N1:=5;N2:=10;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(BT,UP,'短牛'),COLOR0000FF;
TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
STICKLINE(TJ1,0,DOWN,3,0),COLOR880088;
STICKLINE(TJ1,0,DOWN,1.5,0),COLORAA00AA;
STICKLINE(TJ1,0,DOWN,0.8,0),COLORCC00CC;
STICKLINE(TJ1,0,DOWN,0.2,0),COLORFF00FF;
DRAWTEXT(TJ1,UP,'中牛'),COLORFF00FF;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(TJ2,0,UP,5,0),COLOR008888;
STICKLINE(TJ2,0,UP,2,0),COLOR00AAAA;
STICKLINE(TJ2,0,UP,1,0),COLOR00CCCC;
STICKLINE(TJ2,0,UP,0.2,0),COLOR00FFFF;
DRAWTEXT(TJ2,UP,'大牛'),COLOR00FFFF;
ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
STICKLINE(ST,10,DOWN,5,0),COLOR008800;
STICKLINE(ST,10,DOWN,2,0),COLOR00AA00;
STICKLINE(ST,10,DOWN,1,0),COLOR00CC00;
STICKLINE(ST,10,DOWN,0.2,0),COLOR00FF00;
DRAWTEXT(ST,DOWN*1.1,'卖'),COLOR00FF00;

通达信看牛卖指标公式

 

相关文章