在线检测未来函数

(愚公买卖)指标出现钱袋时的选股程序

来源:Internet,编辑:股旁网,2012-08-16

编写要求:

愚公买卖指令源码:请老师编个钱袋出现时的选股程序 DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,9) ; DRAWICON((ZIG(3,5)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,4); VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100; VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100; VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100; VAR6:=(VAR3+VAR4+VAR5)/3; VAR7:=EMA(VAR6,5); ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK; VAR8:=IF(VAR6<=-20,10,0); VAR9:=HHV(VAR8,10); VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0); K:=EMA(VAR7,5)*2, , COLORFF00FF; D:=EMA(K,5), , COLORWHITE; J:=K*3-D*2, ,COLORYELLOW; VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10; HS:=VOL/CAPITAL*100, , COLORGREEN; DRAWTEXT(VAR8=10 AND FILTER(VAR8=10,5),LOW*1.00,'准备') COLORMAGENTA; DRAWTEXT(VARA=20,LOW*1.00,'一定要买') COLORRED; DRAWICON(VARA=20,LOW*1.00,1); VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20; VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1); VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1); VAR11:=VARFREF(VOL,1) AND CLOSE>REF(CLOSE,1); DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'庄家异动'),LINETHICK1,COLORFF00FF; VAR12:=(HIGH+LOW+CLOSE)/3; VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14)); VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70)); VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0); VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15); VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100; VAR18:=100-ABS(VAR17); VAR19:=IF(VAR18<90,VAR18,100); VAR1A:=IF(VARE>0,VARE,0); VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60; VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100; DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*1.00,'大动作') COLORYELLOW; VAR20:=PEAKBARS(3,15,1)<10; VAR21:=IF(VAR20=1,2,0); VAR22:=IF(VAR21=2,2,0); VAR23:=IF(VAR22>REF(VAR22,1),35,0)LINETHICK2; DRAWTEXT(VAR23=35,HIGH*1.00,'一定要逃')COLORGREEN; DRAWICON(VAR23=35,HIGH*1.00,2);

股旁网解答:

 XG:ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

相关文章