在线检测未来函数

修改MACD和RSI公式

来源:Internet,编辑:股旁网,2012-08-31

编写条件:

求助老师帮忙改写MACD和RSI公式的结合体 要求:1原来的MACD不要输出DIF和DEA 只显示红绿柱就可以了 2 用RSI参数6 12 两条线代替DIF和DEA就可以了

编写方法:

 DIF:=EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW;

DEA:=EMA(DIF,9),NODRAW;
MACD:(DIF-DEA)*2*30,NODRAW;
STICKLINE(MACD> 0,50,50+MACD,0.1,0),COLORRED;
STICKLINE(MACD< 0,50,50+MACD,0.1,0),COLORCYAN;
LC:=REF(CLOSE,1);
DIF1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DEA2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
 
 
 

相关文章