在线检测未来函数

通达信主力跑光作品主图指标公式

来源:Internet,编辑:股旁网,2012-09-12

MA5:=MA(C,5);
MA13:=MA(C,13);
MA25:=MA(C,25);
MA55:=MA(C,55);
∠5:=57.3*(ATAN(100*(MA5/REF(MA5,1)-1)));
∠13:=57.3*(ATAN(100*(MA13/REF(MA13,1)-1)));
∠25:=57.3*(ATAN(100*(MA25/REF(MA25,1)-1)));
∠55:=57.3*(ATAN(100*(MA55/REF(MA55,1)-1)));
C1:=REF(C,1);
C2:=REF(C,2);
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
M1:MA5;
M2:MA13;
M3:MA25;
M4:MA55;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
MACD1:=CROSS(DIFF,DEA) AND COUNT(MACD>0,1)=1;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,9,1);
D:=SMA(K,9,1);
J:=3*K-2*D;
KDJ1:=CROSS(K,D) AND CROSS(J,D);
均线:=CROSS(MA(C,5),MA(C,10));
量线:=CROSS(MA(V,5),MA(V,10));
SCC:=MACD1 AND KDJ1 AND 均线 AND 量线;
SC1:=MACD1 AND KDJ1;
SC2:=均线 AND 量线;
SC3:=均线 AND MACD1;
SC4:=量线 AND KDJ1;
SC5:=均线 AND KDJ1;
SC6:=MACD1 AND 量线;
DRAWICON(SC1 OR SC2 OR SC3 OR SC4 OR SC5 OR SC6,L-0.20,9);{两个以上指标同时金叉显示9号图标}
DRAWICON(SCC,L-0.20,3);{四个指标同时金叉显示3号图标,便于区别};
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),COLOR2DFFFF;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLOR00AAAA;
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLOR00CACA;
STICKLINE(涨停,OPEN,CLOSE,2,0),COLOR00E3E3;
STICKLINE(涨停,OPEN,CLOSE,1.5,0),COLOR02FFFF;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLOR2DFFFF;
{www.gupang.com 股旁网_通达信股票指标公式}
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),COLOR33FF33;
STICKLINE(跌停,OPEN,CLOSE,3,0),COLOR00B700;
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLOR00D200;
STICKLINE(跌停,OPEN,CLOSE,2,0),COLOR00EA00;
STICKLINE(跌停,OPEN,CLOSE,1.5,0),COLOR0FFF0F;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLOR33FF33;
BDGD:=CROSS(0.8,H=HHV(H,6));
GDSJ:=BARSLAST(BDGD)+1;
波峰:=REF(H,GDSJ),COLOR1EFF1E;
BDDD:=CROSS(0.8,L=LLV(L,6));
DDSJ:=BARSLAST(BDDD)+1;
波谷:=REF(L,DDSJ),COLOR7400E8;
STICKLINE(GDSJ<=8,波峰,波峰,8,0),COLORFFFF24,LINETHICK02;
STICKLINE(DDSJ<=8,波谷,波谷,8,0),COLOR37FFFF,LINETHICK02;
二炮:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
攻击线:=SMA(二炮,4,2),COLORRED,LINETHICK2;
{PARTLINE(攻击线,攻击线>REF(攻击线,1),RGB(210,0,105),攻击线<=REF(攻击线,1),RGB(0,170,0)),LINETHICK2;}
VARA:=4*SMA((CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100,4,1)-
3*SMA(SMA((CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100,4,1),3.2,1);
VARB:=7;
CC:=CROSS(VARA,VARB);
DRAWTEXT(CC,L*0.98,'★'),COLOR00FFFF;
卖出:=CROSS(72,SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100);
DRAWTEXT(卖出,H*1.08,'◆'),COLORGREEN;
DRAWTEXT_FIX(1,0.11,1,0,EXTERNSTR(0,6)),COLORYELLOW;
DRAWTEXT_FIX(1,0.12,1,0,EXTERNSTR(0,1)),COLORYELLOW;
DRAWTEXT_FIX(1,0.88,5,0,'主力跑光作品'),COLORRED;

通达信主力跑光作品主图指标公式

 

相关文章