在线检测未来函数

飞狐佛眼看量指标公式

来源:Internet,编辑:股旁网,2012-09-13

VOL,VOLSTICK;
盘:(CAPITAL / 1000000),POINTDOT,color33CCFF;
业绩:FINANCE(33);
预测量:STICKLINE(((DYNAINFO(7) = CLOSE) AND (DYNAINFO(10) = AMOUNT)),MAX(VOL,(DYNAINFO(17) * REF(MA(VOL,5),1))),MAX(VOL,(DYNAINFO(17) * REF(MA(VOL,5),1))),7,1),POINTDOT,LINETHICK1,colorFF6633;
hsl:=(AMOUNT / (VOL * 100));
LJJ:=IF((((HIGH - LOW) = 0) AND ((CLOSE / REF(CLOSE,1)) < 0.95)),1,(( - LOW) / (HIGH - LOW)));
QD:=(LJJ - 1);
QD2:=IF((REF(LJJ,1) = 0),0.01,REF(LJJ,1));
C1:=IF((REF(QD,1) = 0),0.01,REF(QD,1));
C2:=(((LJJ / QD2) / (((LJJ / QD2) + (QD / C1)) / 100)) / 100);
买量:(C2 * VOL),VOLSTICK,colorCC;
STICKLINE(1,0,买量,6,0),colorCC;
卖量:((C2 - 1) * VOL),VOLSTICK,colorFF00;
STICKLINE(1,0,卖量,6,0),colorFF00;
增减仓:(买量 - (卖量 * (0 - 1))),colorFF9966;
SX:=(CLOSE / COST(50));
VARA1:=(REF(CLOSE,1) / CLOSE);
VARA2:=(CLOSE / REF(CLOSE,1));
VARA3:=(((1 - (MA(LOW,3) / MA((((HIGH + LOW) + (2 * CLOSE)) / 4),20))) * 100) - (50 / 10));
VARA4:=(((1 - (SMA((VARA1 * LOW),3,1) / EMA((((HIGH + LOW) + (2 * CLOSE)) / 4),10))) * 100) - (50 / 10));
VARA5:=((((MA(HIGH,3) / MA((((HIGH + LOW) + (2 * CLOSE)) / 4),20)) - 1) * 100) - (50 / 10));
VARA6:=((((SMA((VARA2 * HIGH),3,1) / EMA((((HIGH + LOW) + (2 * CLOSE)) / 4),10)) - 1) * 100) - (50 / 10));
VARA7:=IF((VARA3 > 0),(((VARA3 * 4000) * REF((((HIGH + LOW) + (2 * CLOSE)) / 4),3)) / CLOSE),0);
升值:=IF((VARA5 > 0),(((VARA5 * 4000) * REF((((HIGH + LOW) + (2 * CLOSE)) / 4),3)) / CLOSE),0);
跌值:=(((VARA4 > 0) AND (SX > REF(SX,1))) AND (VARA7 > 0));
选股:=(((VARA6 > 0) AND (SX < REF(SX,1))) AND (升值 > 0));
告警:=DRAWICON((跌值 = 1),(0 - 3000),10);
VARA8:=DRAWICON((选股 = 1),1000,11);
VARA9:=(AMOUNT / 10000);
对拷:FINANCE(33),POINTDOT;
V1:=REF(CLOSE,1);
VAR1:=((V1 - LOW) / (HIGH - LOW));
VAR4:=(VARA9 * VAR1);
VAR5:=(VOL * VAR1);
VAR2:=ABS(VAR5);
VAR3:=ABS(VAR4);
VAR6:=ABS((VARA9 - VAR3));
大单卖盘:(ABS((VOL - VAR2)) / 100);
VAR7:=(买量 - 卖量);
ZJC:=EMA(VAR7,1);
HQ:=EMA(VAR7,3);
{www.gupang.com 股旁网_飞狐股票指标公式}
HQ1:=CROSS(EMA(VAR7,1),EMA(VAR7,3));
A:=CROSS(EMA(VAR7,3),EMA(VAR7,1));
B1:=DRAWTEXT((A AND (EMA(VAR7,1) > EMA(VAR7,40))),(VOL * 1.6),'--');
DRAWTEXT((FILTER(HQ1,15) AND (EMA(VAR7,1) < EMA(VAR7,30))),(VOL * 2),'++'),colorFF9966;
C3:=SMA((((((3 * HIGH) + (2 * CLOSE)) + OPEN) + LOW) / 7),10,1);
B:=(0 - ((100 * (HHV(HHV(C3,1),14) - C3)) / (HHV(HHV(C3,1),14) - LLV(LLV(C3,1),14))));
W1:=(0 - ((100 * (HHV(HHV(C3,1),34) - C3)) / (HHV(HHV(C3,1),34) - LLV(LLV(C3,1),34))));
W2:=(0 - ((100 * (HHV(HHV(C3,1),55) - C3)) / (HHV(HHV(C3,1),55) - LLV(LLV(C3,1),55))));
W3:=(0 - ((100 * (HHV(HHV(C3,1),89) - C3)) / (HHV(HHV(C3,1),89) - LLV(LLV(C3,1),89))));
W4:=((((B + W1) + W2) + W3) / 4);
HQ1:=SMA(VOL,10,1);
价格WR:=(0 - ((100 * (HHV(HHV(HQ1,1),14) - HQ1)) / (HHV(HHV(HQ1,1),14) - LLV(LLV(HQ1,1),14))));
WR1:=(0 - ((100 * (HHV(HHV(HQ1,1),34) - HQ1)) / (HHV(HHV(HQ1,1),34) - LLV(LLV(HQ1,1),34))));
WR2:=(0 - ((100 * (HHV(HHV(HQ1,1),55) - HQ1)) / (HHV(HHV(HQ1,1),55) - LLV(LLV(HQ1,1),55))));
WR3:=(0 - ((100 * (HHV(HHV(HQ1,1),89) - HQ1)) / (HHV(HHV(HQ1,1),89) - LLV(LLV(HQ1,1),89))));
WR4:=((((价格WR + WR1) + WR2) + WR3) / 4);
(0 - 50),POINTDOT;
(0 - 20),POINTDOT;
(0 - 80),POINTDOT,colorFFFF00;
EXPLAIN(((W4 <= (0 - 80)) AND (W4 > (0 - 100))),'价格趋势较弱,不会保持太久'),colorFFFF;
EXPLAIN(((W4 > (0 - 80)) AND (W4 <= (0 - 50))),'价格趋势有扭转要求,可观察'),colorFFFF;
EXPLAIN(((W4 > (0 - 50)) AND (W4 <= (0 - 20))),'价格趋势中线转强'),colorFFFF;
EXPLAIN(((W4 > (0 - 20)) AND (W4 < 0)),'价格趋势中长线转强'),colorFFFF;
EXPLAIN((W4 = 0),'如果能量配合,已具备长线走牛的可能'),colorFFFF;
EXPLAIN((W4 = (0 - 100)),'趋势很弱,此股不看'),colorFFFF;
EXPLAIN((((REF(W4,3) > REF(W4,2)) AND (REF(W4,2) > REF(W4,1))) AND (REF(W4,1) > W4)),'趋势转空'),colorFFFF;
EXPLAIN((((REF(W4,3) < REF(W4,2)) AND (REF(W4,2) < REF(W4,1))) AND (REF(W4,1) < W4)),'趋势转多'),colorFFFF;
EXPLAIN(((WR4 <= (0 - 80)) AND (WR4 > (0 - 100))),'介入资金散兵游勇'),colorFF00;
EXPLAIN(((WR4 > (0 - 80)) AND (WR4 <= (0 - 50))),'部分中线资金介入'),colorFF00;
EXPLAIN(((WR4 > (0 - 50)) AND (WR4 <= (0 - 20))),'中线资金有进一步介入愿望,关注'),colorFF00;
EXPLAIN(((WR4 > (0 - 20)) AND (WR4 < 0)),'有大资金愿意做此股'),colorFF00;
EXPLAIN((WR4 = 0),'资金在疯狂介入'),colorFF00;
EXPLAIN((WR4 = (0 - 100)),'无资金照看'),colorFF00;
EXPLAIN((((REF(WR4,3) > REF(WR4,2)) AND (REF(WR4,2) > REF(WR4,1))) AND (REF(WR4,1) > WR4)),'资金在撤退'),colorFF00;
EXPLAIN((((REF(WR4,3) < REF(WR4,2)) AND (REF(WR4,2) < REF(WR4,1))) AND (REF(WR4,1) < WR4)),'资金在介入'),colorFF00;

飞狐佛眼看量指标公式

 

相关文章