在线检测未来函数

大智慧量价变化指标公式

来源:Internet,编辑:股旁网,2012-09-13

{1.价角度}
MA5:=EMA(C,5);
价角度:ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,LINETHICK0;
EMA5:WMA(价角度,10),COLOR0598FF,DOTLINE;
PARTLINE(EMA5,EMA5>REF(EMA5,1),RGB(255,0,0)),COLOR00FFFF,LINETHICK2,LAYER0;
DRAWTEXT(DISPSTATUS=2,EMA5,'价:'+NUMTOSTRN(价角度,1)+'度'),COLOR0000FF,LINETHICK1,ALIGN0;
{2.量角度}
MV5:=EMA(V,5);
量角度:ATAN((MV5/REF(MV5,1)-1)*100)*180/3.1416,LINETHICK0;
EMV5:WMA(量角度,10),COLOR00FF00,DOTLINE;
PARTLINE(EMV5,EMV5>REF(EMV5,1),RGB(255,255,0)),COLOR0099FF,LINETHICK2,LAYER0;
DRAWTEXT(DISPSTATUS=2,EMV5,'量:'+NUMTOSTRN(量角度,1)+'度'),COLOR00FF00,LINETHICK1,ALIGN0;
{3.成本角度}
成本角度:ATAN((cyc(5)/REF(cyc(5),1)-1)*100)*180/3.1416,LINETHICK0;
{www.gupang.com 股旁网_大智慧股票指标公式}
CY5:WMA(成本角度,10),COLOR00FFFF,DOTLINE;
PARTLINE(CY5,CY5>REF(CY5,1),RGB(0,255,0)),COLOR00FF00,LINETHICK4,LAYER0;
{3天-5天OBV强弱}
OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
MB3:=MA(OBV,3);
MB5:=MA(OBV,5);
NB1:=BARSLAST(CROSS(MB3,MB5));
NB2:=BARSLAST(CROSS(MB5,MB3));
N:=IF(NB1<NB2,NB1+1,0-NB2-1);
STICKLINE(N>0,0-50,0-50+N*2,6,0),COLOR0000FF;
STICKLINE(N<0,0-50,0-50+N*2,6,0),COLORFFFF00;

大智慧量价变化指标公式

 

相关文章