在线检测未来函数

通达信CCI指标公式

来源:Internet,编辑:股旁网,2012-09-13

N:=14;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
DRAWTEXT(CROSS(200,CCI),250,'下穿200'),COLORGREEN;
DRAWTEXT( CROSS(CCI,-200),-150,'上穿-200'),COLORYELLOW;
DRAWTEXT( CROSS(CCI,-100),-100,'上穿-100'),COLORFF00FF;
STICKLINE(CCI>0,0,CCI,1,0),COLORRED;
STICKLINE(CCI<0,0,CCI,1,0),COLORLIGREEN;
STICKLINE(CROSS(CCI,-200) AND CCI>REF(CCI,1),CCI,0,1,0),COLORYELLOW;
STICKLINE(CROSS(200,CCI) AND CCI<REF(CCI,1),0,CCI,1,0),COLORGREEN;
{www.gupang.com 股旁网_通达信股票指标公式}
CCI70:(TYP-MA(TYP,70))/(0.015*AVEDEV(TYP,70)),COLORYELLOW,LINETHICK2;
差值:=CCI70-REF(CCI70,1);
IF(差值>0,CCI70,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(差值<0,CCI70,DRAWNULL),COLORBLUE,LINETHICK2;
逃顶线:200,COLORGREEN;
强势线:100,COLORRED,LINETHICK2;
趋势线:CCI,COLORGRAY,LINESTICK,LINETHICK1;
中轴线:0,COLORYELLOW,LINETHICK1;
抄底线:-100,COLORWHITE;
弱势线:-200,COLORGREEN;
DRAWICON(CROSS(CCI,-100) OR (REF(CCI,1)>-100 AND REF(CCI,1)<-95 AND CCI>REF(CCI,1)),CCI-0.03,1);
DRAWICON(CROSS(100,CCI) OR (REF(CCI,1)<100 AND REF(CCI,1)>95 AND CCI<REF(CCI,1)),CCI+0.03,2);

通达信CCI指标公式

 

相关文章