在线检测未来函数

同花顺绝对买卖点指标公式

来源:Internet,编辑:股旁网,2012-09-14

N:=5;
vAR3:=LLV(HIGH,240);
VAR4:=((100)*(CLOSE-VAR3))/(VAR3);
VAR5:=REF(LLV(CLOSE,480),1);
VAR6:=REF(HHV(CLOSE,480),1);
VAR7:=((100)*(CLOSE-VAR5))/(VAR6-VAR5);
VAR8:=((CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981)))*(100);
VAR9:=((CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393)))*(100);
VARA:=((CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981)))*(100);
VARB:=((CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393)))*(100);
VARC:=(EMA(((100)*(CLOSE-LLV(LOW,100)))/(HHV(HIGH,100)-LLV(LOW,100)),5))/(4);
VARD:=IF((DATE<99991232),IF((VARC>23.16),VARC,0),0);
VARE:=(VARC<1);
VARF:=VARD;
VAR10:=IF((FILTER((VAR8=0) AND (VARA<1) AND (VAR4<0),5)=1),1,0);
VAR11:=IF((FILTER((VAR8=100) AND (VARA=100),5)=1),1,0);
VAR12:=IF((FILTER((VAR9=0) AND (VARB<1) AND (VAR7<0),5)=1),1,0);
VAR13:=IF((FILTER((VAR9=100) AND (VARB=100),5)=1),1,0);
VAR14:=IF((FILTER((VAR4<1) AND (VAR7<1),30)=1),1,0);
VAR15:=VAR10 AND VAR12;
VAR16:=VAR11 AND VAR13;
VAR17:=(VAR8=0) AND VARE AND VAR14;
VAR18:=VAR15 AND VARE AND VAR14;
VAR19:=(VAR8=100) AND VARF;
VAR1A:=VAR16 AND VARF;
大盘方向:EMA(((100)*(CLOSE-LLV(LOW,100)))/(HHV(HIGH,100)-LLV(LOW,100)),7),CoLorFF00FF;
获利:VAR4,CoLor00FF00;
操盘手:((CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393)))*(100),CoLorFFFFFF;
VAR1B:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,30);
VAR1D:=((2)*(VAR1B-VAR1C))*(10);
VAR1E:=(POW(VAR1D,3))*(0.1)+POW(VAR1D,2);
//{www.gupang.com 股旁网_同花顺股票指标公式}
VAR1F:=SQRT(SQRT((((LOW)*(HIGH))*(OPEN))*(CLOSE)));
VAR20:=EMA((VAR1F)*(0.97),3);
VAR21:=(HIGH+LOW+CLOSE)/(3);
VAR22:=(VAR21-MA(VAR21,14))/((0.015)*(AVEDEV(VAR21,14)));
VAR23:=(IF((VAR1D>0.015),VAR1E,0))/(50);
庄线:VAR23,CoLorFFFF00;
VAR24:=MAX(MAX(HIGH-LOW,ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
VAR25:=MA(VAR24,48);
VAR26:=CROSS(VAR24,VAR25);
VAR27:=IF((FILTER(VAR26,126)=1),70,0);
VAR28:=REF(CLOSE,1);
VAR29:=((SMA(MAX(CLOSE-VAR28,0),6,1))/(SMA(ABS(CLOSE-VAR28),6,1)))*(100);
VAR2A:=((SMA(MAX(CLOSE-VAR28,0),12,1))/(SMA(ABS(CLOSE-VAR28),12,1)))*(100);
VAR2B:=((SMA(MAX(CLOSE-VAR28,0),24,1))/(SMA(ABS(CLOSE-VAR28),24,1)))*(100);
VAR2C:=IF((FILTER(CROSS(VAR29,VAR2A) AND CROSS(VAR2A,VAR2B) AND CROSS(VAR29,VAR2B),5)=1),50,0);
VAR2D:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VAR2E:=SMA(VAR2D,3,1);
VAR2F:=SMA(VAR2E,3,1);
VAR30:=(3)*(VAR2E)-(2)*(VAR2F);
VAR31:=CROSS(VAR30,VAR2E) AND CROSS(VAR30,VAR2F) AND CROSS(VAR2E,VAR2F);
VAR32:=IF((FILTER(VAR31 AND (VAR30<25) AND (VAR2F<20),5)=1),80,0);
VAR33:=IF((FILTER((VAR17 OR VAR18),1)=1),100,0);
VAR34:=(大盘方向<5) AND (获利<0) AND (操盘手=0);
绝对买点:IF((FILTER((VAR34 OR VAR33),N)=1),100,0),CoLor0000FF;
绝对卖点:IF((FILTER(VAR19 AND VAR16 AND VARF,2)=1),100,0),CoLor00FF00;
MD1:IF((FILTER((大盘方向<20) AND VAR2C AND (VAR29<60) AND (VAR2B<40),15)=1),80,0),STICK,Linethick3,CoLor00FFFF;
MD2:IF((FILTER((大盘方向<20) AND MD1 AND VAR32,5)=1),80,0),CoLor000080;
DM3:IF((FILTER((大盘方向<50) AND MD1 AND VAR32 AND VAR27,5)=1),80,0),CoLor800080;
DRAWTEXT(绝对买点,20,'"原码买点"'),CoLor00FFFF;
DRAWTEXT(MD1,50,'"周线选股买点"'),CoLorFF00FF;
DRAWTEXT(绝对卖点,90,'"坚决卖出,空仓"'),CoLor00FF00;
DRAWICON(绝对买点,绝对买点,1),CoLorFFFFFF;
DRAWICON(绝对卖点,绝对卖点,9),CoLorFFFF00;

同花顺绝对买卖点指标公式

 

相关文章