在线检测未来函数

通达信内涵MACD指标公式

来源:Internet,编辑:股旁网,2012-09-14

DIF:=(2*EMA(CLOSE, 12)-EMA(EMA(CLOSE,12),12))-(2*EMA(CLOSE, 26)-EMA(EMA(CLOSE, 26),26));
DEA:=2*EMA(DIF, 9) - EMA(EMA(DIF, 9),9);
MACD1:3*(DIF-DEA)COLORSTICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,3,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,3,0),COLORGREEN;
STICKLINE(MACD1<MACD2,0,MACD1,3,0),COLORCBCBC0;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIF,COLOR33FF33,LINETHICK2;
DEA,COLORYELLOW,LINETHICK2;
MACD:=MACD1,NODRAW,COLORMAGENTA;
强:=IF(DIF>=DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;
弱:=IF(DEA>=DIF,DEA,DRAWNULL),COLORFF9900,LINETHICK2;
DRAWICON(CROSS(DIF,DEA),DIF-0.2,1);
DRAWICON(CROSS(DEA,DIF),DEA+0.2,2);
{www.gupang.com 股旁网_通达信股票指标公式}
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
{DRAWTEXT(B1>0,-0.05,'MACD底背'),COLORFF00FF;}
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
{DRAWTEXT(B2,-0.08,'KDJ底离'),COLORYELLOW;}{KDJ底背离};
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
{DRAWTEXT(B3>0,-0.1,'RSI底离'),COLORCYAN;}{RSI底背离};
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
{DRAWTEXT(D1>0,0.05,'MACD顶离'),COLORBLUE;}{MACD顶背离}
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
{DRAWTEXT(D2>0,0.1,'KDJ顶离'),COLORLIGRAY;}{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
{DRAWTEXT(D3>0,0.2,'RSI顶离'),COLORGREEN;}{RSI顶背离};
DD:=C=HHV(C,180);
EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;
CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
上升背离:(CC AND EE)*DEA,COLOR00FFFF;
顶背离:(DD AND EE AND DEA< HHV(DEA,180))*DEA,STICK,LINETHICK3,COLORGREEN;
FF:=C=LLV(C,180);
GG:= DEA> REF(DEA,1) AND REF(DEA> REF(DEA,1),1)=1;
LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
下降背离:(LL AND GG)*DEA,COLORMAGENTA;
底背离:(FF AND GG AND DEA> LLV(DEA,180))*DEA,STICK,LINETHICK3,COLORRED;

通达信内涵MACD指标公式

 

相关文章