在线检测未来函数

通达信斐波均线+MACD主图指标公式

来源:Internet,编辑:股旁网,2012-09-19

1、当21、34、55日三均线首次金叉共振拐头向上时,正是最佳的伏击牛股的切入点,只要21、34、55日三均线是向上运行的以后股价每次减量回踩都可以买入。MACD在O轴上运行是潜伏大牛股的必备条件,第 一次O轴上金叉是伏击潜力股最佳的买点。 2、55日均线的走势最关健,55日均线只要拐头向上以后,无论股价怎么折腾个股必然走向牛市,这是长期趋势和长期均线决定短期趋势短期均线最好的诠释。当55日均线拐头向上后该股总的趋势必然向上,可以坚定做多。MACD在O轴上时间比O轴下时间长,提示主力对该股反复进行洗盘假摔。 3、四要素:一是基本面要完美;二是21、34、55日三均线金叉共振一致拐头向上很重要;三是量价关系和形态要完美;四是MACD走势要完美。四要素完美同时发生金共振的股票必然走大牛! 4、提示:为保斐波均线系统的准确,量价关系配合可以作为佐证,MACD出水加以辅助,MACD在O轴上拒绝死叉又叫似叉未叉效果相当于水上金叉。 5、新股次新股没有34日均线更没有55日均线时,就往前推两个斐波那契数例,变成:8、13、21。在8、13、21日均线系统中,21日均线最为重要,21日线与55日线一样是评判个股中线趋势的准则,技术分折时必须要遵守长线决定短线的原则。 6、注意:21、34、55日三均线多头向上,55日线上回调阴线买!

MA8:=MA(CLOSE,8);
MA13:MA(CLOSE,13);
MA21:=MA(CLOSE,21),COLOR1880FF;
MA34:MA(CLOSE,34),COLORGREEN;
MA55:MA(CLOSE,55),COLORMAGENTA;
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
P1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0);
P2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLORFF1CAE;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,OPEN,CLOSE,3,0),COLORFF972F;
DRAWTEXT(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,L*0.998,'←底'),COLOR105D10;
DRAWTEXT(CROSS(C,MA55),L*0.995,'←满仓'),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.1,0,'★ 粉色55线走平上翘、线上做多、回调阴线买 ★'),COLORFF00FF;
DRAWTEXT_FIX(1,0,0.2,0,'★ 三均线走平上翘、每次回调均线、可阴线买 ★'),COLORYELLOW;
DRAWTEXT_FIX(1,0.23,0.1,0,'★ 三线开花、金叉全仓、量线、MACD共振才可买 ★'),COLORYELLOW;
DRAWTEXT_FIX(1,0.23,0.2,0,'★ 抄底、满仓、买1买2、量线、MACD共振才可买 ★'),COLORFF00FF;
MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买=1,5),LOW-0.03,'←预警'),COLORFF00FF;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
DRAWTEXT(多方炮,L+0.1,'←多方炮'),COLORGRAY;
DE:=CONST(LLV(L,90));
JI:=CONST(HHV(H,90))-DE;
DE_K:=DE+JI/3*2;
JI_K:=JI/2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
DE_A:=CONST(LLV(RSV,90));
DD_A:=CONST(HHV(RSV,90))-DE_A;
R:=(RSV-DE_A)/DD_A;
RSV1:=R*JI_K+DE_K;
DE_M:=DE+JI/3;
JI_M:=JI/2;
KDL:=CONST(LLV(EMA(C,26),90));
KDH:=CONST(HHV(EMA(C,26),90))-KDL;
R_K1:=(EMA(C,12)-KDL)/KDH;
R_K2:=(EMA(C,26)-KDL)/KDH;
DIF:(R_K1-R_K2)*JI*1.5+DE_M,COLORGRAY;
DEA:EMA(DIF,9),COLOR104C13;
MACD:=(DIF-DEA)*2+DE_M;
STICKLINE(MACD>=DE_M,MACD,DE_M,0,0),COLORRED;
D_1:=MACD>H AND H>=DE_M AND DE_M>=L;
D_2:=MACD>H AND H>=L AND L>DE_M;
D_3:=H>MACD AND MACD>=L AND L>DE_M;
D_4:=H>MACD AND MACD>DE_M AND DE_M>=L;
STICKLINE(D_1>0,H,DE_M,0,0),COLORYELLOW;
STICKLINE(D_2,H,L,0,0),COLORYELLOW;
STICKLINE(D_3,MACD,L,0,0),COLORYELLOW;
STICKLINE(D_4,MACD,DE_M,0,0),COLORYELLOW;
D_5:=MACD<L AND L<=DE_M AND DE_M<=H;
D_6:=MACD<L AND H<DE_M;
D_7:=L<MACD AND MACD<=H AND H<DE_M;
D_8:=L<MACD AND MACD<DE_M AND DE_M<=H;
STICKLINE(MACD<DE_M,DE_M,MACD,0,0),COLORBLUE;
STICKLINE(D_5,DE_M,L,0,0),COLORYELLOW;
STICKLINE(D_6,H,L,0,0),COLORYELLOW;
STICKLINE(D_7,H,MACD,0,0),COLORYELLOW;
STICKLINE(D_8,DE_M,MACD,0,0),COLORYELLOW;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE-VAR1)/(VAR2-VAR1))*100),5);
AK:=EMA((((CLOSE-VAR1)/(VAR2-VAR1))*50),13);
DD2:=EMA(((0.667*REF(AK1,1))+(0.333*AK1)),2);
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((((CLOSE-VAR3)/(VAR4-VAR3))*100),3);
VAR6:=((AK+VAR5)/2);
VAR7:=EMA(((0.667*REF(VAR5,1))+(0.333*AK1)),2);
VAR8:=EMA(VAR6,5);
BB:=EMA(((0.667*REF(VAR8,1))+(0.333*VAR8)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB<30));
CD:=(BB1*0.6);
DRAWTEXT((CD=0.6),L,'←抄底'),COLOR33CC99;
乖离线:=((C-REF(MA21,1))/20+MA21)*1.20;
{ Gupang.com 股-旁-网_通达信股票指标公式}
TT1:=CROSS(MA21,MA34) AND CROSS(MA21,MA55) AND V>REF(V,1);
TT2:=MA21>REF(MA21,2) AND V>REF(V,1) AND CROSS(C,MA21);
STICKLINE(TT1,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT1,L*0.995,'←金叉全仓'),COLORYELLOW;
STICKLINE(CROSS(C,MA34) AND CROSS(C,MA55)
AND CROSS(C,MA21),L,L-0.18,4,0),COLORYELLOW;
DRAWTEXT(CROSS(C,MA34) AND CROSS(C,MA55)
AND CROSS(C,MA21),L*0.97,'←三线开花'),COLORRED;
STICKLINE(TT2,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT2,L*0.995,'←买1'),COLORYELLOW;
STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),COLOR00FF00;
DRAWTEXT(CROSS(C,乖离线) ,H+0.13,'←卖点'),COLOR00FF00;
STICKLINE(MA55>=REF(MA55,1) AND MA21>=REF(MA21,1)
AND CROSS(C,MA55),L,L-0.09,4,0),COLORFF972F;
DRAWTEXT(MA55>=REF(MA55,1) AND MA21>=REF(MA21,1)
AND CROSS(C,MA55),L*0.98,'←满仓'),COLORFF972F;
STICKLINE(MA34>=REF(MA34,1) AND CROSS(C,MA21) AND CROSS(C,MA34)
AND V>REF(V,1),L,L-0.09,4,0),COLORFF00FF;
DRAWTEXT(MA34>=REF(MA34,1) AND CROSS(C,MA21) AND CROSS(C,MA34)
AND V>REF(V,1),L*0.976,'←买2'),COLORFF00FF;

通达信斐波均线+MACD主图指标公式

 

相关文章