在线检测未来函数

通达信均线阶梯彩条主图指标公式

来源:Internet,编辑:股旁网,2012-09-18

TP:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-TP)/TP*100;
JZ:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1)),COLORFFFF00,LINETHICK2;
STICKLINE(A1X>=0,JZ,TP,0,1),COLORDD00DD;
STICKLINE(A1X<0,JZ,TP,0,1),COLOR00CED1;
AAC:=CROSS(A1X,0);
BBC:=CROSS(0,A1X);
DRAWICON(AAC,JZ*0.98,34);
DRAWICON(BBC,JZ*1.015,35);
MA5:MA(CLOSE,5),COLORFFFF00,LINETHICK3;
C1:=C>=MA5;
C2:=C<MA5;
AA:=C1>=C2 ;
BB:=C2>C1 ;
STICKLINE(AA,C,O,3,0),COLORRED;
STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(BB,C,O,3,0),COLOR00FF00;
STICKLINE(BB,H,L,0,0),COLOR00FF00;
STICKLINE(AA,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(BB,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORCYAN;
VAR5:MA5,COLORFFFF00,LINETHICK3;
{ Gupang.com 股-旁-网_通达信股票指标公式}
IF(VAR5>=REF(VAR5,1),VAR5,DRAWNULL),COLOR0000FF,LINETHICK3;
MA20:MA(CLOSE,20),COLORFFFFFF,LINETHICK2;
IF(MA20>=REF(MA20,1),MA20,DRAWNULL),COLORFF00FF,LINETHICK2;
AAA:= C>VAR5;
BBB:= C<VAR5;
DDD:= A1X>=0;
EE:= A1X<0;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
最高2:=CONST(HHV(H,NN));
最低2:=CONST(LLV(L,NN));
PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;
RCC1:=最高2*0.9-(最高2-最低2)*PP;
最低3:=MIN(RCC1,最低2);
AAD:=最低3;
STICKLINE(AAA,AAD-0.000*AAD,AAD-0.030*AAD,4,0),COLORRED;
STICKLINE(BBB,AAD-0.000*AAD,AAD-0.030*AAD,4,0),COLORDDDD00;
STICKLINE(DDD,AAD-0.035*AAD,AAD-0.065*AAD,4,0),COLORFF00FF;
STICKLINE(EE,AAD-0.035*AAD,AAD-0.065*AAD,4,0),COLOR00AAAA;
DRAWTEXT_FIX(1,0.3,0.87,0,'★★ 红色--五日均线持股★★★★ 粉色--梯形彩块持股★★'),COLOR00FF00;

通达信均线阶梯彩条主图指标公式

 

相关文章