在线检测未来函数

大智慧咱的黄金指标公式

来源:Internet,编辑:股旁网,2012-09-20

TYP := (HIGH + LOW + C)/3;
收:(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20)),LINETHICK3,colorwhite;
TYP1 := (HIGH + LOW + o)/3;
开:=(TYP1-MA(TYP1,20))/(0.015*AVEDEV(TYP1,20));
TYP2 := (HIGH + LOW + h)/3;
高:=(TYP2-MA(TYP2,20))/(0.015*AVEDEV(TYP2,20));
TYP3 := (HIGH + LOW + l)/3;
低:=(TYP3-MA(TYP3,20))/(0.015*AVEDEV(TYP,20));
ARRAY:=收;
HIGHBARS:=BARSLAST(NOT(ARRAY>0));
LOWBARS:=BARSLAST(NOT(ARRAY<0));
UPCONDITION:=BARSLAST(HIGHBARS>=6 AND SUM(ARRAY>100,5)>0);
DNCONDITION:=BARSLAST(LOWBARS>=6 AND SUM(ARRAY<-100,5)>0);
UPTREND:=ARRAY>0 AND UPCONDITION<DNCONDITION;
DNTREND:=ARRAY<0 AND UPCONDITION>DNCONDITION;
TRTREND:=HIGHBARS>=5 AND NOT(UPTREND) OR LOWBARS>=5 AND NOT(DNTREND);
STICKLINE(UPTREND,0,收,4,0),COLORFF0000;{蓝色柱子}
STICKLINE(DNTREND,0,收,4,0),color4b2142;{红色柱子}
STICKLINE(TRTREND,0,收,4,0),COLOR00FFFF;{黄色柱子}
STICKLINE(NOT(UPTREND OR DNTREND OR TRTREND),0,收,4,0),COLOR808080;{灰色柱子}
DRAWICON(ABS(收)>=200,收,12);{图标};
ah:=0;
al:=ref(收,1); {注意指标叠加该函数有循环或分支中将不准确,慎重使用叠加方式}
ahl:=ah-al;
a61:=al+ahl*0.2;
nnl:=DISPSTATUS=2;
{暂时}
STICKLINE(收>开,高,低,8.8,1),colorred;
STICKLINE(收>开,收,开,3,0),color0000a2;
STICKLINE(收< 开,高,低,8.8,1),COLOrgreen;
STICKLINE(收< 开,收,开,3,0),color005b00;
STICKLINE(收=开,高,低,8.8,1),colorffff00;
{ Gupang.com 股-旁-网_大智慧股票指标公式}
q191:=al+(ah-al)*-0.121;
DRAWTEXT(nnl,q191,' 下空上多 ̄ ̄'+q191),ALIGN1,Colorwhite,LINETHICK1;
q1921:=al+(ah-al)*0.121;
DRAWTEXT(nnl,q1921,' STOP ̄ ̄'+q1921),ALIGN1,Colorwhite,LINETHICK1;
q1911:=(高+低)/2;
DRAWTEXT(nnl,q1911,'初入止▔▔▔▔▔▔▔'+q1911),ALIGN1,Coloryellow,LINETHICK2;
DRAWFLAGTEXT(q1911,q1911,'首次入场反向走势止损位置'+q1911),COLORblack,LINETHICK7;
DRAWTEXT(nnl,收,' NEW▔▔▔▔▔▔'+收),ALIGN1,colorffff11,LINETHICK2;
a61:=al+ahl*0.382;
nnl:=DISPSTATUS=2;
差值:(收-开),LINETHICK0,Colorffddff;
高低点分割:收/2,LINETHICK0;
DRAWICON(ABS(收)>=200,收,12);{图标};
STICKLINE(C,30,29,8,0),COLORwhite;
STICKLINE(C,-29,-30,8,0),COLORwhite;
STICKLINE(C,-2,2,7,0),colora0a050;{中轴}
DRAWTEXTREL(567,100,' 差值:'+ 差值),Colorffddff,LINETHICK7;
收q:=ref(收,1);
DRAWTEXT(nnl,收q,'▔ ▔ ▔ ▔ ▔ ▔ '+收q),ALIGN1,VALIGN0,colorffff00,LINETHICK4;
VM:=MA(收,1);
{版权所有---k线的舞者}
DRAWTEXT(BARSTATUS=2 and 收>REF(收,1),Vm,'【升】'),COLORRED,LINETHICK2;
DRAWTEXT(BARSTATUS=2 and 收<REF(收,1),Vm,'【降】'),COLORgreen,LINETHICK2;
PARTLINE(收,收>REF(收,1),RGB(255,20,120),收<REF(收,1),RGB(255,255,255)),linethick4;
DRAWTEXTREL(567,230,' 0.01手赚1$等于10点:'),Colorffddff,LINETHICK7;

大智慧咱的黄金指标公式

 

相关文章