在线检测未来函数

通达信RSI微分指标公式

来源:Internet,编辑:股旁网,2012-09-21

VAR1:=REF(OPEN,1);
VAR2:=SMA(MAX(OPEN-VAR1,0),6,1)/SMA(ABS(OPEN-VAR1),6,1)*100,NODRAW;
VAR3:=REF(CLOSE,1);
VAR4:=SMA(MAX(CLOSE-VAR3,0),6,1)/SMA(ABS(CLOSE-VAR3),6,1)*100,NODRAW;
VAR5:=REF(HIGH,1);
VAR6:=SMA(MAX(HIGH-VAR5,0),6,1)/SMA(ABS(HIGH-VAR5),6,1)*100,NODRAW;
VAR7:=REF(LOW,1);
{ Gupang.com 股-旁-网_通达信股票指标公式}
VAR8:=SMA(MAX(LOW-VAR7,0),6,1)/SMA(ABS(LOW-VAR7),6,1)*100,NODRAW;
开盘值:VAR2,NODRAW;
收盘值:VAR4,NODRAW ;
最高值:VAR6,NODRAW ;
最低值:VAR8,NODRAW ;
{STICKLINE(VAR4<VAR2,VAR8,VAR6,3,0),COLORCYAN;
STICKLINE(VAR4>VAR2,VAR8,VAR6,3,0),COLORRED;}
STICKLINE(VAR4<VAR2,VAR2,VAR4,3,0),COLORCYAN;
STICKLINE(VAR4>VAR2,VAR2,VAR4,3,0),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR8>VAR4,VAR4,VAR6,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR8<VAR4,VAR4,VAR6,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR6>VAR4,VAR4,VAR8,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR6<VAR2,VAR2,VAR8,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6>VAR8 AND VAR6>VAR2,VAR2,VAR8,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR8<VAR2,VAR2,VAR6,0.8,1),COLORRED;
STICKLINE(VAR4>VAR2 AND VAR6<VAR8 AND VAR8>VAR2,VAR2,VAR6,0.8,1),COLORRED;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6<VAR4,VAR4,VAR8,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8<VAR4,VAR4,VAR6,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR6>VAR4,VAR4,VAR8,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6<VAR4,VAR2,VAR8,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6>VAR8 AND VAR6>VAR4,VAR2,VAR8,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8<VAR2,VAR2,VAR6,0.8,1),COLORCYAN;
STICKLINE(VAR4<VAR2 AND VAR6<VAR8 AND VAR8>VAR2,VAR2,VAR6,0.8,1),COLORCYAN;
DRAWBAND(20,RGB(400,400,0),20,DRAWNULL);
DRAWBAND(80,RGB(400,400,0),80,DRAWNULL);
趋势:(C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*80+10,COLORYELLOW;

通达信RSI微分指标公式

 

相关文章