在线检测未来函数

通达信峰谷主图指标公式

来源:Internet,编辑:股旁网,2012-09-01

C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),COLOR2DFFFF;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLOR00AAAA;
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLOR00CACA;
STICKLINE(涨停,OPEN,CLOSE,2,0),COLOR00E3E3;
STICKLINE(涨停,OPEN,CLOSE,1.5,0),COLOR02FFFF;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLOR2DFFFF;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),COLOR33FF33;
STICKLINE(跌停,OPEN,CLOSE,3,0),COLOR00B700;
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLOR00D200;
STICKLINE(跌停,OPEN,CLOSE,2,0),COLOR00EA00;
STICKLINE(跌停,OPEN,CLOSE,1.5,0),COLOR0FFF0F;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLOR33FF33;
BDGD:=CROSS(0.8,H=HHV(H,6));
GDSJ:=BARSLAST(BDGD)+1;
波峰:=REF(H,GDSJ),COLOR1EFF1E;
BDDD:=CROSS(0.8,L=LLV(L,6));
DDSJ:=BARSLAST(BDDD)+1;
波谷:=REF(L,DDSJ),COLOR7400E8;
STICKLINE(GDSJ<=8,波峰,波峰,8,0),COLORFFFF24,LINETHICK02;
STICKLINE(DDSJ<=8,波谷,波谷,8,0),COLOR37FFFF,LINETHICK02;
{www.gupang.com 股旁网_通达信股票指标公式}
二炮:=(-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1)+2*C);
攻击线:=SMA(二炮,4,2),COLORRED,LINETHICK2;
{PARTLINE(攻击线,攻击线>REF(攻击线,1),RGB(210,0,105),攻击线<=REF(攻击线,1),RGB(0,170,0)),LINETHICK2;}
VARA:=4*SMA((CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100,4,1)-
3*SMA(SMA((CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100,4,1),3.2,1);
VARB:=7;
CC:=CROSS(VARA,VARB);
DRAWTEXT(CC,L*0.98,'★'),COLOR00FFFF;
卖出:=CROSS(72,SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100);
DRAWTEXT(卖出,H*1.08,'◆'),COLORGREEN;

通达信峰谷主图指标公式

 

相关文章