在线检测未来函数

飞狐超级RSI指标公式

来源:Internet,编辑:股旁网,2012-09-02

DRAWGBK(DATE>900101,COLORRGB(75,95,95),COLORRGB(0,0,0),1);
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=cross(买线,卖线);
SEL:=cross(卖线,买线);
drawtext(bu,LOW,'B'),ALIGN0,color00ffff,linethick3;
DRAWTEXT(bu,LOW,'﹉'),ALIGN0,Color208FFF,LINETHICK3;
DRAWTEXT(sel,HIGH,'﹉'),ALIGN0,ColorFFFF00,LINETHICK3;
drawtext(sel,HIGH*1.01,'S'),ALIGN0,colorgreen,linethick6;
stickline(买线>=卖线,close,open,8,0),color0000aa;
stickline(买线>=卖线,close,open,6,0),color0000cc;
stickline(买线>=卖线,close,open,2,0),color0000ee;
stickline(买线>=卖线,low,high,0.3,0),colorred;
stickline(买线<卖线,close,open,8,0),coloraaaa00;
stickline(买线<卖线,close,open,6,0),colorcccc00;
stickline(买线<卖线,close,open,2,0),coloreeee00;
stickline(买线<卖线,low,high,0.3,0),colorffff00;
stickline(cross(买线,卖线) or cross(卖线,买线),open,close,4.5,0),color00ffff;
指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),linethick1,ColorFFffFF;
界: MA(CLOSE,27),linethick1,Color00FFFF;
DRAWTEXT(cross(指导线,界),界,'⊕'),ALIGN0,Colorffffff;
DRAWTEXT(cross(界,指导线),界,'⊕'),ALIGN1,Color00ffff;
合力线:FORCAST(C,10),color00ff00,linethick1;
保守线:HHV(FORCAST(C,10),21),color208fff,linethick2;
支撑价:LLV(LOW,13),linethick1 , color00ff00;
守线:=llV(FORCAST(C,10),21){,colorffff00,linethick1};
//守线:llV(FORCAST(C,10),21),colorffff00,linethick1;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
G:=95;
DRAWTEXT(cross(J,D),L,'▲'),ALIGN0,Color00ffff,linethick1;
DRAWTEXT(cross(J,D),L,' ̄'),ALIGN0,Color00ffff;
DRAWTEXT(cross(J,G),H*1.01,'▼'),ALIGN0,Colorffff00,linethick1;
DRAWTEXT(cross(J,G),H,' ̄'),ALIGN0,Colorffff00;
{www.gupang.com 股旁网_飞狐股票指标公式}
PT := REF(HIGH,1)-REF(LOW,1);
重心:=(HIGH + LOW + CLOSE)/3;
压力Ⅰ:= 2*重心-LOW;
压力Ⅱ:= 重心 + PT;
支撑Ⅰ:= 2*重心-HIGH;
支撑Ⅱ:= 重心 - PT;
DRAWTEXT(barpos=SYSPARAM(2),买线,' 当前重心='+NUMTOSTR(重心,2)),coloryellow,PXDN13,align4;
DRAWTEXT(barpos=SYSPARAM(2),买线,' 当前压力Ⅰ='+NUMTOSTR(压力Ⅰ,2)),coloryellow,PXDN3,align4;
DRAWTEXT(barpos=SYSPARAM(2),买线,' 当前支撑Ⅰ='+NUMTOSTR(支撑Ⅰ,2)),coloryellow,PXDN3,align4;
DRAWTEXT(barpos=SYSPARAM(2),买线,' 当前压力Ⅱ='+NUMTOSTR(压力Ⅱ,2)),coloryellow,PXDN28,align4;
DRAWTEXT(barpos=SYSPARAM(2),买线,' 当前支撑Ⅱ='+NUMTOSTR(支撑Ⅱ,2)),coloryellow,PXDN28,align4;
a:=BARPOS; a1:=SYSPARAM(1); a2:=SYSPARAM(2); a3:=SYSPARAM(3);
tt:=BARPOS=SYSPARAM(2);
hh:=SYSPARAM(4); ll:=SYSPARAM(5);
DRAWTEXT(TT,hh,' 机构评级:'+selfstring('评级')),colorffffff,pxdn56,align4;N:=3;N1:=10;N3:=34;
Var1:=EMA(EMA(EMA(CLOSE,N),N),N);
短线: Var1-REF(Var1,1)+Var1,color10FFFF;
中短: MA(短线,N1);
中线: EMA(CLOSE,N3),LINETHICK1,colorFFFFFF;
STICKLINE(短线>中短,中短,短线,0.10,1),color0000ff,LINETHICK1;
STICKLINE(中短>短线,短线,中短,0.10,1),LINETHICK1,color00ff00;
DRAWTEXT(CROSS(短线,中短){ and 中短>=ref(中短,1)},中短-0.2,'↑'), , COLOR00FFFF;
{www.gupang.com 股旁网_飞狐股票指标公式}
VarA:=AMOUNT/VOL/100;
VarB:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VarC:=SUM(AMOUNT,7)/VarA/100;
VarD:=DMA(VarB,VOL/VarC);
VarE:=(CLOSE-VarD)/VarD*100;
VarF:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VarJ:=MA(VarE,20)+STD(VarE,20);
BIAS18:=(CLOSE-MA(CLOSE,18))/MA(CLOSE,18)*100;
K:=SMA(VarF,3,1);
顶:STICKLINE(REF(BIAS18,1)>=5 AND CROSS(VarJ,VarE) AND K>79 ,MA(CLOSE,25)*(1-6/100),MA(LOW,30)*(1-15/100),5,0),color0099ff;LC:=REF(HIGH,1);
RSI0:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;
RSI1:=(SMA(MAX(CLOSE-LC,0),8,1))/(SMA(ABS(CLOSE-LC),8,1))*100;
RSI2:(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100,PRECISION2;
RSI3:(SMA(MAX(CLOSE-LC,0),21,1))/(SMA(ABS(CLOSE-LC),21,1))*100,PRECISION2;
RSI4:(SMA(MAX(CLOSE-LC,0),34,1))/(SMA(ABS(CLOSE-LC),34,1))*100,PRECISION2;
YRSI1:(SMA(MAX(CLOSE-LC,0),55,1))/(SMA(ABS(CLOSE-LC),55,1))*100,PRECISION2;
YRSI2:(SMA(MAX(CLOSE-LC,0),89,1))/(SMA(ABS(CLOSE-LC),89,1))*100,PRECISION2;
YRSI3:(SMA(MAX(CLOSE-LC,0),133,1))/(SMA(ABS(CLOSE-LC),133,1))*100,PRECISION2;
SZ1:=RSI1-RSI2;
SZ2:=RSI2-RSI3;
SZ3:=RSI3-RSI4;
SZ4:=RSI4-YRSI1;
SZ5:=ABS(YRSI1-YRSI2);
SZ6:=ABS(YRSI2-YRSI3);
ZSZ7:=SZ1+SZ2+SZ3+SZ4+SZ5+SZ6;
DSZ1:=RSI1-RSI3;
DSZ2:=RSI2-RSI4;
DSZ3:=RSI3-YRSI1;
DSZ4:=RSI4-YRSI3;
DSZ5:=DSZ1+DSZ2+DSZ3+DSZ4;
绿色:=DSZ4>=-0.5 AND DSZ5>7 OR DSZ4>=0 AND DSZ5>11 OR DSZ4>=1 AND DSZ5>13 OR DSZ4>=2 AND DSZ5>15 OR DSZ4>=3 AND DSZ5>18 OR DSZ4>=4 AND DSZ5>21 OR DSZ4>=5 AND DSZ5>24 OR DSZ4>=6 AND DSZ5>27 OR DSZ4>=7 AND DSZ5>30 OR DSZ4>=8 AND DSZ5>35 OR DSZ4>=9 AND DSZ5>40 OR DSZ4>=10 AND DSZ5>45 OR DSZ4>=11 AND DSZ5>50 OR DSZ4>=12 AND DSZ5>55 OR DSZ4>=13 AND DSZ5>60 OR DSZ4>=14 AND DSZ5>65 OR DSZ4>=15 AND DSZ5>70 OR DSZ4>=16 AND DSZ5>75 OR DSZ4>=17 AND DSZ5>80;
红色:=DSZ4>=-0.5 AND DSZ4<1.5 AND DSZ5>13 OR DSZ4>=0 AND DSZ4<1 AND DSZ5>15 OR DSZ4>=1 AND DSZ4<2 AND DSZ5>17 OR DSZ4>=2 AND DSZ4<3 AND DSZ5>19 OR DSZ4>=3 AND DSZ4<4 AND DSZ5>21 OR DSZ4>=4 AND DSZ4<5 AND DSZ5>24 OR DSZ4>=5 AND DSZ4<6 AND DSZ5>30 OR DSZ4>=6 AND DSZ4<7 AND DSZ5>38;
昨1:=RSI1-REF(RSI1,1);
昨2:=RSI2-REF(RSI2,1);
昨3:=RSI3-REF(RSI3,1);
昨4:=RSI4-REF(RSI4,1);
昨5:=YRSI1-REF(YRSI1,1);
昨6:=YRSI2-REF(YRSI2,1);
昨7:=YRSI3-REF(YRSI3,1);
昨合:=昨1+昨2+昨3+昨4+昨5+昨6+昨7;
数值1:=RSI1-REF(RSI1,1);
昨1:=RSI1-REF(RSI1,1);
昨2:=RSI2-REF(RSI2,1);
昨3:=RSI3-REF(RSI3,1);
昨4:=RSI4-REF(RSI4,1);
昨5:=YRSI1-REF(YRSI1,1);
昨6:=YRSI2-REF(YRSI2,1);
昨7:=YRSI3-REF(YRSI3,1);
昨合:=昨1+昨2+昨3+昨4+昨5+昨6+昨7;
涨停条件1:=SZ1>SZ2 AND SZ2>SZ3 AND SZ3>SZ4 AND SZ4>SZ5;
{www.gupang.com 股旁网_飞狐股票指标公式}
涨停条件21:=(SZ5>=0 AND SZ5<=1 OR SZ6>=0 AND SZ6<=1) AND ZSZ7>=11 OR (SZ5>=1 AND SZ5<=2 OR SZ6>=1 AND SZ6<=2) AND ZSZ7>=18 OR (SZ5>=2 AND SZ5<=3 OR SZ6>=2 AND SZ6<=3) AND ZSZ7>=26 OR (SZ5>=3 AND SZ5<=4 OR SZ6>=3 AND SZ6<=4) AND ZSZ7>=32 OR (SZ5>=4 AND SZ5<=5 OR SZ6>=4 AND SZ6<=5) AND ZSZ7>=38 OR (SZ5>=5 AND SZ5<=6 OR SZ6>=5 AND SZ6<=6) AND ZSZ7>=42;
涨停条件22:=(SZ5>=0 AND SZ5<=0.5 OR SZ6>=0 AND SZ6<=0.5) AND ZSZ7>=11 OR (SZ5>=1 AND SZ5<=1.5 OR SZ6>=1 AND SZ6<=1.5) AND ZSZ7>=18 OR (SZ5>=2 AND SZ5<=2.5 OR SZ6>=2 AND SZ6<=2.5) AND ZSZ7>=26 OR (SZ5>=3 AND SZ5<=3.5 OR SZ6>=3 AND SZ6<=3.5) AND ZSZ7>=32 OR (SZ5>=4 AND SZ5<=4.5 OR SZ6>=4 AND SZ6<=4.5) AND ZSZ7>=38 OR (SZ5>=5 AND SZ5<=5.5 OR SZ6>=5 AND SZ6<=5.5) AND ZSZ7>=42;
涨停条件23:=(SZ5>=0 OR SZ6>=0) AND ZSZ7>=11 OR (SZ5>=1 OR SZ6>=1) AND ZSZ7>=18 OR (SZ5>=2 OR SZ6>=2) AND ZSZ7>=26 OR (SZ5>=3 OR SZ6>=3) AND ZSZ7>=32 OR (SZ5>=4 OR SZ6>=4) AND ZSZ7>=38 OR (SZ5>=5 OR SZ6>=5) AND ZSZ7>=42;
SZ1:=RSI1-RSI2;
SZ2:=RSI2-RSI3;
SZ3:=RSI3-RSI4;
SZ4:=RSI4-YRSI1;
SZ5:=ABS(YRSI1-YRSI2);
SZ6:=ABS(YRSI2-YRSI3);
ZSZ7:=SZ1+SZ2+SZ3+SZ4+SZ5+SZ6;
DSZ1:=RSI1-RSI3;
DSZ2:=RSI2-RSI4;
DSZ3:=RSI3-YRSI1;
DSZ4:=RSI4-YRSI3;
DSZ5:=DSZ1+DSZ2+DSZ3+DSZ4;
涨停条件3:=昨合>35 AND 昨7>0.99;
强使攻击:=RSI1>36 AND RSI2>34 AND RSI3>30 AND RSI4>28 AND YRSI1>25 AND YRSI2>23 AND YRSI3>21;
SZ8:=SZ1>SZ2 AND SZ2>SZ3 AND SZ3>SZ5 AND SZ4<SZ6;
涨停条件1:=SZ1>SZ2 AND SZ2>SZ3 AND SZ3>SZ4 AND SZ4>SZ5;
连续涨停1:=(SZ5>0.8 OR SZ6>0.8) AND SZ4>SZ5 AND SZ3>2.7 AND SZ2>3.8 AND SZ1>6 OR (SZ5>0.1 OR SZ6>0.1) AND
SZ4>SZ5 AND SZ3>1 AND SZ2>2 AND SZ1>3 OR (SZ5>-0.9999 OR SZ6>-0.999) AND SZ4>SZ5 AND SZ3>1 AND SZ2>2 AND SZ1>3 AND RSI1>20 AND RSI2>20 AND RSI4>20 AND YRSI1>20 AND YRSI2>20 AND YRSI3>20;
花1:=RSI1>=RSI2 AND RSI2>=RSI3 AND RSI3>=RSI4 AND RSI4>=YRSI1 AND YRSI1>=YRSI2 AND YRSI2>=YRSI3;
花2:=SZ1>=SZ2 AND SZ2>=SZ3 AND SZ3>=SZ4 AND SZ4>=SZ5 AND SZ5>=SZ6;
穿越日1:=CROSS(RSI1,20) OR CROSS(RSI1,18) OR CROSS(RSI1,17.5);
穿越日2:=CROSS(RSI2,20) OR CROSS(RSI2,18) OR CROSS(RSI1,17.5);
穿越日3:=(穿越日1 OR 穿越日2) AND (CROSS(RSI1,RSI3) OR CROSS(RSI1,RSI2) OR CROSS(RSI2,RSI3));
穿越周1:=CROSS(RSI4,20) OR CROSS(RSI4,18) OR CROSS(RSI4,17.5);
穿越周2:=CROSS(YRSI1,20) OR CROSS(YRSI1,18) OR CROSS(RSI4,17.5);
穿越周3:=(穿越周1 OR 穿越周2) AND (CROSS(RSI4,YRSI2) OR CROSS(RSI4,YRSI1) OR CROSS(YRSI1,YRSI2));
穿越周4:=CROSS(RSI4,YRSI2) OR CROSS(RSI4,YRSI1) OR CROSS(YRSI1,YRSI2);
穿越月1:=CROSS(YRSI1,20) OR CROSS(YRSI1,18) OR CROSS(YRSI1,17);
穿越月2:=CROSS(YRSI2,20) OR CROSS(YRSI2,18) OR CROSS(YRSI1,17);
穿越月3:=(穿越月1 OR 穿越月2) AND (CROSS(YRSI1,YRSI3) OR CROSS(YRSI1,YRSI2) OR CROSS(YRSI2,YRSI3)) OR CROSS(YRSI1,YRSI2) AND CROSS(YRSI2,YRSI3);
穿越月4:=CROSS(YRSI1,YRSI2) OR CROSS(YRSI2,YRSI3);
STICKLINE(花1 AND RSI1>REF(RSI1,1),20,22,5,0),colorFFFFFF;
STICKLINE(花1 AND SZ8 AND SZ1<SZ5*19 OR 花1 AND 花2 AND 连续涨停1 OR 花1 AND 强使攻击 AND RSI1>REF(RSI1,1),20,22,9,0),colorFF00FF;
STICKLINE(花1 AND 花2 AND SZ1<SZ5*19,20,22,10,0),colorFF;
STICKLINE(连续涨停1 AND SZ1<SZ5*15 AND RSI1>REF(RSI1,1),20,22,5,0),color80;
STICKLINE(花1 AND SZ8 AND 连续涨停1 OR 花1 AND 强使攻击 AND RSI1>REF(RSI1,1),20,22,5,0),colorFF00;
STICKLINE(花1 AND 花2 AND 连续涨停1 OR 花1 AND 强使攻击 AND RSI1>REF(RSI1,1),20,22,5,0),colorFFFF;
DRAWNUMBER(昨合>28,20,昨合,0),ALIGN4,colorFFFFFF;
DRAWNUMBER(昨合>39 AND 昨7>0.8,20,昨合,0),ALIGN4,colorFF00FF;
DRAWNUMBER(昨合>40 AND 昨7>0.98,20,昨合,0),ALIGN4,colorFF;
DRAWNUMBER(RSI1-REF(RSI1,1)>5,RSI1*1.1,RSI1-REF(RSI1,1),0),ALIGN0,colorFF00;
DRAWNUMBER(昨合>20,20,昨7,1),ALIGN5,colorFFFF;
DRAWNUMBER(昨合>30,21,昨7,1),ALIGN5,colorFF;
DRAWTEXT(涨停条件1 AND 涨停条件3 AND 涨停条件23,RSI1*1.3,'涨'),ALIGN0,colorFFFFFF;
DRAWTEXT(涨停条件1 AND 涨停条件3 AND 涨停条件22,RSI1*1.3,'涨'),ALIGN0,colorFFFF;
DRAWTEXT(涨停条件1 AND 涨停条件3 AND 涨停条件21,RSI1*1.3,'涨'),ALIGN0,colorFF;
STICKLINE(数值1>8,REF(RSI1,1)*1.3,RSI1*0.95,3,0),colorFF00;
STICKLINE(数值1>8 AND RSI1>10,REF(RSI1,1)*1.3,RSI1*0.95,1,1);
STICKLINE(绿色 AND RSI1>REF(RSI1,1) AND CLOSE>OPEN AND 数值1>8 AND RSI1>8,REF(RSI1,1)*1.3,RSI1*0.95,6,0),colorFF00FF;
STICKLINE(红色 AND RSI1>REF(RSI1,1) AND CLOSE>OPEN AND 数值1>3 AND RSI1>5,REF(RSI1,1)*1.3,RSI1*0.95,4,0),color80;
STICKLINE(红色 AND RSI1>REF(RSI1,1) AND CLOSE>OPEN AND 数值1>8 AND RSI1>8,REF(RSI1,1)*1.3,RSI1*0.95,6,0),colorFF;
STICKLINE(红色 AND 绿色 AND RSI1>REF(RSI1,1) AND CLOSE>OPEN AND 数值1>8 AND RSI1>10,REF(RSI1,1)*1.3,RSI1*0.95,2,1),colorFFFF;
DRAWICON(穿越日3 AND CROSS(RSI1,20) AND CROSS(RSI2,20),15,10);
DRAWICON(穿越日3 AND 穿越周3,15,10);
DRAWICON(穿越日3 AND 穿越周4 AND 穿越月4,15,10);
DRAWICON(穿越日3 AND 穿越周3 AND 穿越月3,15,'x7');
半仓:=穿越日3 AND 穿越周4 AND 穿越月4 AND 花1 AND 花2 AND 连续涨停1 AND SZ1<SZ5*19;
满仓:=穿越周3 AND 穿越月3;
DRAWTEXT(半仓 AND 满仓=0,RSI1*1.5,'小'),ALIGN0,colorFFFF;
DRAWTEXT(满仓 AND 半仓,RSI1*1.5,'大'),ALIGN0,colorFF00;
20 LINEDOT;
30 LINEDOT;
65 LINEDOT;

飞狐超级RSI指标公式

 

相关文章