在线检测未来函数

大智慧长短线RSI+顶底背离指标公式

来源:Internet,编辑:股旁网,2012-09-02

指标提示加减仓,进场和出局,源码中用到未来函数,用于判断背离,不影响使用。

LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORRED;
RSI2:SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100,LINETHICK2,COLORGREEN;
R1:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
R2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
VAR1:=4*SMA(R1,5,1)-3*SMA(SMA(R1,5,1),3.2,1);
VAR2:=24;
IF(CROSS(VAR1,VAR2),10,0),STICK,COLORRED;
DRAWTEXT(CROSS(VAR1,VAR2),10,'加'),COLOREEFF00;
VAR3:= 4*SMA(R1,5,1)-3*SMA(SMA(R1,5,1),3,1);
STICKLINE(CROSS(80,VAR3),100,90,3,0),COLORFFF666;
DRAWTEXT(CROSS(80,VAR3),100,'减'), COLOREEFF00;
VAR4:= 4*SMA(R2,5,1)-3*SMA(SMA(R2,5,1),3,1);
STICKLINE(CROSS(72,VAR4),110,100,3,0),STICK,COLORRED;
DRAWTEXT(CROSS(72,VAR4),105,'出局'), COLOREEFF00;
VAR5:=4*SMA(R2,5,1)-3*SMA(SMA(R2,5,1),3.2,1);
VAR6:=38;
IF(CROSS(VAR5,VAR6),15,0),STICK,COLORRED;
DRAWTEXT(CROSS(VAR5,VAR6),18,'进场'), COLOREEFF00;
AA:=REF(RSI1,3)=HHV(RSI1,2*3+1);
BB:=BACKSET(AA,3+1);
CC:=FILTER(BB,3) AND RSI1=HHV(RSI1,3+1);
A1:=BARSLAST(REF(CC,1));
背离:=REF(CLOSE,A1+1)<CLOSE AND REF(RSI1,A1+1)>RSI1 AND CC;
DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORCYAN,LINETHICK2;
AA2:=REF(RSI1,3)=LLV(RSI1,2*3+1);
BB2:=BACKSET(AA2,3+1);
CC2:=FILTER(BB2,3) AND RSI1=LLV(RSI1,3+1);
AA2A:=BARSLAST(REF(CC2,1));
底背离:=REF(C,AA2A+1)>CLOSE AND REF(RSI1,AA2A+1)<RSI1 AND CC2;
DRAWLINE(CC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORMAGENTA,LINETHICK2;
DRAWTEXT(顶背离,RSI1*1.02,' -顶背'),COLORMAGENTA;
DRAWTEXT(底背离,RSI1*1.05,' -底背'),COLORMAGENTA;
{www.gupang.com 股旁网_大智慧股票指标公式}
AA00:=REF(RSI2,3)=HHV(RSI2,2*3+1);
BB00:=BACKSET(AA00,3+1);
CC00:=FILTER(BB00,3) AND RSI2=HHV(RSI2,3+1);
A11:=BARSLAST(REF(CC00,1));
顶背离1:=REF(CLOSE,A11+1)<CLOSE AND REF(RSI2,A11+1)>RSI2 AND CC00;
DRAWLINE(CC00,RSI2,FILTER(顶背离1>0,5),RSI2,0),COLORwhite,LINETHICK2;
AA22:=REF(RSI2,3)=LLV(RSI2,2*3+1);
BB22:=BACKSET(AA22,3+1);
CC22:=FILTER(BB22,3) AND RSI2=LLV(RSI2,3+1);
AA22A:=BARSLAST(REF(CC22,1));
底背离1:=REF(C,AA22A+1)>CLOSE AND REF(RSI2,AA22A+1)<RSI2 AND CC22;
DRAWLINE(CC22,RSI2,FILTER(底背离1>0,5),RSI2,0),COLORRED,LINETHICK2;
DRAWTEXT(顶背离1,RSI2*1.02,' -顶背'),COLORMAGENTA;
DRAWTEXT(底背离1,RSI2*1.05,' -底背'),COLORMAGENTA;
100,POINTDOT;
80,POINTDOT;
50,POINTDOT;
20,POINTDOT;
0,POINTDOT;

大智慧长短线RSI+顶底背离指标公式

 

相关文章