在线检测未来函数

同花顺搏杀持股主图指标公式

来源:Internet,编辑:股旁网,2012-09-03

VAR4:=(LOW+HIGH+CLOSE)/3;
操作: MA(VAR4,5),LINETHICK2,colorwhite;
拉升:HHV(操作,13),colorred,LINETHICK1;
压力:HHV(操作,60),colorred;
//{www.gupang.com 股旁网_同花顺股票指标公式}
买卖:LLV(操作,13),LINETHICK1,COLOR00FF00;
底部支撑: LLV(LOW,60)*1.02,color00CCFF;
顶部: HHV(HIGH,60)*0.98,colorFFFFCC;
STICKLINE(操作>REF(操作,1),操作,操作+0.018,5,0),coloryellow,LINETHICK4;
STICKLINE(拉升>REF(拉升,1),拉升,拉升+0.018,5,0),coloryellow,LINETHICK2;
STICKLINE(拉升=REF(拉升,1),拉升,拉升,1,1),colorred;
STICKLINE(买卖=REF(买卖,1),买卖,买卖,1,1),colorred;
STICKLINE(买卖>REF(买卖,1),买卖,买卖+0.028,4,1),COLORF00FF0,LINETHICK2;
STICKLINE(顶部=REF(顶部,1),顶部,顶部,7,1),colorred;
STICKLINE(压力=REF(压力,1),压力,压力,7,1),colorred;
STICKLINE(底部支撑=REF(底部支撑,1),底部支撑,底部支撑,1,1),colorred; VAR0:=(CLOSE*2+HIGH+LOW)/4*vol;
var1:=SUM(VAR0,89)/SUM(vol,89);
var21:=IF(COUNT(VAR0>0,2)>=2,MA(CLOSE,89)*(1+(MA(VAR0,89)/REF(MA(VAR0,89),1)-1)/21),MA(CLOSE,89));
var3:=IF(COUNT(ABS(CLOSE-var1)>21,8)>=1 AND COUNT(CLOSE/REF(CLOSE,1)<0.8,8)<1 AND COUNT(VAR0>0,2)>=2,10,0);
var4:=IF(CLOSE>=var1 AND COUNT(VAR0>0,2)>=2,var1*1.001,IF(VAR0<0.1 AND COUNT(VAR0>0,2)<1.5,MA(CLOSE,89),var1*0.999));
var5:=IF(var3>0,var21,var4);
var6:=MA(CLOSE,89);
生命线:IF(var5/REF(var5,1)>1.1 OR var5/REF(var5,1)<0.9,VAR6,VAR5),colorff80ff,linethick2;
持股线FL:hhv(ma(C,17),2),color00ff00;
FS:if(ma(C,17)<持股线FL,(ma(C,17)-(持股线FL-ma(C,17))),持股线FL),color80ffff,linethick2;
CG:ma(C,17),linethick2,colorf4e202;
var2:=MA((OPEN+CLOSE+HIGH+LOW)/4,46);
aa:=(CLOSE>var2 AND CLOSE>MA(CLOSE, 5)) or (c<var2 and c>ma(c,5) and c>FS);
bb:=(CLOSE<var2 and c<ma(c,5)) or (c>var2 and c<ma(c,5));
cc:=if(aa and bb,0,1);
STICKLINE(cc,CLOSE,OPEN,8,1),COLORYELLOW;
STICKLINE(cc,HIGH,max(c,o),0.8,0),COLORYELLOW;
STICKLINE(cc,min(c,o),LOW,0.8,0),COLORYELLOW;
STICKLINE(aa,CLOSE,OPEN,8,0),COLORRED;
STICKLINE(aa,HIGH,LOW,0.8,0),COLORRED;
STICKLINE(bb,CLOSE,OPEN,8,0),COLORGREEN;
STICKLINE(bb,HIGH,LOW,0.8,0),COLORGREEN;
价上持股线:=CROSS(CLOSE,持股线FL);
持股穿生命:=CROSS(持股线FL,生命线);
价上生命线:=CROSS(CLOSE,生命线);
DRAWTEXT(CROSS(CLOSE,持股线FL),(LOW* 0.98),'▲'),LINETHICK0,colorYELLOW;
DRAWTEXT(CROSS(CLOSE,持股线FL),(LOW * 0.95),'上'),LINETHICK3,colorYELLOW;
DRAWTEXT(CROSS(CLOSE,持股线FL),(LOW * 0.92),'持'),LINETHICK3,colorYELLOW;
DRAWTEXT(CROSS(CLOSE,持股线FL),(LOW * 0.89),'股'),LINETHICK3,colorYELLOW;
DRAWTEXT(CROSS(CLOSE,持股线FL),(LOW * 0.86),'线'),LINETHICK3,colorYELLOW;
DRAWTEXT(CROSS(CLOSE,生命线),(LOW * 0.98),'▲'),LINETHICK2,colorFF00FF;
DRAWTEXT(CROSS(CLOSE,生命线),(LOW * 0.95),'上'),LINETHICK3,colorFF00FF;
DRAWTEXT(CROSS(CLOSE,生命线),(LOW * 0.92),'生'),LINETHICK3,colorFF00FF;
DRAWTEXT(CROSS(CLOSE,生命线),(LOW * 0.89),'命'),LINETHICK3,colorFF00FF;
DRAWTEXT(CROSS(CLOSE,生命线),(LOW * 0.86),'线'),LINETHICK3,colorFF00FF;
//{www.gupang.com 股旁网_同花顺股票指标公式}
DRAWTEXT(CROSS(持股线FL,生命线),(LOW * 0.98),'▲'),LINETHICK5,color00FF00;
DRAWTEXT(CROSS(持股线FL,生命线),(LOW * 0.85),'交叉'),LINETHICK3,color00FF00;
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL1:=REF(CLOSE,2);
MM:=((SMA(MAX((CLOSE - LL1),0),6,1) / SMA(ABS((CLOSE - LL1)),6,1)) * 100);
DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);
DRAWTEXT(CROSS(Y,X),(LOW * 0.985),'▲'),LINETHICK2,colorred;
DRAWTEXT(CROSS(Y,X),(LOW * 0.90),'买'),LINETHICK3,colorred;
DRAWTEXT(DB,(HIGH * 1.02),'●出货'),LINETHICK2,color00ff00;

飞狐搏杀持股主图指标公式

 

相关文章