在线检测未来函数

大智慧心想事成主图指标公式

来源:Internet,编辑:股旁网,2012-09-04

ema13:ema(c,13),colorwhite,linethick2;
ema34:ema(c,34),coloryellow;
ema55:ema(c,55),colorff00ff;
ema120:ema(c,120),colorffcc66;
ar1:=ema55>ema34 and ema34>ema13;
ar2:=BARSLAST((c-ema13)/ema13*100<-6);
ar3:=ema13>=ref(ema13,2);
ar4:=count(cross(c,ema13),ar2)=1;
ar5:=ar1 and ar2 and ar3 and ar4;
ar6:=ar5 and filter(ar5,10);
drawtext(ar6,l-0.09,'红杏出墙'),coloryellow;
stickline(ar6,h,l,0.5,1),coloryellow;
stickline(ar6,o,c,6,1),linethick2,coloryellow;
br1:=count(BETWEEN((c-ref(c,1))/ref(c,1)*100,0,5) ,5)=5;
br2:=abs((ema13-ema34)+(ema34-ema55))/c<0.2;
br3:=c>ema55 and (ref(c,1)<ref(ema55,1) or ref(c,2)<ref(ema55,2) or ref(c,3)<ref(ema55,3) or ref(c,4)<ref(ema55,4) or ref(c,5)<ref(ema55,5));
br4:=br1 and br2 and br3;
{www.gupang.com 股旁网_大智慧股票指标公式}
drawtext(br4 and filter(br4,10),l-0.09,'蚂蚁上树'),color00C5FF;
stickline(br4 and filter(br4,10),h,l,0.5,1),color00C5FF;
stickline(br4 and filter(br4,10),o,c,6,1),linethick2,color00C5FF;
cr1:=(c-ref(c,1))/ref(c,1)*100>0.5;
cr2:=v>ma(v,5)*0.6;
cr3:=count(cross(ema13,ema55),3)=1;
cr4:=abs(ema34-ema55)/ema55<0.03;
cr5:=ema55<=ema120 and ema55>=ref(ema55,1);
cr6:=FILTER(cr1 and cr2 and cr3 and cr4 and cr5,2);
stickline(cr6,h,l,0.5,1),colorf00ff0;
stickline(cr6,o,c,6,1),linethick2,colorf00ff0;
drawtext(cr6,l-0.09,'红衣侠女'),colorf00ff0;
dr1:=ema13>ema34 and ema34<ema55;
dr2:=BARSLAST(cross(c,ema55) );
dr3:=h=hhv(h,dr2);
dr4:=BARSLAST(dr3);
dr5:=count(o>c and c<ref(c,1) and c>ema55 and BETWEEN((c-ema55)/ema55,0,0.02),dr4)=1;
dr6:=c>ref(c,1) ;
dr7:= dr1 and dr5 and dr6 ;
dr8:=dr7 and FILTER(dr7 ,10);
drawtext(dr8,l-0.09,'黑客点击'),colord6ba63;
stickline(dr8,h,l,0.5,1),colord6ba63;
stickline(dr8,o,c,6,1),linethick2,colord6ba63;
er:=barslast(ref(cross(ema55,ema34),1)) and cross(ema34,ema55);
DRAWTEXT(er,l-0.09,'均线互换'),color0099ff;
stickline(er,h,l,0.5,1),color0099ff;
stickline(er,o,c,6,1),linethick2,color0099ff;
fr:=barslast(ref(cross(ema34,ema13),1)) and cross(ema13,ema34);
DRAWTEXT(fr,l-0.09,'梅开二度'),colorwhite;
stickline(fr,h,l,0.5,1),colorwhite;
stickline(fr,o,c,6,1),linethick2,colorwhite;
gr1:=BARSLAST(BETWEEN("bias.bias2"(6,13,24),0,5) );
gr2:=ema13>ema34 and ema34>ema55 and ema13>ref(ema13,1);
gr3:=count("bias.bias2"(6,13,24)>10 and h=hhv(h,gr1),gr1);
gr4:=h=hhv(h,gr1);
gr5:="macd.macd"(12,26,9)<ref("macd.macd"(12,26,9),1);
gr6:=gr2 and gr3 and gr4;
gr7:=gr2 and gr3 and gr4 and gr5;
drawtext(gr6 and gr7,h+0.13,''),color00ff00;
stickline(gr6 and gr7,h,h+0.09,4,0),color00ff00;
hr2:=ema13>=ref(ema13,3) and ema34>=ref(ema34,1) and ema55>=ref(ema55,1) and cross(c,ema13) and cross(c,ema34) and cross(c,ema55);
DRAWTEXT(hr2 and filter(hr2,10),l-0.09,'三线推进'),colorFFC8FF;
stickline(hr2 and filter(hr2,10),h,l,0.5,1),colorFFC8FF;
stickline(hr2 and filter(hr2,10),o,c,6,1),linethick2,colorFFC8FF;
阴线一:=AMOUNT/V/7.1;
阴线二:=(3*H+LOW+O+2*C)/7.1;
阴线三:=SUM(AMOUNT,51)/阴线一/7.1;
大阴线:=DMA(阴线二,V/阴线三);
洗盘:=(C-大阴线)/大阴线*100;
DRAWTEXT(CROSS(-1.99,洗盘),l*0.995,'←洗盘尾声'),COLORF00FF0;
VAR1:=REF(C,1);
VAR15:=SMA(MAX(C-VAR1,0),7,1)/SMA(ABS(C-VAR1),7,1)*100;
STICKLINE(CROSS(78,VAR15),C,O,7,1) ,COLORBLUE,LINETHICK1;
DRAWTEXT(CROSS(78,VAR15),H*1.001,'↓止赢') ,COLOR00FFFF,LINETHICK1;

大智慧心想事成主图指标公式

 

相关文章