在线检测未来函数

飞狐K线形态带解盘主图指标公式

来源:Internet,编辑:股旁网,2012-09-05

JJ:=((o+c+l+h)/4)linethick0;
ZZ:=(AMOUNT/vol/100)linethick0;
风卷残云:=ref(C<ref(C,2),1)and ref(C<O,2)AND C>REF(h,1)AND ref(O>ref(C,2),4)and C>O ;
JP1:=IF(风卷残云>0,'风卷残云','');
映日荷花:=O<ref(C,1)AND C>ref(jj,1)and C<O and ref(c>O,2);
JP2:=IF(风卷残云>0,'映日荷花','');
葵花向阳:=C>=ref(h,1)and ref(c<O,1)and C>O ;
JP3:=IF(葵花向阳>0,'葵花向阳','');
春燕啄泥:=ref(C<O,1) and C<ref(O,1)and C=O and c>jj;
JP4:=IF(春燕啄泥>0,'春燕啄泥','');
九天射阳:=ref(C>O,1) and C>ref(O,1)and C=jj and C>O ;
JP5:=IF(九天射阳>0,'九天射阳','');
春光乍泄:=ref(C<O,1) and C<ref(O,1)and C>ref(jj,1)and O<ref(c,1) ;
JP6:=IF(春光乍泄>0,'春光乍泄','');
孤翁独钓:=ref(C<O,1) and o>ref(c,1)and h<ref(o,1) and C>O ;
JP7:=IF(孤翁独钓>0,'孤翁独钓','');
落日残阳:=ref(C>O,1)and c>ref(jj,1)and h<ref(C,1)and C>o;
JP8:=IF(落日残阳>0,'落日残阳','');
江河浩荡:= REF(c>o,1)and C<ref(l,1)and zz<ref(l,1);
JP9:=IF(江河浩荡>0,'江河浩荡','');
雨打浮萍:=REF(c>o,1)and O<=ref(c,1)and zz<=ref(jj,1)and C>ref(o,1)and C<O;
JP10:=IF(雨打浮萍>0,'雨打浮萍','');
星星之火:=ref(C<O,1)and O>=jj and C>O;
JP11:=IF(星星之火>0,'星星之火','');
一泄千里:=ref(C<O,1)and o=h and C<o;
JP12:=IF(一泄千里>0,'一泄千里','');
喷薄而出:=ref(C<O,1)and ref(O<ref(c,1),2) and zz>ref(zz,1)and c>REF(h,1);
JP13:=IF(喷薄而出>0,'喷薄而出','');
红旗漫卷:=ref(O>jj,1)and c>ref(h,1)and ref(c>o,1) ;
JP14:=IF(红旗漫卷>0,'红旗漫卷','');
一触即发:=ref(c<o,1)and C>ref(h,1)and C>O;
JP15:=IF(一触即发>0,'一触即发','');
一手遮天:=ref(c<O,1)and C>ref(h,1)and L<ref(c,1);
JP16:=IF(一手遮天>0,'一手遮天','');
螳臂挡车:=ref(c>O,1)and H<ref(l,1)and C>O;
JP17:=IF(螳臂挡车>0,'螳臂挡车','');
回天无力:=ref(c>O,1)and O=ref(c,1)and C<O and ref(C<o,3);
JP18:=IF(回天无力>0,'回天无力','');
回光返照:=ref(c<O,1)and ref(c<O,2)and ref(c<O,3) and ref(C<o,4)and C>ref(h,4);
JP19:=IF(回光返照>0,'回光返照','');
覆巢而下:=ref(c>O,1)and ref(h=O,2)and O<ref(c,1)and C<O and H<ref(c,1) ;
JP20:=IF(覆巢而下>0,'覆巢而下','');
水漫金山:=ref(c>o,1)and ref(C<ref(c,1),2)and C<o and c<ref(l,1);
JP21:=IF(水漫金山>0,'水漫金山','');
惨淡经营:=ref(c>o,1)and o<= ref(o,1)and c<ref(l,1)and C<o ;
JP22:=IF(惨淡经营>0,'惨淡经营','');
芝麻开花:=ref(c<JJ,1)and o>ref(h,1)and C>o ;
JP23:=IF(芝麻开花>0,'芝麻开花','');
背水一战:=ref(C>ref(o,1),2)and ref(l<ref(l,1),2)and O>ref(c,2);
JP24:=IF(背水一战>0,'背水一战','');
直上青云:=ref(c<o,1)and ref(C>ref(h,1),2)and C>O and L>ref(c,1);
{www.gupang.com 股旁网_飞狐股票指标公式}
JP25:=IF(直上青云>0,'直上青云','');
弹剑长啸:=ref(c<o,1)and O=ref(O,1)and C>o;
JP26:=IF(弹剑长啸>0,'弹剑长啸','');
天高云淡:=ref(c>o,1)and O>ref(h,1)and C<o and L>ref(c,1);
JP27:=IF(天高云淡>0,'天高云淡','');
蚂蚁撼树:=ref(c<o,1)and O=H and C<jj and C>ref(c,1);
JP28:=IF(蚂蚁撼树>0,'蚂蚁撼树','');
更上层楼:=ref(C<O,1)and C>ref(h,2)and O<ref(C,1)and C>O;
JP29:=IF(更上层楼>0,'更上层楼','');
浪子回头:=ref(C<O,1)and o>ref(o,1)and C>O;
JP30:=IF(浪子回头>0,'浪子回头','');
忍辱负重:=ref(C>O,1)and o<ref(c,1)and l>ref(jj,1);
JP31:=IF(忍辱负重>0,'忍辱负重','');
极目楚天:=ref(C>O,1)and o=ref(o,1)and c>ref(h,1);
JP32:=IF(极目楚天>0,'极目楚天','');
强势攀登:=ref(C=l,1)and c=h and jj>ref(jj,1);
JP33:=IF(强势攀登>0,'强势攀登','');
DRAWTEXT(极目楚天>0,l*0.99,'←极目楚天'),COLORYELLOW;
DRAWTEXT(强势攀登>0,l*0.99,'←强势攀登'),COLORYELLOW;
DRAWTEXT(忍辱负重>0,l*0.99,'←忍辱负重'),COLORYELLOW;
DRAWTEXT(浪子回头>0,l*0.99,'←浪子回头'),COLORYELLOW;
DRAWTEXT(更上层楼>0,l*0.99,'←更上层楼'),COLORYELLOW;
DRAWTEXT(蚂蚁撼树>0,l*0.99,'←蚂蚁撼树'),COLORYELLOW;
DRAWTEXT(天高云淡>0,l*0.99,'←天高云淡'),COLORYELLOW;
DRAWTEXT(弹剑长啸>0,l*0.99,'←弹剑长啸'),COLORYELLOW;
DRAWTEXT(直上青云>0,l*0.99,'←直上青云'),COLORYELLOW;
DRAWTEXT(背水一战>0,l*0.99,'←背水一战'),COLORYELLOW;
DRAWTEXT(芝麻开花>0,l*0.99,'←芝麻开花'),COLORYELLOW;
DRAWTEXT(惨淡经营>0,h*1.01,'←惨淡经营'),COLORYELLOW;
DRAWTEXT(水漫金山>0,h*1.01,'←水漫金山'),COLORYELLOW;
DRAWTEXT(覆巢而下>0,h*1.01,'←覆巢而下'),COLORYELLOW;
DRAWTEXT(回光返照>0,h*1.01,'←回光返照'),COLORYELLOW;
DRAWTEXT(回天无力>0,h*1.01,'←回天无力'),COLORYELLOW;
DRAWTEXT(螳臂挡车>0,h*1.01,'←螳臂挡车'),COLORYELLOW;
DRAWTEXT(一手遮天>0,l*0.99,'←一手遮天'),COLORYELLOW;
DRAWTEXT(一触即发>0,l*0.99,'←一触即发'),COLORYELLOW;
DRAWTEXT(红旗漫卷>0,l*0.99,'←红旗漫卷'),Color0000FF;
DRAWTEXT(喷薄而出>0,l*0.99,'←喷薄而出'),COLORYELLOW;
DRAWTEXT(一泄千里>0,H*1.01,'←一泄千里'),COLORYELLOW;
DRAWTEXT(星星之火>0,l*0.998,'←星星之火'),COLORYELLOW;
DRAWTEXT(雨打浮萍>0,H*1.01,'←雨打浮萍'),COLORYELLOW;
DRAWTEXT(江河浩荡>0,H*1.01,'江河浩荡→'),COLORYELLOW,align2;
DRAWTEXT(落日残阳>0,H*1.002,'←落日残阳'),COLORYELLOW;
DRAWTEXT(孤翁独钓>0,LOW*0.99,'←孤翁独钓'),Color0000FF;
DRAWTEXT(春光乍泄>0,LOW*0.99,'←春光乍泄'),Color00FF00;
DRAWTEXT(九天射阳>0,LOW*0.99,'←九天射阳'),ColorC0BBEA;
DRAWTEXT(春燕啄泥>0,LOW*0.99,'←春燕啄泥'),ColorFFFF00;
DRAWTEXT(葵花向阳>0,LOW*0.99,'←葵花向阳'),COLORYELLOW;
DRAWTEXT(映日荷花>0,LOW*0.99,'←映日荷花'),ColorFFC7FF;
DRAWTEXT(风卷残云>0,LOW*1.03,'风卷残云→'),ColorFFFFFF,align2;
JP:=JP1+JP2+JP3+JP4+JP5+JP6+JP7+JP8+JP9+JP10+JP11+JP12+JP13+JP14+JP15+JP16+JP17+JP18+JP19+JP20+JP21+JP22+JP23+JP24+JP25+JP26+JP27+JP28+JP29+JP30+JP31+JP32+JP33;
DRAWTEXTEX(SYSPARAM(1)=BARPOS,0,0,0,JP),ALIGN5,colorFFFF00;
EXPLAIN(SYSPARAM(1)=BARPOS,JP),COLORFFFFCC;

飞狐K线形态带解盘主图指标公式

 

相关文章