在线检测未来函数

大智慧主力吸筹换手指标公式

来源:Internet,编辑:股旁网,2012-09-05

K:=(DATE < 1121230);
XD1:=INDEXO;
XD2:=INDEXH;
XD3:=INDEXL;
XD4:=INDEXC;
对应指数开盘:INDEXO,LINETHICK0,Color0000FF;
盘中最高:INDEXH,LINETHICK0 ;
盘中最低:INDEXL,LINETHICK0 ;
收盘点位:INDEXC,LINETHICK0 ;
大盘流量增减:(100 * ((INDEXV / REF(INDEXV,1)) - 1)),LINETHICK0,ColorFFFF00;
JJ:=(((XD4 + XD2) + XD3) / 3);
A:=EMA(JJ,10);
B:=REF(A,1);
决策价位:B,LINETHICK0;
A1:=EMA(XD4,5);
B1:=EMA(XD4,10);
AA1:=FILTER(((A > B) AND (A1 < B1)),5);
QW:=(0 - ((100 * (HHV(XD2,14) - XD4)) / (HHV(XD2,14) - LLV(XD3,14))));
WR1:=DMA(QW,17);
DDF:=((((DATE <= 1010704) OR ((DATE >= 1011017) AND (DATE <= 1011211))) OR ((DATE >= 1020121) AND (DATE <= 1020712))) OR (DATE >= 1021025));
HJK:="1a0001$CLOSE";
MA1JKK:=MA(HJK,2);
MA2JKK:=MA(HJK,5);
HHKK:=(SMA(("1a0001$AMOUNT" + "399001$AMOUNT"),10,1) / 1000000);
HHHK:=(HHKK * CLOSE);
MA1KK:=MA(HHHK,2);
MA2KK:=MA(HHHK,5);
MSD1:=((("BI29$CLOSE" - LLV("BI29$LOW",34)) / (HHV("BI29$HIGH",34) - LLV("BI29$LOW",34))) * 100);
DDDFFF:=MA(MSD1,3);
MSD2:=((("BI02$CLOSE" - LLV("BI02$LOW",34)) / (HHV("BI02$HIGH",34) - LLV("BI02$LOW",34))) * 100);
ST:=MA(MSD2,3);
MSD3:=((("BI03$CLOSE" - LLV("BI03$LOW",34)) / (HHV("BI03$HIGH",34) - LLV("BI03$LOW",34))) * 100);
上海:=MA(MSD3,3);
MSD4:=((("BI04$CLOSE" - LLV("BI04$LOW",34)) / (HHV("BI04$HIGH",34) - LLV("BI04$LOW",34))) * 100);
深圳:=MA(MSD4,3);
MSD5:=((("BI05$CLOSE" - LLV("BI05$LOW",34)) / (HHV("BI05$HIGH",34) - LLV("BI05$LOW",34))) * 100);
次新:=MA(MSD5,3);
MSD6:=((("BI06$CLOSE" - LLV("BI06$LOW",34)) / (HHV("BI06$HIGH",34) - LLV("BI06$LOW",34))) * 100);
三通:=MA(MSD6,3);
MSD7:=((("BI07$CLOSE" - LLV("BI07$LOW",34)) / (HHV("BI07$HIGH",34) - LLV("BI07$LOW",34))) * 100);
三无:=MA(MSD7,3);
MSD8:=((("BI08$CLOSE" - LLV("BI08$LOW",34)) / (HHV("BI08$HIGH",34) - LLV("BI08$LOW",34))) * 100);
港口:=MA(MSD8,3);
MSD9:=((("BI09$CLOSE" - LLV("BI09$LOW",34)) / (HHV("BI09$HIGH",34) - LLV("BI09$LOW",34))) * 100);
电力:=MA(MSD9,3);
MSD10:=((("BI10$CLOSE" - LLV("BI10$LOW",34)) / (HHV("BI10$HIGH",34) - LLV("BI10$LOW",34))) * 100);
上证180:=MA(MSD10,3);
MSD11:=((("BI11$CLOSE" - LLV("BI11$LOW",34)) / (HHV("BI11$HIGH",34) - LLV("BI11$LOW",34))) * 100);
电脑:=MA(MSD11,3);
MSD12:=((("BI12$CLOSE" - LLV("BI12$LOW",34)) / (HHV("BI12$HIGH",34) - LLV("BI12$LOW",34))) * 100);
金融:=MA(MSD12,3);
MSD13:=((("BI13$CLOSE" - LLV("BI13$LOW",34)) / (HHV("BI13$HIGH",34) - LLV("BI13$LOW",34))) * 100);
房地产:=MA(MSD13,3);
MSD14:=((("BI14$CLOSE" - LLV("BI14$LOW",34)) / (HHV("BI14$HIGH",34) - LLV("BI14$LOW",34))) * 100);
钢铁:=MA(MSD14,3);
MSD15:=((("BI15$CLOSE" - LLV("BI15$LOW",34)) / (HHV("BI15$HIGH",34) - LLV("BI15$LOW",34))) * 100);
电子:=MA(MSD15,3);
MSD16:=((("BI16$CLOSE" - LLV("BI16$LOW",34)) / (HHV("BI16$HIGH",34) - LLV("BI16$LOW",34))) * 100);
纺织:=MA(MSD16,3);
MSD17:=((("BI17$CLOSE" - LLV("BI17$LOW",34)) / (HHV("BI17$HIGH",34) - LLV("BI17$LOW",34))) * 100);
农业:=MA(MSD17,3);
MSD18:=((("BI18$CLOSE" - LLV("BI18$LOW",34)) / (HHV("BI18$HIGH",34) - LLV("BI18$LOW",34))) * 100);
航天航空:=MA(MSD18,3);
MSD19:=((("BI19$CLOSE" - LLV("BI19$LOW",34)) / (HHV("BI19$HIGH",34) - LLV("BI19$LOW",34))) * 100);
家电:=MA(MSD19,3);
MSD20:=((("BI20$CLOSE" - LLV("BI20$LOW",34)) / (HHV("BI20$HIGH",34) - LLV("BI20$LOW",34))) * 100);
汽车:=MA(MSD20,3);
MSD21:=((("BI21$CLOSE" - LLV("BI21$LOW",34)) / (HHV("BI21$HIGH",34) - LLV("BI21$LOW",34))) * 100);
化工:=MA(MSD21,3);
MSD22:=((("BI22$CLOSE" - LLV("BI22$LOW",34)) / (HHV("BI22$HIGH",34) - LLV("BI22$LOW",34))) * 100);
科技板块:=MA(MSD22,3);
MSD23:=((("BI23$CLOSE" - LLV("BI23$LOW",34)) / (HHV("BI23$HIGH",34) - LLV("BI23$LOW",34))) * 100);
造纸:=MA(MSD23,3);
MSD24:=((("BI24$CLOSE" - LLV("BI24$LOW",34)) / (HHV("BI24$HIGH",34) - LLV("BI24$LOW",34))) * 100);
石油化工:=MA(MSD24,3);
MSD25:=((("BI25$CLOSE" - LLV("BI25$LOW",34)) / (HHV("BI25$HIGH",34) - LLV("BI25$LOW",34))) * 100);
网络概念:=MA(MSD25,3);
MSD26:=((("BI26$CLOSE" - LLV("BI26$LOW",34)) / (HHV("BI26$HIGH",34) - LLV("BI26$LOW",34))) * 100);
医药板块:=MA(MSD26,3);
MSD28:=((("BI28$CLOSE" - LLV("BI28$LOW",34)) / (HHV("BI28$HIGH",34) - LLV("BI28$LOW",34))) * 100);
西部概念:=MA(MSD28,3);
{www.gupang.com 股旁网_大智慧股票指标公式}
V1:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(DDDFFF,ST),上海),深圳),次新),三通),三无),港口),电力),上证180),电脑),金融),房地产),钢铁),电子),纺织),农业),航天航空),家电),汽车),化工),科技板块),造纸),石油化工),网络概念),医药板块),西部概念);
H1:=INDEXA;
VAR2HGG:=(((INDEXC + INDEXL) + INDEXH) / 3);
XHH:=((INDEXA / INDEXV) / 100);
{短线MACD}
VAR1:=EMA(CLOSE,12)-EMA(CLOSE,26);
VAR2:=EMA(VAR1,50);
VAR3:=2*(VAR1-VAR2);
STICKLINE(VAR3<ref(VAR3,1) and VAR3>0,0,VAR3,4,1),COLORYELLOW;
STICKLINE(VAR3>=ref(VAR3,1)and VAR3>0,0,VAR3,4,1),COLORRED;
STICKLINE(VAR3>ref(VAR3,1)and VAR3<0,0,VAR3,4,1),COLORFFC8FF;
STICKLINE(VAR3<=ref(VAR3,1)and VAR3<0,0,VAR3,4,1),COLORFFCC66;
趋势:EMA(CLOSE,12)-EMA(CLOSE,26),COLORWHITE;
长趋势:EMA(VAR1,50),COLORYELLOW;
{简单基本面信息}
流通盘大小:=FINANCE2(37)/1000000*100;
销售毛利率:=FINANCE2(12);
净利润同比增长:=FINANCE2(10);
DRAWTEXTABS(10,120,'流通盘大小:'+流通盘大小+'亿 '),LINETHICK1,colorwhite;
DRAWTEXTABS(150,120,'销售毛利率:'+销售毛利率+'% '),LINETHICK1,colorwhite;
DRAWTEXTABS(280,120,'净利润同比增长:'+净利润同比增长+'% '),LINETHICK1,colorwhite;
当日换手率:=sum(100*v/capital,1);
DRAWTEXTABS(440,120,'当日换手率: '+NUMTOSTRN(当日换手率,2)+'%'),colorwhite,LINETHICK1;
五日换手率:=sum(100*v/capital,5);
DRAWTEXTABS(560,120,'五日换手率: '+NUMTOSTRN(五日换手率,2)+'%'),colorwhite,LINETHICK1;
金叉:=barslast(FILTER(CROSS("KD.K","KD.D") and "KD.D"<30,13));
主力吸筹区:=if(金叉>0 and 金叉<61,金叉,0);
DRAWTEXTREL(10,15,STKLABEL+' '+STKNAME),LINETHICK2,Color00FF05;
DRAWTEXTREL(120,20,'主力建仓天数:'+NUMTOSTRN(主力吸筹区,0)+'天'),Color00FF05,LINETHICK2;
{次日短线支撑:=(IF((INDEXC > 200),VAR2HGG,XHH) - INDEXL);
次日短线阻力:=(INDEXC - 次日短线支撑);
VAR193:=(INDEXC + 次日短线支撑);};

大智慧主力吸筹换手指标公式

 

相关文章