在线检测未来函数

通达信变色数字轨道主图指标公式

来源:Internet,编辑:股旁网,2012-09-05

1.股票强弱会自动随趋势变色,有利于判断多空。 2.轨道右边有数字显示,方便您看到压力或支撑位价格。 3.运用市盈率和净资产的关系,可以计算未来股价上升的空间,主图有显示数据。

净资产:FINANCE(34),NODRAW,COLORFF00FF;
每股收益:FINANCE(33),NODRAW,COLORFF7F50;
市盈率:DYNAINFO(39),NODRAW,COLORFF00FF;
流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上轨:(1+7/100)*DD,COLORGREEN;
下轨:(1-7/100)*DD,COLORGREEN;
中轨:(上轨+下轨)/2,COLORGREEN;
疯狂:(1+14/100)*DD,COLORRED,POINTDOT;
抄底:(1-14/100)*DD,COLORCDFF99,POINTDOT;
DRAWNUMBER(ISLASTBAR,上轨,上轨),COLOR00FFFF;
DRAWNUMBER(ISLASTBAR,下轨,下轨),COLORFFFF00;
DRAWNUMBER(ISLASTBAR,中轨,中轨),COLOR00FF00;
DRAWNUMBER(ISLASTBAR,疯狂,疯狂),COLOR0000FF;
DRAWNUMBER(ISLASTBAR,抄底,抄底),COLORWHITE;
上轨红:IF(上轨>=REF(上轨,1),上轨,DRAWNULL),COLORRED,LINETHICK1;
中轨红:IF(中轨>=REF(中轨,1), 中轨,DRAWNULL),COLORRED, LINETHICK1;
下轨红:IF(下轨>=REF(下轨,1), 下轨,DRAWNULL),COLORRED,LINETHICK1;
{中期临界点90:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),CIRCLEDOT,COLORGRAY;}
{年:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL),CIRCLEDOT,COLORGRAY;}
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
涨停:=IF(REF(C,1)*1.095-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORYELLOW;
DRAWTEXT(涨停,L-0.1,'涨停'),COLORYELLOW;
C3:=REF(C,1);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORBLUE;
DRAWTEXT(跌停,H+0.3,'跌停'),COLORBLUE;
{www.gupang.com 股旁网_通达信股票指标公式}
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
{AMA2:EMA(DMA(CLOSE,CQ2),2),COLORLIBLUE,LINETHICK2;}
{无穷均线:DMA(CLOSE,(VOL)/(CAPITAL)),LINETHICK1,COLORFF00FF;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE>=OPEN),CLOSE,OPEN,3,0),COLORRED;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE>=OPEN),HIGH,LOW,0,0),COLORRED;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE<OPEN),CLOSE,OPEN,3,1),COLORRED;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE<OPEN),OPEN,HIGH,0,0),COLORRED;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE<OPEN),CLOSE,LOW,0,0),COLORRED;}
{STICKLINE((CLOSE<中轨) AND (CLOSE>OPEN),CLOSE,OPEN,3,1),COLORGREEN;}
{STICKLINE((CLOSE<中轨) AND (CLOSE<=OPEN),CLOSE,OPEN,0,1),COLORGREEN;}
{STICKLINE((CLOSE<中轨) AND (CLOSE<=OPEN),HIGH,LOW,3,1),COLORGREEN;}
{STICKLINE((CLOSE<中轨) AND (CLOSE>OPEN),CLOSE,HIGH,0,1),COLORGREEN;}
{STICKLINE((CLOSE<中轨) AND (CLOSE>OPEN),OPEN,LOW,0,1),COLORGREEN;};

通达信变色数字轨道主图指标公式

 

相关文章