在线检测未来函数

通达信众赢白黄蓝绿指标公式

来源:Internet,编辑:股旁网,2012-09-06

MA3:MA(CLOSE,3),COLORWHITE;
MA5:MA(CLOSE,5),COLORYELLOW;
MA10:MA(CLOSE,10),COLORRED;
MA20:MA(CLOSE,20),COLORBLUE;
MA30:MA(CLOSE,30),COLORGREEN;
MA60:MA(CLOSE,60),COLORMAGENTA,POINTDOT,LINETHICK2;
VAR1:=EMA(CLOSE,3);
VAR2:=EMA(CLOSE,5);
VAR3:=EMA(CLOSE,10);
VAR4:=EMA(CLOSE,20);
VAR5:=EMA(CLOSE,30);
VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;
VAR7:=(VAR6-REF(VAR6,15))/REF(VAR6,15)*100;
VAR8:=(VAR6-REF(VAR6,15))/REF(VAR6, 15)*100;
VAR9:=EMA(VAR7,8);
STICKLINE(VAR7<1*REF(VAR7,1),HIGH,LOW,0,0),COLORGREEN;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,2.5, 0),COLOR006000;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,1.9, 0),COLOR007500;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,1.4, 0),COLOR009100;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,1, 0),COLOR00A600;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,0.7, 0),COLOR00BB00;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,0.4, 0),COLOR00CC00;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,0.1, 0),COLORGREEN;
STICKLINE(VAR7>1*REF(VAR7,1),HIGH,LOW,0,0),COLORRED;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,2.5, 0),COLOR000055;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,1.9, 0),COLOR000077;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,1.3, 0),COLOR000099;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,0.7, 0),COLOR0000DD;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,0.2, 0),COLOR0000FF;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),HIGH,LOW,0,0),COLORBLUE;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,2.5, 0),COLORA12100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,1.9, 0),COLORB72100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,1.4, 0),COLORC32100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,1, 0),COLORCF2100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,0.6, 0),COLORDB2100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,0.3, 0),COLORFF5E00;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,0.1, 0),COLORFF6E00;
{www.gupang.com 股旁网_通达信股票指标公式}
买进价:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;
买进条件:=CROSS(CLOSE,买进价) AND 买进价>REF(买进价,1);
STICKLINE(买进条件,HIGH,LOW,0,1),COLORWHITE,LINETHICK2;
STICKLINE(买进条件,OPEN,CLOSE,2.8,0),COLOR808080;
STICKLINE(买进条件,OPEN,CLOSE,2.5,0),COLOR919890;
STICKLINE(买进条件,OPEN,CLOSE,2.2,0),COLORB4B5AF;
STICKLINE(买进条件,OPEN,CLOSE,1.7,0),COLORCCCCCC;
STICKLINE(买进条件,OPEN,CLOSE,1.2,0),COLORDDDDDD;
STICKLINE(买进条件,OPEN,CLOSE,0.8,0),COLOREEEEEE;
STICKLINE(买进条件,OPEN,CLOSE,0.4,0),COLORF5F1F1;
STICKLINE(买进条件,OPEN,CLOSE,0.1,0),COLORFFFAFA;
加码价:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
加码条件:=CROSS(CLOSE,加码价) AND 加码价>REF(加码价,1);
STICKLINE(加码条件,HIGH,LOW,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(加码条件,OPEN,CLOSE,2.5,0),COLOR0033FF;
STICKLINE(加码条件,OPEN,CLOSE,2.1,0),COLOR00BEFF;
STICKLINE(加码条件,OPEN,CLOSE,1.7,0),COLOR13BCFF;
STICKLINE(加码条件,OPEN,CLOSE,1.3,0),COLOR13D1FF;
STICKLINE(加码条件,OPEN,CLOSE,0.9,0),COLOR00D6FF;
STICKLINE(加码条件,OPEN,CLOSE,0.4,0),COLOR13E5FF;
STICKLINE(加码条件,OPEN,CLOSE,0,0),COLOR00F6FC;

通达信众赢白黄蓝绿指标公式

 

相关文章