在线检测未来函数

智策多空警戒线指标

来源:Internet,编辑:股旁网,2012-09-18

编写要求:

VAR0:=(CLOSE - LLV(LOW,32)) / (HHV(HIGH,32) - LLV(LOW,32)) * CLOSE; VAR1:=EMA(VAR0,3); VAR3:=EMA(VAR0,7); HH:=HHV(VAR3,64); LL:=LLV(VAR3,64); VARHIGH:=IF(VAR1>=REF(HH,1),H,REF(H,BARSLAST(VAR1>=REF(HH,1)))); VARLOW:=IF(VAR1<=REF(LL,1),L,REF(L,BARSLAST(VAR1<=REF(LL,1)))); B1:PARTLINE(VARHIGH=REF(VARHIGH,1),VARHIGH),NOTDRAWTEXT,COLORRED,0,2; B2:PARTLINE(VARLOW=REF(VARLOW,1),VARLOW),NOTDRAWTEXT,COLORGREEN,0,2; B3:MA(C,21),NOTDRAWTEXT,RGB(255,0,255); 这是源码,请哪位老师改成通达信的

股旁网解答:

 VAR0:=(CLOSE - LLV(LOW,32)) / (HHV(HIGH,32) - LLV(LOW,32)) * CLOSE;

VAR1:=EMA(VAR0,3);
VAR3:=EMA(VAR0,7);
HH:=HHV(VAR3,64);
LL:=LLV(VAR3,64);
VARHIGH:=IF(VAR1>=REF(HH,1),H,REF(H,BARSLAST(VAR1>=REF(HH,1))));
VARLOW:=IF(VAR1<=REF(LL,1),L,REF(L,BARSLAST(VAR1<=REF(LL,1))));
B1:REFX(IF(VARHIGH=REF(VARHIGH,1),VARHIGH,DRAWNULL),1),COLORRED;
B2:REFX(IF(VARLOW=REF(VARLOW,1),VARLOW,DRAWNULL),1),COLORGREEN;
B3:MA(C,21),COLORFF00FF;
 
 

相关文章