在线检测未来函数

飞狐DMICD指标公式

来源:Internet,编辑:股旁网,2012-10-16

input:p(14,2,100),m(6,1,100);
TRr := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),P);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),P);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),P);
PDI:= DMP*100/TRr;
MDI:= DMM*100/TRr;
0,colorgreen;
//20,colorred;
//-20,colorred;
ADX6: MA((pdi-mdi)/(MDI+PDI)*100,m),colorwhite,linethick1;
{ Gupang.com 股-旁-网_飞狐股票指标公式}
ADX12: MA((pdi-mdi)/(MDI+PDI)*100,m*2),coloryellow,linethick1;
ADX26:= MA((pdi-mdi)/(MDI+PDI)*100,m*2.5),colorcyan,linethick1;
fillrgn(adx6>=adx12,adx6,adx12),color3333cc;
fillrgn(adx6<adx12,adx6,adx12),color66cc00;
mpdi:ema(pdi,6),colorred;
mmdi:-ema(mdi,6),colorred;
DIFF := adx6 - adx26;
DEA := EMA(DIFF,5);
adxCD : 2*(DIFF-DEA), COLORSTICK;

飞狐DMICD指标公式

 

相关文章