在线检测未来函数

通达信短线红绿买卖指标公式

来源:Internet,编辑:股旁网,2012-10-16

TTJ:=200;TNB:=7;TNS:=7;
VR1:=0.1;
VR2:=0.1;
{0,COLORWHITE;}
CS1:=(2*CLOSE+HIGH+LOW)/4*(VR1+0.001);
CS2:=EMA(CS1,4)*(VR2);
CS3:=EMA(CS2,4);
CS4:=EMA(CS3,4);
JS0:=(CS4-REF(CS4,1))/REF(CS4,1)*100*(VR2);
短波0:=JS0;
JS1:=MA(JS0,2);
短波1:=JS1;
JS2:=MA(JS0,1);
短波2:=JS2;
红实波:=JS0>=0 AND JS0>REF(JS0,1),COLORRED;
红空波:=JS0>=0 AND JS0<=REF(JS0,1),COLORLIRED;
绿波:=JS0<0 AND JS1>=JS2,COLORGREEN,NODRAW;
蓝波:=JS0<0 AND JS1<=JS2,COLORBLUE,NODRAW;
X1:=0.0;
Y1:=0.00;
DQ1:=0; {0左对齐,1右对齐}
JJ1:=0.05; {间距}
涨:=短波0>REF(短波0,1);
跌:=短波0<REF(短波0,1);
红涨:=红实波;
连涨:=BARSLAST(短波0>REF(短波0,1) AND REF(短波0,1)<REF(短波0,2))*涨+1*涨,COLORRED;
连跌:=BARSLAST(短波0<REF(短波0,1) AND REF(短波0,1)>REF(短波0,2))*跌+1*跌,COLORGREEN,NODRAW;
红连涨:=BARSLAST(红实波 AND REF(红实波,1)=0)*红涨+1*红涨,COLORFF00FF;
买:=CROSS(短波0,REF(短波0,1));
卖:=CROSS(-短波0,-REF(短波0,1));
红卖:=CROSS(-短波0,-REF(短波0,1)) AND 红空波;
连涨N:=IF(卖=1,REF(连涨,1),0);
连跌N:=IF(买=1,REF(连跌,1),0);
红连涨N:=IF(红卖=1,REF(红连涨,1),0);
{ Gupang.com 股-旁-网_通达信股票指标公式}
连涨0:=IF(连涨>0,连涨,DRAWNULL),COLORRED,CIRCLEDOT;
连跌0:=IF(连跌>0,-连跌,DRAWNULL),COLORGREEN,CIRCLEDOT;
红连涨0:=IF(红连涨>0,红连涨,DRAWNULL),COLORFF00FF,CIRCLEDOT,LINETHICK2;
IF(连涨>0,连涨,DRAWNULL),COLORRED,CIRCLEDOT;
IF(连跌>0,-连跌,DRAWNULL),COLORGREEN,CIRCLEDOT;
IF(红连涨>0,红连涨,DRAWNULL),COLORFF00FF,CIRCLEDOT,LINETHICK2;
久跌买:=连跌>=TNB AND C/REF(C,1)>1 ;
STICKLINE(久跌买 AND COUNT(久跌买,TNB)=1,0,连跌0,1,0),COLORRED;{蓝柱达到TN1天买入提示};
DRAWTEXT(久跌买 AND COUNT(久跌买,TNB)=1,连跌0,' 注意买'),COLORRED;
DRAWTEXT(久跌买 AND COUNT(久跌买,TNB)=1 AND C>MA(C,20) AND C>DKX,连跌0+2,' 很准'),COLORMAGENTA;
久涨抛:=连涨>=TNS AND C/REF(C,1)<1.01;
STICKLINE(久涨抛 AND COUNT(久涨抛,TNS)=1,0,连涨,1,0),COLORGREEN;{红柱达到TN1天卖出提示};
DRAWTEXT(久涨抛 AND COUNT(久涨抛,TNS)=1,连涨-1,' 注意卖'),COLORGREEN;
买强:=连涨-红连涨<=1 AND 红连涨=1 AND (REF(连跌,1)>=3 OR REF(连跌,2)>=3) AND L/DKX<1.03;
STICKLINE(买强,0,2,1,0),COLORMAGENTA;
DRAWTEXT(买强 ,1,' 快速买'),COLORMAGENTA;
获利了结0:=(BARSLAST(买强=1)<=4 AND BARSLAST(买强=1)>2 AND H/DKX>1.08)
OR (BARSLAST(买强=1)<=4 AND 连跌=1) ;
获利了结1:=EXIST(获利了结0,5)=0 AND BARSLAST(买强=1)=5;
STICKLINE(获利了结0 OR 获利了结1,0,-2,1,0),COLORGREEN;
DRAWTEXT(获利了结0 OR 获利了结1 ,-2,' 快速卖'),COLORGREEN;

通达信短线红绿买卖指标公式

 

相关文章